Merge in perpetuated testsuite patches.
This commit is contained in:
parent
7bf686ca3f
commit
00cf53144c
22
gdb-6.3-rh-dummykfail-20041202.patch
Normal file
22
gdb-6.3-rh-dummykfail-20041202.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
2003-07-11 Elena Zannoni <ezannoni@redhat.com>
|
||||||
|
|
||||||
|
* lib/gdb.exp (setup_kfail, kfail): Redefine procedures.
|
||||||
|
|
||||||
|
--- ./gdb/testsuite/lib/gdb.exp.1 2004-11-24 15:59:46.131394720 -0500
|
||||||
|
+++ ./gdb/testsuite/lib/gdb.exp 2004-11-24 16:01:06.304206600 -0500
|
||||||
|
@@ -63,6 +63,15 @@
|
||||||
|
|
||||||
|
### Only procedures should come after this point.
|
||||||
|
|
||||||
|
+if {![llength [info procs kfail]]} {
|
||||||
|
+ proc setup_kfail { args } {
|
||||||
|
+ #setup_xfail args
|
||||||
|
+ }
|
||||||
|
+ proc kfail { bugid message } {
|
||||||
|
+ fail $message
|
||||||
|
+ }
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
#
|
||||||
|
# gdb_version -- extract and print the version number of GDB
|
||||||
|
#
|
17
gdb-6.3-rh-testversion-20041202.patch
Normal file
17
gdb-6.3-rh-testversion-20041202.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
2003-02-24 Elena Zannoni <ezannoni@redhat.com>
|
||||||
|
|
||||||
|
* gdb.gdb/selftest.exp: Add matching on specific Red Hat only version
|
||||||
|
string.
|
||||||
|
|
||||||
|
--- ./gdb/testsuite/gdb.gdb/selftest.exp.1 Fri Jul 11 09:44:09 2003
|
||||||
|
+++ ./gdb/testsuite/gdb.gdb/selftest.exp Fri Jul 11 09:44:16 2003
|
||||||
|
@@ -314,7 +314,10 @@ proc test_with_self { executable } {
|
||||||
|
-re ".\[0-9\]+ = +.+ +0x.*\[0-9.\]+.*$gdb_prompt $" {
|
||||||
|
pass "printed version with cast"
|
||||||
|
}
|
||||||
|
+ -re ".\[0-9\]+ = .Red Hat Linux \[\\(\\)0-9.a-z\\-\]+.*$gdb_prompt $" {
|
||||||
|
+ pass "printed version Red Had Linux only"
|
||||||
|
+ }
|
||||||
|
-re ".*$gdb_prompt $" { fail "printed version" }
|
||||||
|
timeout { fail "(timeout) printed version" }
|
||||||
|
}
|
24
gdb.spec
24
gdb.spec
@ -26,14 +26,18 @@ URL: http://gnu.org/software/gdb/
|
|||||||
Obsoletes: gdb64
|
Obsoletes: gdb64
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# GDB patches have the format gdb-<version>-<desc>-<YYYYMMDD>.patch;
|
||||||
|
# should include the ChangeLog.RedHat change-log entry; and should be
|
||||||
|
# created using diff -u ./gdb (not gdb-6.3/gdb).
|
||||||
|
|
||||||
# Red Hat local patches
|
# Red Hat local patches
|
||||||
|
|
||||||
# Create empty ChangeLog.RedHat files in all relevant directories.
|
# Create empty ChangeLog.RedHat files in all relevant directories.
|
||||||
Patch0: gdb-6.3-rh-changelogs-20041202.patch
|
Patch0: gdb-6.3-rh-changelogs-20041202.patch
|
||||||
|
# Work around out-of-date dejagnu that does not have KFAIL
|
||||||
# GDB patches have the format gdb-<version>-<desc>-<YYYYMMDD>.patch;
|
Patch1: gdb-6.3-rh-dummykfail-20041202.patch
|
||||||
# should include the ChangeLog.RedHat change-log entry; and should be
|
# Match Red Hat's version info
|
||||||
# created using diff -u ./gdb (not gdb-6.3/gdb).
|
Patch2: gdb-6.3-rh-testversion-20041202.patch
|
||||||
|
|
||||||
|
|
||||||
# ------------------------------------------
|
# ------------------------------------------
|
||||||
@ -42,8 +46,6 @@ Patch0: gdb-6.3-rh-changelogs-20041202.patch
|
|||||||
#N/A: Patch0: gdb-6.1post-ChangeLog.patch
|
#N/A: Patch0: gdb-6.1post-ChangeLog.patch
|
||||||
# ChangeLogs patches for doc.
|
# ChangeLogs patches for doc.
|
||||||
#N/A: Patch2: gdb-6.1post-ChangeLog-doc.patch
|
#N/A: Patch2: gdb-6.1post-ChangeLog-doc.patch
|
||||||
####### start patches from the previous RPM.
|
|
||||||
# Silence gcc warnings.
|
|
||||||
|
|
||||||
####### end patches from the previous RPM.
|
####### end patches from the previous RPM.
|
||||||
|
|
||||||
@ -84,10 +86,6 @@ Patch28: gdb-6.1post-abi-ppc64section-oct2004.patch
|
|||||||
Patch29: broken.patch
|
Patch29: broken.patch
|
||||||
|
|
||||||
###### Testsuite merge, fixes, and local RH hack
|
###### Testsuite merge, fixes, and local RH hack
|
||||||
# Work around out-of-date dejagnu that does not have kfail
|
|
||||||
Patch31: gdb-6.1post-test-rh-kfail.patch
|
|
||||||
# Match Red Hat version info
|
|
||||||
Patch32: gdb-6.1post-test-rh-version.patch
|
|
||||||
# Get selftest working with sep-debug-info
|
# Get selftest working with sep-debug-info
|
||||||
#Patch33: gdb-6.1post-test-self-jul2004.patch
|
#Patch33: gdb-6.1post-test-self-jul2004.patch
|
||||||
Patch33: broken.patch
|
Patch33: broken.patch
|
||||||
@ -191,10 +189,10 @@ and printing their data.
|
|||||||
# Apply patches defined above.
|
# Apply patches defined above.
|
||||||
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
# Apply patches defined above.
|
# Apply patches defined above.
|
||||||
#%patch0 -p1
|
|
||||||
#%patch2 -p1
|
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
@ -214,8 +212,6 @@ and printing their data.
|
|||||||
%patch28 -p1
|
%patch28 -p1
|
||||||
%patch29 -p1
|
%patch29 -p1
|
||||||
|
|
||||||
%patch31 -p1
|
|
||||||
%patch32 -p1
|
|
||||||
%patch33 -p1
|
%patch33 -p1
|
||||||
%patch34 -p1
|
%patch34 -p1
|
||||||
%patch35 -p1
|
%patch35 -p1
|
||||||
|
Loading…
Reference in New Issue
Block a user