Fixed AALineThick.patch to display vertical lines correctly
Resolves: #798255
This commit is contained in:
parent
b8518cbc01
commit
c41d61076a
@ -1,5 +1,6 @@
|
|||||||
--- gd-2.0.35/gd.c.pom 2007-06-19 22:25:51.000000000 +0200
|
diff -up gd-2.0.35/gd.c.AALineThick gd-2.0.35/gd.c
|
||||||
+++ gd-2.0.35/gd.c 2007-09-05 11:25:16.000000000 +0200
|
--- gd-2.0.35/gd.c.AALineThick 2007-06-19 22:25:51.000000000 +0200
|
||||||
|
+++ gd-2.0.35/gd.c 2012-02-28 11:02:09.708015922 +0100
|
||||||
@@ -3474,6 +3474,8 @@ static void gdImageAALine (gdImagePtr im
|
@@ -3474,6 +3474,8 @@ static void gdImageAALine (gdImagePtr im
|
||||||
/* keep them as 32bits */
|
/* keep them as 32bits */
|
||||||
long x, y, inc;
|
long x, y, inc;
|
||||||
@ -15,13 +16,13 @@
|
|||||||
}
|
}
|
||||||
+ else {
|
+ else {
|
||||||
+ double ag;
|
+ double ag;
|
||||||
+ if (dy < dx)
|
+ if (abs(dy) < abs(dx))
|
||||||
+ ag = cos (atan2 (dy, dx));
|
+ ag = cos (atan2 (dy, dx));
|
||||||
+ else
|
+ else
|
||||||
+ ag = sin (atan2 (dy, dx));
|
+ ag = sin (atan2 (dy, dx));
|
||||||
+ if (ag != 0)
|
+ if (ag != 0)
|
||||||
+ {
|
+ {
|
||||||
+ wid = thick / ag;
|
+ wid = abs(thick / ag);
|
||||||
+ }
|
+ }
|
||||||
+ else
|
+ else
|
||||||
+ {
|
+ {
|
||||||
|
6
gd.spec
6
gd.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A graphics library for quick creation of PNG or JPEG images
|
Summary: A graphics library for quick creation of PNG or JPEG images
|
||||||
Name: gd
|
Name: gd
|
||||||
Version: 2.0.35
|
Version: 2.0.35
|
||||||
Release: 13%{?dist}
|
Release: 14%{?dist}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.libgd.org/Main_Page
|
URL: http://www.libgd.org/Main_Page
|
||||||
@ -99,6 +99,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/pkgconfig/gdlib.pc
|
%{_libdir}/pkgconfig/gdlib.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 28 2012 Honza Horak <hhorak@redhat.com> - 2.0.35-14
|
||||||
|
- Fixed AALineThick.patch to display vertical lines correctly
|
||||||
|
Resolves: #798255
|
||||||
|
|
||||||
* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.35-13
|
* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.35-13
|
||||||
- Rebuilt for glibc bug#747377
|
- Rebuilt for glibc bug#747377
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user