fix license tag
This commit is contained in:
parent
db8e7ca84e
commit
7b70eabfbe
@ -1,10 +1,11 @@
|
|||||||
--- gd-2.0.33/gd_gif_in.c.loop 2004-11-01 19:28:56.000000000 +0100
|
diff -up gd-2.0.35/gd_gif_in.c.loop gd-2.0.35/gd_gif_in.c
|
||||||
+++ gd-2.0.33/gd_gif_in.c 2006-07-10 14:59:42.000000000 +0200
|
--- gd-2.0.35/gd_gif_in.c.loop 2007-06-14 15:51:41.000000000 -0400
|
||||||
@@ -418,16 +418,17 @@
|
+++ gd-2.0.35/gd_gif_in.c 2008-07-21 11:20:25.000000000 -0400
|
||||||
return firstcode;
|
@@ -453,16 +453,17 @@ LWZReadByte_(gdIOCtx *fd, LZW_STATIC_DAT
|
||||||
} else if (code == end_code) {
|
return sd->firstcode;
|
||||||
|
} else if (code == sd->end_code) {
|
||||||
int count;
|
int count;
|
||||||
+ int max_count = 1024;
|
+ int max_count = 1024;
|
||||||
unsigned char buf[260];
|
unsigned char buf[260];
|
||||||
|
|
||||||
if (*ZeroDataBlockP)
|
if (*ZeroDataBlockP)
|
||||||
@ -17,7 +18,7 @@
|
|||||||
- if (count != 0)
|
- if (count != 0)
|
||||||
- return -2;
|
- return -2;
|
||||||
+ if (count != 0 || max_count < 0 )
|
+ if (count != 0 || max_count < 0 )
|
||||||
+ return -2;
|
+ return -2;
|
||||||
}
|
}
|
||||||
|
|
||||||
incode = code;
|
incode = code;
|
||||||
|
7
gd.spec
7
gd.spec
@ -1,9 +1,9 @@
|
|||||||
Summary: A graphics library for quick creation of PNG or JPEG images
|
Summary: A graphics library for quick creation of PNG or JPEG images
|
||||||
Name: gd
|
Name: gd
|
||||||
Version: 2.0.35
|
Version: 2.0.35
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: MIT and GPL
|
License: MIT
|
||||||
URL: http://www.libgd.org/Main_Page
|
URL: http://www.libgd.org/Main_Page
|
||||||
Source0: http://www.libgd.org/releases/%{name}-%{version}.tar.bz2
|
Source0: http://www.libgd.org/releases/%{name}-%{version}.tar.bz2
|
||||||
Patch0: gd-2.0.33-freetype.patch
|
Patch0: gd-2.0.33-freetype.patch
|
||||||
@ -97,6 +97,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/pkgconfig/gdlib.pc
|
%{_libdir}/pkgconfig/gdlib.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 21 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.35-6
|
||||||
|
- fix license tag (nothing in this is GPL)
|
||||||
|
|
||||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.35-5
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.35-5
|
||||||
- Autorebuild for GCC 4.3
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user