- drop uneeded patch
- really set default font search path
This commit is contained in:
parent
d960c3c224
commit
3b3b1f1ef2
@ -1,13 +0,0 @@
|
|||||||
--- gd-2.0.33/configure.freetype 2005-09-07 17:16:03.000000000 +0200
|
|
||||||
+++ gd-2.0.33/configure 2005-09-07 17:16:54.000000000 +0200
|
|
||||||
@@ -11705,8 +11705,8 @@
|
|
||||||
else
|
|
||||||
libft_INCLUDES=`$FREETYPE_CONFIG --cflags`
|
|
||||||
fi
|
|
||||||
- libft_LDFLAGS=`$FREETYPE_CONFIG --libs`
|
|
||||||
- libft_LDFLAGS=`echo " $libft_LDFLAGS" |sed 's/ -l[^ ][^ ]*//g'`
|
|
||||||
+ # Hack to ingore the broken freetype config --libs flags
|
|
||||||
+ libft_LDFLAGS=""
|
|
||||||
else
|
|
||||||
if test -n "$FREETYPE_DIR"; then
|
|
||||||
libft_INCLUDES="-I$FREETYPE_DIR/include/freetype2 -I$FREETYPE_DIR/include"
|
|
@ -1,11 +0,0 @@
|
|||||||
--- gd-2.0.34/Makefile.in.pom 2007-09-04 15:08:18.000000000 +0200
|
|
||||||
+++ gd-2.0.34/Makefile.in 2007-09-04 15:58:05.000000000 +0200
|
|
||||||
@@ -227,7 +227,7 @@ AUTOMAKE = @AUTOMAKE@
|
|
||||||
AWK = @AWK@
|
|
||||||
CC = @CC@
|
|
||||||
CCDEPMODE = @CCDEPMODE@
|
|
||||||
-CFLAGS = @CFLAGS@
|
|
||||||
+CFLAGS = @CFLAGS@ -D_DEFAULT_FONTPATH="/usr/share/X11/fonts/TTF/:/usr/share/fonts/bitstream-vera/:/usr/share/fonts/dejavu-lgc/:/usr/share/fonts/default/Type1/:/usr/share/X11/fonts/Type1:/usr/share/fonts/liberation/"
|
|
||||||
CPP = @CPP@
|
|
||||||
CPPFLAGS = @CPPFLAGS@
|
|
||||||
CXX = @CXX@
|
|
20
gd.spec
20
gd.spec
@ -1,19 +1,17 @@
|
|||||||
Summary: A graphics library for quick creation of PNG or JPEG images
|
Summary: A graphics library for quick creation of PNG or JPEG images
|
||||||
Name: gd
|
Name: gd
|
||||||
Version: 2.0.35
|
Version: 2.0.35
|
||||||
Release: 24%{?dist}
|
Release: 25%{?dist}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.libgd.org/Main_Page
|
URL: http://www.libgd.org/Main_Page
|
||||||
Source0: http://www.libgd.org/releases/%{name}-%{version}.tar.bz2
|
Source0: http://www.libgd.org/releases/%{name}-%{version}.tar.bz2
|
||||||
Patch0: gd-2.0.33-freetype.patch
|
|
||||||
Patch3: gd-2.0.34-multilib.patch
|
Patch3: gd-2.0.34-multilib.patch
|
||||||
Patch4: gd-loop.patch
|
Patch4: gd-loop.patch
|
||||||
Patch5: gd-2.0.34-sparc64.patch
|
Patch5: gd-2.0.34-sparc64.patch
|
||||||
Patch6: gd-2.0.35-overflow.patch
|
Patch6: gd-2.0.35-overflow.patch
|
||||||
Patch7: gd-2.0.35-AALineThick.patch
|
Patch7: gd-2.0.35-AALineThick.patch
|
||||||
Patch8: gd-2.0.33-BoxBound.patch
|
Patch8: gd-2.0.33-BoxBound.patch
|
||||||
Patch9: gd-2.0.34-fonts.patch
|
|
||||||
Patch10: gd-2.0.35-time.patch
|
Patch10: gd-2.0.35-time.patch
|
||||||
Patch11: gd-2.0.35-security3.patch
|
Patch11: gd-2.0.35-security3.patch
|
||||||
Patch12: gd-2.0.35-runtests.patch
|
Patch12: gd-2.0.35-runtests.patch
|
||||||
@ -60,14 +58,12 @@ files for gd, a graphics library for creating PNG and JPEG graphics.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .freetype
|
|
||||||
%patch3 -p1 -b .mlib
|
%patch3 -p1 -b .mlib
|
||||||
%patch4 -p1 -b .loop
|
%patch4 -p1 -b .loop
|
||||||
%patch6 -p1 -b .overflow
|
%patch6 -p1 -b .overflow
|
||||||
%patch5 -p1 -b .sparc64
|
%patch5 -p1 -b .sparc64
|
||||||
%patch7 -p1 -b .AALineThick
|
%patch7 -p1 -b .AALineThick
|
||||||
%patch8 -p1 -b .bb
|
%patch8 -p1 -b .bb
|
||||||
%patch9 -p1 -b .fonts
|
|
||||||
%patch10 -p1 -b .time
|
%patch10 -p1 -b .time
|
||||||
%patch11 -p1 -b .sec3
|
%patch11 -p1 -b .sec3
|
||||||
%patch12 -p1 -b .runtests
|
%patch12 -p1 -b .runtests
|
||||||
@ -78,6 +74,14 @@ files for gd, a graphics library for creating PNG and JPEG graphics.
|
|||||||
%patch17 -p1 -b .aarch64
|
%patch17 -p1 -b .aarch64
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
# Provide a correct default font search path
|
||||||
|
CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
|
||||||
|
/usr/share/fonts/bitstream-vera:\
|
||||||
|
/usr/share/fonts/dejavu:\
|
||||||
|
/usr/share/fonts/default/Type1:\
|
||||||
|
/usr/share/X11/fonts/Type1:\
|
||||||
|
/usr/share/fonts/liberation\"'"
|
||||||
|
|
||||||
%configure --disable-rpath
|
%configure --disable-rpath
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -119,6 +123,10 @@ popd
|
|||||||
%{_libdir}/pkgconfig/gdlib.pc
|
%{_libdir}/pkgconfig/gdlib.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 23 2013 Remi Collet <rcollet@redhat.com> - 2.0.35-25
|
||||||
|
- drop uneeded patch
|
||||||
|
- really set default font search path
|
||||||
|
|
||||||
* Mon Mar 25 2013 Honza Horak <hhorak@redhat.com> - 2.0.35-24
|
* Mon Mar 25 2013 Honza Horak <hhorak@redhat.com> - 2.0.35-24
|
||||||
- Fix build on aarch64
|
- Fix build on aarch64
|
||||||
|
|
||||||
@ -376,7 +384,7 @@ popd
|
|||||||
* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
|
* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||||
- update to 1.8.3
|
- update to 1.8.3
|
||||||
|
|
||||||
* Sat Jun 4 2000 Nalin Dahyabhai <nalin@redhat.com>
|
* Sun Jun 4 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||||
- rebuild in new environment
|
- rebuild in new environment
|
||||||
|
|
||||||
* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
|
* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
|
||||||
|
Loading…
Reference in New Issue
Block a user