add upstream patch for libvpx 1.4.0
This commit is contained in:
parent
10c3182448
commit
26f02f8ae8
37
gd-2.1.1-libvpx.patch
Normal file
37
gd-2.1.1-libvpx.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
From d41eb72cd4545c394578332e5c102dee69e02ee8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Remi Collet <fedora@famillecollet.com>
|
||||||
|
Date: Tue, 7 Apr 2015 13:11:03 +0200
|
||||||
|
Subject: [PATCH] Fix build with latest libvpx 1.4.0
|
||||||
|
|
||||||
|
These new constants exist at least since 1.0.0
|
||||||
|
Compatibility ones have been droped in 1.4.0
|
||||||
|
---
|
||||||
|
src/webpimg.c | 14 +++++++-------
|
||||||
|
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/webpimg.c b/src/webpimg.c
|
||||||
|
index cf73d64..e49fcc6 100644
|
||||||
|
--- a/src/webpimg.c
|
||||||
|
+++ b/src/webpimg.c
|
||||||
|
@@ -711,14 +711,14 @@ static WebPResult VPXEncode(const uint8* Y,
|
||||||
|
codec_ctl(&enc, VP8E_SET_STATIC_THRESHOLD, 0);
|
||||||
|
codec_ctl(&enc, VP8E_SET_TOKEN_PARTITIONS, 2);
|
||||||
|
|
||||||
|
- vpx_img_wrap(&img, IMG_FMT_I420,
|
||||||
|
+ vpx_img_wrap(&img, VPX_IMG_FMT_I420,
|
||||||
|
y_width, y_height, 16, (uint8*)(Y));
|
||||||
|
- img.planes[PLANE_Y] = (uint8*)(Y);
|
||||||
|
- img.planes[PLANE_U] = (uint8*)(U);
|
||||||
|
- img.planes[PLANE_V] = (uint8*)(V);
|
||||||
|
- img.stride[PLANE_Y] = y_stride;
|
||||||
|
- img.stride[PLANE_U] = uv_stride;
|
||||||
|
- img.stride[PLANE_V] = uv_stride;
|
||||||
|
+ img.planes[VPX_PLANE_Y] = (uint8*)(Y);
|
||||||
|
+ img.planes[VPX_PLANE_U] = (uint8*)(U);
|
||||||
|
+ img.planes[VPX_PLANE_V] = (uint8*)(V);
|
||||||
|
+ img.stride[VPX_PLANE_Y] = y_stride;
|
||||||
|
+ img.stride[VPX_PLANE_U] = uv_stride;
|
||||||
|
+ img.stride[VPX_PLANE_V] = uv_stride;
|
||||||
|
|
||||||
|
res = vpx_codec_encode(&enc, &img, 0, 1, 0, VPX_DL_BEST_QUALITY);
|
||||||
|
|
2
gd.spec
2
gd.spec
@ -20,6 +20,7 @@ Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}%{
|
|||||||
Source2: getver.pl
|
Source2: getver.pl
|
||||||
|
|
||||||
Patch1: gd-2.1.0-multilib.patch
|
Patch1: gd-2.1.0-multilib.patch
|
||||||
|
Patch2: gd-2.1.1-libvpx.patch
|
||||||
|
|
||||||
BuildRequires: freetype-devel
|
BuildRequires: freetype-devel
|
||||||
BuildRequires: fontconfig-devel
|
BuildRequires: fontconfig-devel
|
||||||
@ -77,6 +78,7 @@ files for gd, a graphics library for creating PNG and JPEG graphics.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n libgd-%{version}%{?prever:-%{prever}}
|
%setup -q -n libgd-%{version}%{?prever:-%{prever}}
|
||||||
%patch1 -p1 -b .mlib
|
%patch1 -p1 -b .mlib
|
||||||
|
%patch2 -p1 -b .vpx
|
||||||
|
|
||||||
# Workaround for missing file
|
# Workaround for missing file
|
||||||
cp %{SOURCE2} config/getver.pl
|
cp %{SOURCE2} config/getver.pl
|
||||||
|
Loading…
Reference in New Issue
Block a user