- update to 2.0.34
This commit is contained in:
parent
0a6d05fccd
commit
26aa9c0834
@ -1 +1 @@
|
|||||||
gd-2.0.33.tar.gz
|
gd-2.0.34.tar.bz2
|
||||||
|
112
gd-2.0.34-multilib.patch
Normal file
112
gd-2.0.34-multilib.patch
Normal file
@ -0,0 +1,112 @@
|
|||||||
|
--- gd-2.0.34/Makefile.in.pom 2007-02-03 02:41:46.000000000 +0100
|
||||||
|
+++ gd-2.0.34/Makefile.in 2007-02-08 13:34:06.000000000 +0100
|
||||||
|
@@ -341,6 +341,7 @@
|
||||||
|
ACLOCAL_AMFLAGS = -I config
|
||||||
|
SUBDIRS = config test
|
||||||
|
bin_SCRIPTS = bdftogd config/gdlib-config
|
||||||
|
+pkgconf_CFILE = config/gdlib.pc
|
||||||
|
EXTRA_DIST = README-JPEG.TXT README.TXT configure.pl bdftogd demoin.png err.out index.html install-item makefile.sample readme.jpn entities.html entities.tcl
|
||||||
|
include_HEADERS = gd.h gdfx.h gd_io.h gdcache.h gdfontg.h gdfontl.h gdfontmb.h gdfonts.h gdfontt.h entities.h
|
||||||
|
lib_LTLIBRARIES = libgd.la
|
||||||
|
@@ -553,6 +554,15 @@
|
||||||
|
rm -f "$(DESTDIR)$(bindir)/$$f"; \
|
||||||
|
done
|
||||||
|
|
||||||
|
+install-pkgconfigCF:
|
||||||
|
+ $(mkdir_p) "$(DESTDIR)$(libdir)/pkgconfig"
|
||||||
|
+ echo " cp $(pkgconf_CFILE) $(DESTDIR)$(libdir)/pkgconfig/gdlib.pc"
|
||||||
|
+ cp $(pkgconf_CFILE) $(DESTDIR)$(libdir)/pkgconfig/gdlib.pc
|
||||||
|
+
|
||||||
|
+uninstall-pkgconfigCF:
|
||||||
|
+ echo " rm $(DESTDIR)$(libdir)/pkgconfig/gdlib.pc"
|
||||||
|
+ rm $(DESTDIR)$(libdir)/pkgconfig/gdlib.pc
|
||||||
|
+
|
||||||
|
mostlyclean-compile:
|
||||||
|
-rm -f *.$(OBJEXT)
|
||||||
|
|
||||||
|
@@ -986,7 +996,7 @@
|
||||||
|
|
||||||
|
install-data-am: install-includeHEADERS
|
||||||
|
|
||||||
|
-install-exec-am: install-binPROGRAMS install-binSCRIPTS \
|
||||||
|
+install-exec-am: install-binPROGRAMS install-binSCRIPTS install-pkgconfigCF\
|
||||||
|
install-libLTLIBRARIES
|
||||||
|
|
||||||
|
install-info: install-info-recursive
|
||||||
|
@@ -1015,7 +1025,7 @@
|
||||||
|
|
||||||
|
ps-am:
|
||||||
|
|
||||||
|
-uninstall-am: uninstall-binPROGRAMS uninstall-binSCRIPTS \
|
||||||
|
+uninstall-am: uninstall-binPROGRAMS uninstall-binSCRIPTS uninstall-pkgconfigCF\
|
||||||
|
uninstall-includeHEADERS uninstall-info-am \
|
||||||
|
uninstall-libLTLIBRARIES
|
||||||
|
|
||||||
|
--- gd-2.0.34/config/gdlib.pc.in.pom 2007-02-08 13:29:04.000000000 +0100
|
||||||
|
+++ gd-2.0.34/config/gdlib.pc.in 2007-01-29 09:51:29.000000000 +0100
|
||||||
|
@@ -0,0 +1,14 @@
|
||||||
|
+prefix=@prefix@
|
||||||
|
+exec_prefix=@exec_prefix@
|
||||||
|
+libdir=@libdir@
|
||||||
|
+includedir=@includedir@
|
||||||
|
+bindir=@bindir@
|
||||||
|
+ldflags=@LDFLAGS@
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+Name: gd-devel
|
||||||
|
+Description: A graphics library for quick creation of PNG or JPEG images
|
||||||
|
+Version: @VERSION@
|
||||||
|
+Requires:
|
||||||
|
+Libs: @LIBS@
|
||||||
|
+Cflags: -I@includedir@
|
||||||
|
--- gd-2.0.34/config/gdlib-config.in.pom 2007-02-03 02:41:00.000000000 +0100
|
||||||
|
+++ gd-2.0.34/config/gdlib-config.in 2007-02-08 13:27:25.000000000 +0100
|
||||||
|
@@ -7,9 +7,10 @@
|
||||||
|
# installation directories
|
||||||
|
prefix=@prefix@
|
||||||
|
exec_prefix=@exec_prefix@
|
||||||
|
-libdir=@libdir@
|
||||||
|
+libdir=`pkg-config gdlib --variable=libdir`
|
||||||
|
includedir=@includedir@
|
||||||
|
bindir=@bindir@
|
||||||
|
+ldflags=`pkg-config gdlib --variable=ldflags`
|
||||||
|
|
||||||
|
usage()
|
||||||
|
{
|
||||||
|
@@ -68,7 +69,7 @@
|
||||||
|
echo @GDLIB_REVISION@
|
||||||
|
;;
|
||||||
|
--ldflags)
|
||||||
|
- echo @LDFLAGS@
|
||||||
|
+ echo $ldflags
|
||||||
|
;;
|
||||||
|
--libs)
|
||||||
|
echo @LIBS@ @LIBICONV@
|
||||||
|
@@ -83,7 +84,7 @@
|
||||||
|
echo "GD library @VERSION@"
|
||||||
|
echo "includedir: $includedir"
|
||||||
|
echo "cflags: -I@includedir@"
|
||||||
|
- echo "ldflags: @LDFLAGS@"
|
||||||
|
+ echo "ldflags: $ldflags"
|
||||||
|
echo "libs: @LIBS@ @LIBICONV@"
|
||||||
|
echo "libdir: $libdir"
|
||||||
|
echo "features: @FEATURES@"
|
||||||
|
--- gd-2.0.34/configure.pom 2007-02-08 13:25:00.000000000 +0100
|
||||||
|
+++ gd-2.0.34/configure 2007-02-08 13:31:53.000000000 +0100
|
||||||
|
@@ -24672,7 +24672,7 @@
|
||||||
|
Support for pthreads: $acx_pthread_ok
|
||||||
|
" >&6; }
|
||||||
|
|
||||||
|
-ac_config_files="$ac_config_files Makefile config/Makefile config/gdlib-config test/Makefile"
|
||||||
|
+ac_config_files="$ac_config_files Makefile config/Makefile config/gdlib-config config/gdlib.pc test/Makefile"
|
||||||
|
|
||||||
|
|
||||||
|
cat >confcache <<\_ACEOF
|
||||||
|
@@ -25257,6 +25257,7 @@
|
||||||
|
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
|
||||||
|
"config/Makefile") CONFIG_FILES="$CONFIG_FILES config/Makefile" ;;
|
||||||
|
"config/gdlib-config") CONFIG_FILES="$CONFIG_FILES config/gdlib-config" ;;
|
||||||
|
+ "config/gdlib.pc" ) CONFIG_FILES="$CONFIG_FILES config/gdlib.pc" ;;
|
||||||
|
"test/Makefile") CONFIG_FILES="$CONFIG_FILES test/Makefile" ;;
|
||||||
|
|
||||||
|
*) { { echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
|
13
gd-2.0.34-sparc64.patch
Normal file
13
gd-2.0.34-sparc64.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- gd-2.0.34/configure.sp 2007-02-08 13:44:32.000000000 +0100
|
||||||
|
+++ gd-2.0.34/configure 2007-02-08 13:50:39.000000000 +0100
|
||||||
|
@@ -9075,8 +9075,8 @@
|
||||||
|
|
||||||
|
*)
|
||||||
|
if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then
|
||||||
|
- archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
|
||||||
|
- archive_expsym_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
|
||||||
|
+ archive_cmds='$CC $CFLAGS -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
|
||||||
|
+ archive_expsym_cmds='$CC $CFLAGS -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
|
||||||
|
else
|
||||||
|
ld_shlibs=no
|
||||||
|
fi
|
24
gd.spec
24
gd.spec
@ -1,21 +1,18 @@
|
|||||||
Summary: A graphics library for quick creation of PNG or JPEG images
|
Summary: A graphics library for quick creation of PNG or JPEG images
|
||||||
Name: gd
|
Name: gd
|
||||||
Version: 2.0.33
|
Version: 2.0.34
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: BSD-style
|
License: BSD-style
|
||||||
URL: http://www.boutell.com/gd/
|
URL: http://www.libgd.org/Main_Page
|
||||||
Source0: http://www.boutell.com/gd/http/%{name}-%{version}.tar.gz
|
Source0: http://www.libgd.org/Releases/%{name}-%{version}.tar.bz2
|
||||||
Patch0: gd-2.0.33-freetype.patch
|
Patch0: gd-2.0.33-freetype.patch
|
||||||
Patch1: gd-2.0.33-SetAAPixel.patch
|
Patch3: gd-2.0.34-multilib.patch
|
||||||
Patch2: gd-2.0.33-security.patch
|
|
||||||
Patch3: gd-2.0.33-multilib.patch
|
|
||||||
Patch4: gd-loop.patch
|
Patch4: gd-loop.patch
|
||||||
Patch5: gd-sparc64.patch
|
Patch5: gd-2.0.34-sparc64.patch
|
||||||
Patch6: gd-2.0.33-overflow.patch
|
Patch6: gd-2.0.33-overflow.patch
|
||||||
Patch7: gd-2.0.33-AALineThick.patch
|
Patch7: gd-2.0.33-AALineThick.patch
|
||||||
Patch8: gd-2.0.33-BoxBound.patch
|
Patch8: gd-2.0.33-BoxBound.patch
|
||||||
Patch9: gd-2.0.33-cve-07-0455.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: freetype-devel, fontconfig-devel, libX11-devel, libXpm-devel
|
BuildRequires: freetype-devel, fontconfig-devel, libX11-devel, libXpm-devel
|
||||||
BuildRequires: libjpeg-devel, libpng-devel, zlib-devel, pkgconfig
|
BuildRequires: libjpeg-devel, libpng-devel, zlib-devel, pkgconfig
|
||||||
@ -56,15 +53,12 @@ files for gd, a graphics library for creating PNG and JPEG graphics.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .freetype
|
%patch0 -p1 -b .freetype
|
||||||
%patch1 -p1 -b .SetAAPixel
|
|
||||||
%patch2 -p1 -b .security
|
|
||||||
%patch3 -p1 -b .mlib
|
%patch3 -p1 -b .mlib
|
||||||
%patch4 -p1 -b .loop
|
%patch4 -p1 -b .loop
|
||||||
%patch5 -p1 -b .sparc64
|
|
||||||
%patch6 -p1 -b .overflow
|
%patch6 -p1 -b .overflow
|
||||||
|
%patch5 -p1 -b .sparc64
|
||||||
%patch7 -p1 -b .AALineThick
|
%patch7 -p1 -b .AALineThick
|
||||||
%patch8 -p1 -b .bb
|
%patch8 -p1 -b .bb
|
||||||
%patch9 -p1 -b .cve-07-0455
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-rpath
|
%configure --disable-rpath
|
||||||
@ -83,7 +77,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc COPYING README-JPEG.TXT index.html entities.html
|
%doc COPYING README-JPEG.TXT index.html entities.html
|
||||||
@ -104,6 +97,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 8 2007 Ivana Varekova <varekova@redhat.com> 2.0.34-1
|
||||||
|
- update to 2.0.34
|
||||||
|
|
||||||
* Mon Jan 29 2007 Ivana Varekova <varekova@redhat.com> 2.0.33-12
|
* Mon Jan 29 2007 Ivana Varekova <varekova@redhat.com> 2.0.33-12
|
||||||
- Resolves: #224610
|
- Resolves: #224610
|
||||||
CVE-2007-0455 gd buffer overrun
|
CVE-2007-0455 gd buffer overrun
|
||||||
|
Loading…
Reference in New Issue
Block a user