Update to 3.33.4
This commit is contained in:
parent
b750c557a9
commit
e1febbfc80
1
.gitignore
vendored
1
.gitignore
vendored
@ -39,3 +39,4 @@
|
||||
/gcr-3.27.92.tar.xz
|
||||
/gcr-3.28.0.tar.xz
|
||||
/gcr-3.28.1.tar.xz
|
||||
/gcr-3.33.4.tar.xz
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 7c307f7bbf9b8e94e88fab8e550a8c9f72aabad8 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Sat, 1 Jun 2019 10:02:50 +0200
|
||||
Subject: [PATCH] fix parameter type for signal handler
|
||||
|
||||
The on_prompter_prompting signal handler used a struct as a otherwise unused parameter
|
||||
while a pointer was passed by the caller. This led to a stack smashing on the ppc64le
|
||||
platform and a segfault.
|
||||
|
||||
fixes https://bugzilla.redhat.com/show_bug.cgi?id=1631759
|
||||
---
|
||||
ui/gcr-prompter-tool.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ui/gcr-prompter-tool.c b/ui/gcr-prompter-tool.c
|
||||
index 0a22238..cd1cc56 100644
|
||||
--- a/ui/gcr-prompter-tool.c
|
||||
+++ b/ui/gcr-prompter-tool.c
|
||||
@@ -72,7 +72,7 @@ stop_timeout (void)
|
||||
|
||||
static void
|
||||
on_prompter_prompting (GObject *obj,
|
||||
- GParamSpec param,
|
||||
+ GParamSpec *param,
|
||||
gpointer user_data)
|
||||
{
|
||||
if (gcr_system_prompter_get_prompting (the_prompter))
|
||||
--
|
||||
2.21.0
|
||||
|
11
gcr.spec
11
gcr.spec
@ -3,15 +3,13 @@
|
||||
%endif
|
||||
|
||||
Name: gcr
|
||||
Version: 3.28.1
|
||||
Release: 5%{?dist}
|
||||
Version: 3.33.4
|
||||
Release: 1%{?dist}
|
||||
Summary: A library for bits of crypto UI and parsing
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://wiki.gnome.org/Projects/CryptoGlue
|
||||
Source0: https://download.gnome.org/sources/%{name}/3.28/%{name}-%{version}.tar.xz
|
||||
# https://gitlab.gnome.org/GNOME/gcr/commit/7c307f7bbf9b8e94e88fab8e550a8c9f72aabad8
|
||||
Patch0: gcr-3.28.1-signal.patch
|
||||
Source0: https://download.gnome.org/sources/%{name}/3.33/%{name}-%{version}.tar.xz
|
||||
|
||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||
BuildRequires: pkgconfig(gobject-introspection-1.0)
|
||||
@ -124,6 +122,9 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/gcr-viewer.desktop
|
||||
%{_libdir}/libgcr-base-3.so.*
|
||||
|
||||
%changelog
|
||||
* Mon Aug 19 2019 Kalev Lember <klember@redhat.com> - 3.33.4-1
|
||||
- Update to 3.33.4
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.28.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gcr-3.28.1.tar.xz) = ae36c39584d6bc2ba9d86de8bc71eac21fb3251b966ab1eddf467d01ed5789ba6e6597c83ea2ed9403e632893e7c7cb6c17e04878d726b72528af9199bebb3da
|
||||
SHA512 (gcr-3.33.4.tar.xz) = d87901d2025141c81973db9fefe6bd51c568f9749f3057e067bce60aa29572d1ba77ae34bc5e94aebbc899756316d47db4a8def802492b1757554e93e54c75cc
|
||||
|
Loading…
Reference in New Issue
Block a user