Update to 3.28.1
This commit is contained in:
parent
a21618e05e
commit
6b3893f704
1
.gitignore
vendored
1
.gitignore
vendored
@ -38,3 +38,4 @@
|
||||
/gcr-3.20.0.tar.xz
|
||||
/gcr-3.27.92.tar.xz
|
||||
/gcr-3.28.0.tar.xz
|
||||
/gcr-3.28.1.tar.xz
|
||||
|
@ -1,42 +0,0 @@
|
||||
From 038962d643361f44ddb58ae9611a9386b291e7f1 Mon Sep 17 00:00:00 2001
|
||||
From: Daiki Ueno <dueno@src.gnome.org>
|
||||
Date: Sat, 29 Sep 2018 09:40:14 +0200
|
||||
Subject: [PATCH] system-prompter: Fix use of g_hash_table_lookup_extended
|
||||
|
||||
Since the glib commit 8dc8b33d, g_hash_table_lookup_extended() started
|
||||
to clear the argument to NULL, even if the lookup failed. Do not
|
||||
expect the original key is preserved in that case.
|
||||
|
||||
Fixes #9.
|
||||
---
|
||||
gcr/gcr-system-prompter.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gcr/gcr-system-prompter.c b/gcr/gcr-system-prompter.c
|
||||
index 975abe4..39250e7 100644
|
||||
--- a/gcr/gcr-system-prompter.c
|
||||
+++ b/gcr/gcr-system-prompter.c
|
||||
@@ -491,17 +491,19 @@ prompt_stop_prompting (GcrSystemPrompter *self,
|
||||
ActivePrompt *active;
|
||||
GVariant *retval;
|
||||
gpointer watch;
|
||||
+ Callback *orig_callback;
|
||||
|
||||
g_debug ("stopping prompting for operation %s@%s",
|
||||
callback->path, callback->name);
|
||||
|
||||
/* Get a pointer to our actual callback */
|
||||
if (!g_hash_table_lookup_extended (self->pv->callbacks, callback,
|
||||
- (gpointer *)&callback, &watch)) {
|
||||
+ (gpointer *)&orig_callback, &watch)) {
|
||||
g_debug ("couldn't find the callback for prompting operation %s@%s",
|
||||
callback->path, callback->name);
|
||||
return;
|
||||
}
|
||||
+ callback = orig_callback;
|
||||
|
||||
/*
|
||||
* We remove these from the callbacks hash table so that we don't
|
||||
--
|
||||
2.19.1
|
||||
|
9
gcr.spec
9
gcr.spec
@ -3,15 +3,13 @@
|
||||
%endif
|
||||
|
||||
Name: gcr
|
||||
Version: 3.28.0
|
||||
Release: 3%{?dist}
|
||||
Version: 3.28.1
|
||||
Release: 1%{?dist}
|
||||
Summary: A library for bits of crypto UI and parsing
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://wiki.gnome.org/Projects/CryptoGlue
|
||||
Source0: https://download.gnome.org/sources/%{name}/3.28/%{name}-%{version}.tar.xz
|
||||
# Fix gnome-shell crashes with glib 2.59
|
||||
Patch0: 0001-system-prompter-Fix-use-of-g_hash_table_lookup_exten.patch
|
||||
|
||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||
BuildRequires: pkgconfig(gobject-introspection-1.0)
|
||||
@ -116,6 +114,9 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/gcr-viewer.desktop
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 21 2019 Kalev Lember <klember@redhat.com> - 3.28.1-1
|
||||
- Update to 3.28.1
|
||||
|
||||
* Fri Jan 04 2019 Kalev Lember <klember@redhat.com> - 3.28.0-3
|
||||
- Backport a patch to fix gnome-shell crashes with glib 2.59
|
||||
- Use make_build and make_install macros
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gcr-3.28.0.tar.xz) = 8d5e650cb369fa889b0adfdc1dc1cb5f8b184881256e6c0a2ed456074a54ceb61d64c0929c093bec66c0d5a15c1718f6e3736a1b25b6d7076081df93b49419e0
|
||||
SHA512 (gcr-3.28.1.tar.xz) = ae36c39584d6bc2ba9d86de8bc71eac21fb3251b966ab1eddf467d01ed5789ba6e6597c83ea2ed9403e632893e7c7cb6c17e04878d726b72528af9199bebb3da
|
||||
|
Loading…
Reference in New Issue
Block a user