- fix gcr-prompter crash (rhbz#1631759)
This commit is contained in:
parent
3c7a6e7df6
commit
5af0aa559f
30
gcr-3.28.1-signal.patch
Normal file
30
gcr-3.28.1-signal.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From 7c307f7bbf9b8e94e88fab8e550a8c9f72aabad8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
|
Date: Sat, 1 Jun 2019 10:02:50 +0200
|
||||||
|
Subject: [PATCH] fix parameter type for signal handler
|
||||||
|
|
||||||
|
The on_prompter_prompting signal handler used a struct as a otherwise unused parameter
|
||||||
|
while a pointer was passed by the caller. This led to a stack smashing on the ppc64le
|
||||||
|
platform and a segfault.
|
||||||
|
|
||||||
|
fixes https://bugzilla.redhat.com/show_bug.cgi?id=1631759
|
||||||
|
---
|
||||||
|
ui/gcr-prompter-tool.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/ui/gcr-prompter-tool.c b/ui/gcr-prompter-tool.c
|
||||||
|
index 0a22238..cd1cc56 100644
|
||||||
|
--- a/ui/gcr-prompter-tool.c
|
||||||
|
+++ b/ui/gcr-prompter-tool.c
|
||||||
|
@@ -72,7 +72,7 @@ stop_timeout (void)
|
||||||
|
|
||||||
|
static void
|
||||||
|
on_prompter_prompting (GObject *obj,
|
||||||
|
- GParamSpec param,
|
||||||
|
+ GParamSpec *param,
|
||||||
|
gpointer user_data)
|
||||||
|
{
|
||||||
|
if (gcr_system_prompter_get_prompting (the_prompter))
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
7
gcr.spec
7
gcr.spec
@ -4,12 +4,14 @@
|
|||||||
|
|
||||||
Name: gcr
|
Name: gcr
|
||||||
Version: 3.28.1
|
Version: 3.28.1
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: A library for bits of crypto UI and parsing
|
Summary: A library for bits of crypto UI and parsing
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://wiki.gnome.org/Projects/CryptoGlue
|
URL: https://wiki.gnome.org/Projects/CryptoGlue
|
||||||
Source0: https://download.gnome.org/sources/%{name}/3.28/%{name}-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/%{name}/3.28/%{name}-%{version}.tar.xz
|
||||||
|
# https://gitlab.gnome.org/GNOME/gcr/commit/7c307f7bbf9b8e94e88fab8e550a8c9f72aabad8
|
||||||
|
Patch0: gcr-3.28.1-signal.patch
|
||||||
|
|
||||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||||
BuildRequires: pkgconfig(gobject-introspection-1.0)
|
BuildRequires: pkgconfig(gobject-introspection-1.0)
|
||||||
@ -122,6 +124,9 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/gcr-viewer.desktop
|
|||||||
%{_libdir}/libgcr-base-3.so.*
|
%{_libdir}/libgcr-base-3.so.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jun 02 2019 Dan Horák <dan[at]danny.cz> - 3.28.1-4
|
||||||
|
- fix gcr-prompter crash (rhbz#1631759)
|
||||||
|
|
||||||
* Thu Apr 11 2019 Fabiano Fidêncio <fidencio@redhat.com> - 3.28.1-3
|
* Thu Apr 11 2019 Fabiano Fidêncio <fidencio@redhat.com> - 3.28.1-3
|
||||||
- Split gcr-base into a new package
|
- Split gcr-base into a new package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user