diff --git a/gcc.spec b/gcc.spec
index 47c60b6..fa30127 100644
--- a/gcc.spec
+++ b/gcc.spec
@@ -174,8 +174,6 @@ Patch12: gcc47-libstdc++-docs.patch
 Patch13: gcc47-no-add-needed.patch
 Patch14: gcc47-ppl-0.10.patch
 Patch15: gcc47-libitm-fno-exceptions.patch
-Patch16: gcc47-pr53438.patch
-Patch17: gcc47-libgo-r187890.patch
 
 Patch1000: fastjar-0.97-segfault.patch
 Patch1001: fastjar-0.97-len1.patch
@@ -677,8 +675,6 @@ package or when debugging this package.
 %patch14 -p0 -b .ppl-0.10~
 %endif
 %patch15 -p0 -b .libitm-fno-exceptions~
-%patch16 -p0 -b .pr53438~
-%patch17 -p0 -b .libgo-r187890~
 
 %if 0%{?_enable_debug_packages}
 cat > split-debuginfo.sh <<\EOF
diff --git a/gcc47-libgo-r187890.patch b/gcc47-libgo-r187890.patch
deleted file mode 100644
index a061979..0000000
--- a/gcc47-libgo-r187890.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- libgo/runtime/print.c	(revision 187889)
-+++ libgo/runtime/print.c	(revision 187890)
-@@ -136,7 +136,7 @@ void
- runtime_printpc(void *p __attribute__ ((unused)))
- {
- 	runtime_prints("PC=");
--	runtime_printhex((uint64)runtime_getcallerpc(p));
-+	runtime_printhex((uint64)(uintptr)runtime_getcallerpc(p));
- }
- 
- void
diff --git a/gcc47-pr53438.patch b/gcc47-pr53438.patch
deleted file mode 100644
index fe83526..0000000
--- a/gcc47-pr53438.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-2012-05-23  Richard Guenther  <rguenther@suse.de>
-
-	PR tree-optimization/53438
-	* tree-sra.c (analyze_access_subtree): Correct bitfield exclusion.
-
---- gcc/tree-sra.c	(revision 187804)
-+++ gcc/tree-sra.c	(revision 187805)
-@@ -2096,9 +2096,12 @@ analyze_access_subtree (struct access *r
- 	  && (TREE_CODE (root->type) != INTEGER_TYPE
- 	      || TYPE_PRECISION (root->type) != root->size)
- 	  /* But leave bitfield accesses alone.  */
--	  && (root->offset % BITS_PER_UNIT) == 0)
-+	  && (TREE_CODE (root->expr) != COMPONENT_REF
-+	      || !DECL_BIT_FIELD (TREE_OPERAND (root->expr, 1))))
- 	{
- 	  tree rt = root->type;
-+	  gcc_assert ((root->offset % BITS_PER_UNIT) == 0
-+		      && (root->size % BITS_PER_UNIT) == 0);
- 	  root->type = build_nonstandard_integer_type (root->size,
- 						       TYPE_UNSIGNED (rt));
- 	  root->expr = build_ref_for_offset (UNKNOWN_LOCATION,