From 6ed6e5a4c3b129ba34f1fba1a5d3a930dd0b078e Mon Sep 17 00:00:00 2001
From: Jakub Jelinek <jakub@redhat.com>
Date: Tue, 31 Jan 2017 12:35:13 +0100
Subject: [PATCH] 7.0.1-0.4

---
 gcc.spec                      |  4 ----
 gcc7-pr79170-workaround.patch | 16 ----------------
 2 files changed, 20 deletions(-)
 delete mode 100644 gcc7-pr79170-workaround.patch

diff --git a/gcc.spec b/gcc.spec
index d34c270..9d20a47 100644
--- a/gcc.spec
+++ b/gcc.spec
@@ -231,7 +231,6 @@ Patch11: gcc7-s390-asan.patch
 Patch12: gcc7-pr79197.patch
 Patch13: gcc7-pr79232.patch
 Patch14: gcc7-pr79288.patch
-Patch15: gcc7-pr79170-workaround.patch
 
 Patch1000: nvptx-tools-no-ptxas.patch
 Patch1001: nvptx-tools-build.patch
@@ -823,7 +822,6 @@ package or when debugging this package.
 %patch12 -p0 -b .pr79197~
 %patch13 -p0 -b .pr79232~
 %patch14 -p0 -b .pr79288~
-%patch15 -p0 -b .pr79170-workaround~
 
 cd nvptx-tools-%{nvptx_tools_gitrev}
 %patch1000 -p1 -b .nvptx-tools-no-ptxas~
@@ -3251,8 +3249,6 @@ fi
   (PR target/79197)
 - fix C++ ICE with comma expression on lhs of assignment (PR c++/79232)
 - fix default TLS model for C++ non-inline static data members (PR c++/79288)
-- add workaround for powerpc constant size memcmp expansion bug (#1417753,
-  PR target/79170)
 - libcp1plugin.so added to gcc-gdb-plugin for C++ support
 
 * Sat Jan 28 2017 Jakub Jelinek <jakub@redhat.com> 7.0.1-0.3
diff --git a/gcc7-pr79170-workaround.patch b/gcc7-pr79170-workaround.patch
deleted file mode 100644
index f094ca8..0000000
--- a/gcc7-pr79170-workaround.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-2017-01-31  Jakub Jelinek  <jakub@redhat.com>
-
-	PR target/79170
-	* config/rs6000/rs6000.c (expand_block_compare): Temporarily disable.
-
---- gcc/config/rs6000/rs6000.c.jj	2017-01-31 09:25:59.000000000 +0100
-+++ gcc/config/rs6000/rs6000.c	2017-01-31 10:17:21.131929670 +0100
-@@ -19462,7 +19462,7 @@ expand_block_compare (rtx operands[])
-      with carry instructions do not generate the 64-bit
-      carry and so we must emit code to calculate it ourselves.
-      We choose not to implement this yet.  */
--  if (TARGET_32BIT && TARGET_POWERPC64)
-+  if ((TARGET_32BIT && TARGET_POWERPC64) || 1)
-     return false;
- 
-   /* If this is not a fixed size compare, just call memcmp.  */