Rebuild with LLVM 18. Rebase to 12.52 in order to bring in fixes for LLVM 18.
Resolves: RHEL-49954
This commit is contained in:
parent
ae7418f308
commit
d3b808d734
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
|||||||
/annobin-12.18.tar.xz
|
/annobin-12.18.tar.xz
|
||||||
/annobin-12.20.tar.xz
|
/annobin-12.20.tar.xz
|
||||||
/annobin-12.32.tar.xz
|
/annobin-12.32.tar.xz
|
||||||
|
/annobin-12.52.tar.xz
|
||||||
|
@ -1,11 +1,11 @@
|
|||||||
--- annobin.orig/gcc-plugin/annobin.cc 2023-06-23 09:52:10.176119281 +0100
|
--- annobin.orig/gcc-plugin/annobin.cc 2024-07-22 14:02:09.227059334 +0100
|
||||||
+++ annobin-12.14/gcc-plugin/annobin.cc 2023-06-23 10:06:28.621554381 +0100
|
+++ annobin-12.52/gcc-plugin/annobin.cc 2024-07-22 14:03:38.516398800 +0100
|
||||||
@@ -3155,7 +3155,7 @@ plugin_init (struct plugin_name_args *
|
@@ -3300,7 +3300,7 @@ plugin_init (struct plugin_name_args *
|
||||||
versions that are needed. (Note - 2.35.2, as used by RHEL-9, is insufficient).
|
versions that are needed. (Note - 2.35.2, as used by RHEL-9, is insufficient).
|
||||||
See BZ 2016458 for an example of where this solution is needed. */
|
See BZ 2016458 for an example of where this solution is needed. */
|
||||||
#if GCCPLUGIN_VERSION_MAJOR >= 12
|
#if GCCPLUGIN_VERSION_MAJOR >= 12
|
||||||
- annobin_attach_type = link_order;
|
- annobin_attach_type = link_order;
|
||||||
+ annobin_attach_type = group;
|
+ annobin_attach_type = group;
|
||||||
#else
|
#else
|
||||||
annobin_attach_type = group;
|
annobin_attach_type = group;
|
||||||
#endif
|
#endif
|
||||||
|
10
annobin.spec
10
annobin.spec
@ -8,8 +8,8 @@ BuildRequires: scl-utils-build
|
|||||||
|
|
||||||
Name: %{?scl_prefix}annobin
|
Name: %{?scl_prefix}annobin
|
||||||
Summary: Annotate and examine compiled binary files
|
Summary: Annotate and examine compiled binary files
|
||||||
Version: 12.32
|
Version: 12.52
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPL-3.0-or-later AND LGPL-2.0-or-later AND (GPL-2.0-or-later WITH GCC-exception-2.0) AND (LGPL-2.0-or-later WITH GCC-exception-2.0) AND GFDL-1.3-or-later
|
License: GPL-3.0-or-later AND LGPL-2.0-or-later AND (GPL-2.0-or-later WITH GCC-exception-2.0) AND (LGPL-2.0-or-later WITH GCC-exception-2.0) AND GFDL-1.3-or-later
|
||||||
URL: https://sourceware.org/annobin/
|
URL: https://sourceware.org/annobin/
|
||||||
# Maintainer: nickc@redhat.com
|
# Maintainer: nickc@redhat.com
|
||||||
@ -472,7 +472,7 @@ mv %{buildroot}/%{llvm_plugin_dir}/annobin-for-clang.so %{buildroot}/%{clang_plu
|
|||||||
# Note - we cannot just store %%{gcc_vr} as sometimes the gcc rpm version changes
|
# Note - we cannot just store %%{gcc_vr} as sometimes the gcc rpm version changes
|
||||||
# without the NVR being altered. See BZ #2030671 for more discussion on this.
|
# without the NVR being altered. See BZ #2030671 for more discussion on this.
|
||||||
mkdir -p %{buildroot}/%{ANNOBIN_GCC_PLUGIN_DIR}
|
mkdir -p %{buildroot}/%{ANNOBIN_GCC_PLUGIN_DIR}
|
||||||
cat `gcc --print-file-name=rpmver` > %{buildroot}/%{ANNOBIN_GCC_PLUGIN_DIR}/%{aver}
|
cat `%gcc_for_annobin --print-file-name=rpmver` > %{buildroot}/%{ANNOBIN_GCC_PLUGIN_DIR}/%{aver}
|
||||||
|
|
||||||
# Also install a copy of the sources into the build tree.
|
# Also install a copy of the sources into the build tree.
|
||||||
mkdir -p %{buildroot}%{annobin_source_dir}
|
mkdir -p %{buildroot}%{annobin_source_dir}
|
||||||
@ -557,6 +557,10 @@ make check GCC=%gcc_for_annobin
|
|||||||
#---------------------------------------------------------------------------------
|
#---------------------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 22 2024 Nick Clifton <nickc@redhat.com> - 12.52-1
|
||||||
|
- Rebuild with LLVM 18. (RHEL-49954)
|
||||||
|
- Rebase to 12.52 in order to bring in fixes for LLVM 18.
|
||||||
|
|
||||||
* Tue Nov 28 2023 Nick Clifton <nickc@redhat.com> - 12.32-2
|
* Tue Nov 28 2023 Nick Clifton <nickc@redhat.com> - 12.32-2
|
||||||
- GCC Plugin: Add %%verify tokens to show that the default plugin names are symbolic links. (RHEL-17505)
|
- GCC Plugin: Add %%verify tokens to show that the default plugin names are symbolic links. (RHEL-17505)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (annobin-12.32.tar.xz) = 10ab73bc48d0a95102292d90d28c87440b969055ab07e964020703276b6c5db35b8693e828fb0063e1d6e5efb025c8ffe3fafb2dd40377c25767b09a986bc02b
|
SHA512 (annobin-12.52.tar.xz) = d5ef0bf20fb9db1fb3c86000fbd2f130f30fabc45e6ea183438f272f57119f0c34267ce47fe7ba6a9c227657c4aeecb9c71b4390cc808e8d1ddd9fd85ce02c8a
|
||||||
|
Loading…
Reference in New Issue
Block a user