815 lines
28 KiB
Diff
815 lines
28 KiB
Diff
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
|
From: Keith Seitz <keiths@redhat.com>
|
|
Date: Fri, 24 Jul 2020 16:09:15 -0400
|
|
Subject: debuginfod-use-pkg-config.patch
|
|
|
|
;; Use pkg-config for debuginfod.m4.
|
|
;; (Aaron Merey)
|
|
|
|
From: Aaron Merey <amerey@redhat.com>
|
|
Date: Fri, 24 Jul 2020 15:16:20 -0400
|
|
Subject: [PATCH] config/debuginfod.m4: Use PKG_CHECK_MODULES
|
|
|
|
Use PKG_CHECK_MODULES to set debuginfod autoconf vars. Also add
|
|
pkg.m4 to config/.
|
|
|
|
ChangeLog:
|
|
|
|
* config/debuginfod.m4: use PKG_CHECK_MODULES.
|
|
* config/pkg.m4: New file.
|
|
* configure: Rebuild.
|
|
* configure.ac: Remove AC_DEBUGINFOD.
|
|
|
|
ChangeLog/binutils:
|
|
|
|
* Makefile.am: Replace LIBDEBUGINFOD with DEBUGINFOD_LIBS.
|
|
* Makefile.in: Rebuild.
|
|
* configure: Rebuild.
|
|
* doc/Makefile.in: Rebuild.
|
|
|
|
ChangeLog/gdb:
|
|
|
|
* Makefile.in: Replace LIBDEBUGINFOD with DEBUGINFOD_LIBS.
|
|
* configure: Rebuild.
|
|
|
|
diff --git a/config/debuginfod.m4 b/config/debuginfod.m4
|
|
--- a/config/debuginfod.m4
|
|
+++ b/config/debuginfod.m4
|
|
@@ -1,38 +1,30 @@
|
|
-dnl Copyright (C) 1997-2019 Free Software Foundation, Inc.
|
|
+dnl Copyright (C) 1997-2020 Free Software Foundation, Inc.
|
|
dnl This file is free software, distributed under the terms of the GNU
|
|
dnl General Public License. As a special exception to the GNU General
|
|
dnl Public License, this file may be distributed as part of a program
|
|
dnl that contains a configuration script generated by Autoconf, under
|
|
dnl the same distribution terms as the rest of that program.
|
|
|
|
+m4_include([../config/pkg.m4])
|
|
+
|
|
AC_DEFUN([AC_DEBUGINFOD],
|
|
[
|
|
-# Enable debuginfod
|
|
+# Handle optional debuginfod support
|
|
AC_ARG_WITH([debuginfod],
|
|
- AC_HELP_STRING([--with-debuginfod],
|
|
- [Enable debuginfo lookups with debuginfod (auto/yes/no)]),
|
|
- [], [with_debuginfod=auto])
|
|
+ AC_HELP_STRING([--with-debuginfod], [Enable debuginfo lookups with debuginfod (auto/yes/no)]),
|
|
+ [], [with_debuginfod=auto])
|
|
AC_MSG_CHECKING([whether to use debuginfod])
|
|
AC_MSG_RESULT([$with_debuginfod])
|
|
|
|
-if test "${with_debuginfod}" = no; then
|
|
- AC_MSG_WARN([debuginfod support disabled; some features may be unavailable.])
|
|
+if test "x$with_debuginfod" != xno; then
|
|
+ PKG_CHECK_MODULES([DEBUGINFOD], [libdebuginfod >= 0.179],
|
|
+ [AC_DEFINE([HAVE_LIBDEBUGINFOD], [1], [Define to 1 if debuginfod is enabled.])],
|
|
+ [if test "x$with_debuginfod" = xyes; then
|
|
+ AC_MSG_ERROR(["--with-debuginfod was given, but libdebuginfod is missing or unusable."])
|
|
+ else
|
|
+ AC_MSG_WARN([libdebuginfod is missing or unusable; some features may be unavailable.])
|
|
+ fi])
|
|
else
|
|
- AC_CHECK_LIB([debuginfod], [debuginfod_begin], [have_debuginfod_lib=yes])
|
|
- AC_CHECK_DECL([debuginfod_begin], [have_debuginfod_h=yes], [],
|
|
- [#include <elfutils/debuginfod.h>])
|
|
- if test "x$have_debuginfod_lib" = "xyes" -a \
|
|
- "x$have_debuginfod_h" = "xyes"; then
|
|
- AC_DEFINE([HAVE_LIBDEBUGINFOD], [1],
|
|
- [Define to 1 if debuginfod is enabled.])
|
|
- AC_SUBST([LIBDEBUGINFOD], ["-ldebuginfod"])
|
|
- else
|
|
- AC_SUBST([LIBDEBUGINFOD], [])
|
|
- if test "$with_debuginfod" = yes; then
|
|
- AC_MSG_ERROR([debuginfod is missing or unusable])
|
|
- else
|
|
- AC_MSG_WARN([debuginfod is missing or unusable; some features may be unavailable.])
|
|
- fi
|
|
- fi
|
|
+ AC_MSG_WARN([debuginfod support disabled; some features may be unavailable.])
|
|
fi
|
|
])
|
|
diff --git a/config/pkg.m4 b/config/pkg.m4
|
|
new file mode 100644
|
|
--- /dev/null
|
|
+++ b/config/pkg.m4
|
|
@@ -0,0 +1,275 @@
|
|
+# pkg.m4 - Macros to locate and utilise pkg-config. -*- Autoconf -*-
|
|
+# serial 12 (pkg-config-0.29.2)
|
|
+
|
|
+dnl Copyright © 2004 Scott James Remnant <scott@netsplit.com>.
|
|
+dnl Copyright © 2012-2015 Dan Nicholson <dbn.lists@gmail.com>
|
|
+dnl
|
|
+dnl This program is free software; you can redistribute it and/or modify
|
|
+dnl it under the terms of the GNU General Public License as published by
|
|
+dnl the Free Software Foundation; either version 2 of the License, or
|
|
+dnl (at your option) any later version.
|
|
+dnl
|
|
+dnl This program is distributed in the hope that it will be useful, but
|
|
+dnl WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+dnl General Public License for more details.
|
|
+dnl
|
|
+dnl You should have received a copy of the GNU General Public License
|
|
+dnl along with this program; if not, write to the Free Software
|
|
+dnl Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
|
|
+dnl 02111-1307, USA.
|
|
+dnl
|
|
+dnl As a special exception to the GNU General Public License, if you
|
|
+dnl distribute this file as part of a program that contains a
|
|
+dnl configuration script generated by Autoconf, you may include it under
|
|
+dnl the same distribution terms that you use for the rest of that
|
|
+dnl program.
|
|
+
|
|
+dnl PKG_PREREQ(MIN-VERSION)
|
|
+dnl -----------------------
|
|
+dnl Since: 0.29
|
|
+dnl
|
|
+dnl Verify that the version of the pkg-config macros are at least
|
|
+dnl MIN-VERSION. Unlike PKG_PROG_PKG_CONFIG, which checks the user's
|
|
+dnl installed version of pkg-config, this checks the developer's version
|
|
+dnl of pkg.m4 when generating configure.
|
|
+dnl
|
|
+dnl To ensure that this macro is defined, also add:
|
|
+dnl m4_ifndef([PKG_PREREQ],
|
|
+dnl [m4_fatal([must install pkg-config 0.29 or later before running autoconf/autogen])])
|
|
+dnl
|
|
+dnl See the "Since" comment for each macro you use to see what version
|
|
+dnl of the macros you require.
|
|
+m4_defun([PKG_PREREQ],
|
|
+[m4_define([PKG_MACROS_VERSION], [0.29.2])
|
|
+m4_if(m4_version_compare(PKG_MACROS_VERSION, [$1]), -1,
|
|
+ [m4_fatal([pkg.m4 version $1 or higher is required but ]PKG_MACROS_VERSION[ found])])
|
|
+])dnl PKG_PREREQ
|
|
+
|
|
+dnl PKG_PROG_PKG_CONFIG([MIN-VERSION])
|
|
+dnl ----------------------------------
|
|
+dnl Since: 0.16
|
|
+dnl
|
|
+dnl Search for the pkg-config tool and set the PKG_CONFIG variable to
|
|
+dnl first found in the path. Checks that the version of pkg-config found
|
|
+dnl is at least MIN-VERSION. If MIN-VERSION is not specified, 0.9.0 is
|
|
+dnl used since that's the first version where most current features of
|
|
+dnl pkg-config existed.
|
|
+AC_DEFUN([PKG_PROG_PKG_CONFIG],
|
|
+[m4_pattern_forbid([^_?PKG_[A-Z_]+$])
|
|
+m4_pattern_allow([^PKG_CONFIG(_(PATH|LIBDIR|SYSROOT_DIR|ALLOW_SYSTEM_(CFLAGS|LIBS)))?$])
|
|
+m4_pattern_allow([^PKG_CONFIG_(DISABLE_UNINSTALLED|TOP_BUILD_DIR|DEBUG_SPEW)$])
|
|
+AC_ARG_VAR([PKG_CONFIG], [path to pkg-config utility])
|
|
+AC_ARG_VAR([PKG_CONFIG_PATH], [directories to add to pkg-config's search path])
|
|
+AC_ARG_VAR([PKG_CONFIG_LIBDIR], [path overriding pkg-config's built-in search path])
|
|
+
|
|
+if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
|
|
+ AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
|
|
+fi
|
|
+if test -n "$PKG_CONFIG"; then
|
|
+ _pkg_min_version=m4_default([$1], [0.9.0])
|
|
+ AC_MSG_CHECKING([pkg-config is at least version $_pkg_min_version])
|
|
+ if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
|
|
+ AC_MSG_RESULT([yes])
|
|
+ else
|
|
+ AC_MSG_RESULT([no])
|
|
+ PKG_CONFIG=""
|
|
+ fi
|
|
+fi[]dnl
|
|
+])dnl PKG_PROG_PKG_CONFIG
|
|
+
|
|
+dnl PKG_CHECK_EXISTS(MODULES, [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
|
|
+dnl -------------------------------------------------------------------
|
|
+dnl Since: 0.18
|
|
+dnl
|
|
+dnl Check to see whether a particular set of modules exists. Similar to
|
|
+dnl PKG_CHECK_MODULES(), but does not set variables or print errors.
|
|
+dnl
|
|
+dnl Please remember that m4 expands AC_REQUIRE([PKG_PROG_PKG_CONFIG])
|
|
+dnl only at the first occurence in configure.ac, so if the first place
|
|
+dnl it's called might be skipped (such as if it is within an "if", you
|
|
+dnl have to call PKG_CHECK_EXISTS manually
|
|
+AC_DEFUN([PKG_CHECK_EXISTS],
|
|
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
|
|
+if test -n "$PKG_CONFIG" && \
|
|
+ AC_RUN_LOG([$PKG_CONFIG --exists --print-errors "$1"]); then
|
|
+ m4_default([$2], [:])
|
|
+m4_ifvaln([$3], [else
|
|
+ $3])dnl
|
|
+fi])
|
|
+
|
|
+dnl _PKG_CONFIG([VARIABLE], [COMMAND], [MODULES])
|
|
+dnl ---------------------------------------------
|
|
+dnl Internal wrapper calling pkg-config via PKG_CONFIG and setting
|
|
+dnl pkg_failed based on the result.
|
|
+m4_define([_PKG_CONFIG],
|
|
+[if test -n "$$1"; then
|
|
+ pkg_cv_[]$1="$$1"
|
|
+ elif test -n "$PKG_CONFIG"; then
|
|
+ PKG_CHECK_EXISTS([$3],
|
|
+ [pkg_cv_[]$1=`$PKG_CONFIG --[]$2 "$3" 2>/dev/null`
|
|
+ test "x$?" != "x0" && pkg_failed=yes ],
|
|
+ [pkg_failed=yes])
|
|
+ else
|
|
+ pkg_failed=untried
|
|
+fi[]dnl
|
|
+])dnl _PKG_CONFIG
|
|
+
|
|
+dnl _PKG_SHORT_ERRORS_SUPPORTED
|
|
+dnl ---------------------------
|
|
+dnl Internal check to see if pkg-config supports short errors.
|
|
+AC_DEFUN([_PKG_SHORT_ERRORS_SUPPORTED],
|
|
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])
|
|
+if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
|
+ _pkg_short_errors_supported=yes
|
|
+else
|
|
+ _pkg_short_errors_supported=no
|
|
+fi[]dnl
|
|
+])dnl _PKG_SHORT_ERRORS_SUPPORTED
|
|
+
|
|
+
|
|
+dnl PKG_CHECK_MODULES(VARIABLE-PREFIX, MODULES, [ACTION-IF-FOUND],
|
|
+dnl [ACTION-IF-NOT-FOUND])
|
|
+dnl --------------------------------------------------------------
|
|
+dnl Since: 0.4.0
|
|
+dnl
|
|
+dnl Note that if there is a possibility the first call to
|
|
+dnl PKG_CHECK_MODULES might not happen, you should be sure to include an
|
|
+dnl explicit call to PKG_PROG_PKG_CONFIG in your configure.ac
|
|
+AC_DEFUN([PKG_CHECK_MODULES],
|
|
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
|
|
+AC_ARG_VAR([$1][_CFLAGS], [C compiler flags for $1, overriding pkg-config])dnl
|
|
+AC_ARG_VAR([$1][_LIBS], [linker flags for $1, overriding pkg-config])dnl
|
|
+
|
|
+pkg_failed=no
|
|
+AC_MSG_CHECKING([for $2])
|
|
+
|
|
+_PKG_CONFIG([$1][_CFLAGS], [cflags], [$2])
|
|
+_PKG_CONFIG([$1][_LIBS], [libs], [$2])
|
|
+
|
|
+m4_define([_PKG_TEXT], [Alternatively, you may set the environment variables $1[]_CFLAGS
|
|
+and $1[]_LIBS to avoid the need to call pkg-config.
|
|
+See the pkg-config man page for more details.])
|
|
+
|
|
+if test $pkg_failed = yes; then
|
|
+ AC_MSG_RESULT([no])
|
|
+ _PKG_SHORT_ERRORS_SUPPORTED
|
|
+ if test $_pkg_short_errors_supported = yes; then
|
|
+ $1[]_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "$2" 2>&1`
|
|
+ else
|
|
+ $1[]_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "$2" 2>&1`
|
|
+ fi
|
|
+ # Put the nasty error message in config.log where it belongs
|
|
+ echo "$$1[]_PKG_ERRORS" >&AS_MESSAGE_LOG_FD
|
|
+
|
|
+ m4_default([$4], [AC_MSG_ERROR(
|
|
+[Package requirements ($2) were not met:
|
|
+
|
|
+$$1_PKG_ERRORS
|
|
+
|
|
+Consider adjusting the PKG_CONFIG_PATH environment variable if you
|
|
+installed software in a non-standard prefix.
|
|
+
|
|
+_PKG_TEXT])[]dnl
|
|
+ ])
|
|
+elif test $pkg_failed = untried; then
|
|
+ AC_MSG_RESULT([no])
|
|
+ m4_default([$4], [AC_MSG_FAILURE(
|
|
+[The pkg-config script could not be found or is too old. Make sure it
|
|
+is in your PATH or set the PKG_CONFIG environment variable to the full
|
|
+path to pkg-config.
|
|
+
|
|
+_PKG_TEXT
|
|
+
|
|
+To get pkg-config, see <http://pkg-config.freedesktop.org/>.])[]dnl
|
|
+ ])
|
|
+else
|
|
+ $1[]_CFLAGS=$pkg_cv_[]$1[]_CFLAGS
|
|
+ $1[]_LIBS=$pkg_cv_[]$1[]_LIBS
|
|
+ AC_MSG_RESULT([yes])
|
|
+ $3
|
|
+fi[]dnl
|
|
+])dnl PKG_CHECK_MODULES
|
|
+
|
|
+
|
|
+dnl PKG_CHECK_MODULES_STATIC(VARIABLE-PREFIX, MODULES, [ACTION-IF-FOUND],
|
|
+dnl [ACTION-IF-NOT-FOUND])
|
|
+dnl ---------------------------------------------------------------------
|
|
+dnl Since: 0.29
|
|
+dnl
|
|
+dnl Checks for existence of MODULES and gathers its build flags with
|
|
+dnl static libraries enabled. Sets VARIABLE-PREFIX_CFLAGS from --cflags
|
|
+dnl and VARIABLE-PREFIX_LIBS from --libs.
|
|
+dnl
|
|
+dnl Note that if there is a possibility the first call to
|
|
+dnl PKG_CHECK_MODULES_STATIC might not happen, you should be sure to
|
|
+dnl include an explicit call to PKG_PROG_PKG_CONFIG in your
|
|
+dnl configure.ac.
|
|
+AC_DEFUN([PKG_CHECK_MODULES_STATIC],
|
|
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
|
|
+_save_PKG_CONFIG=$PKG_CONFIG
|
|
+PKG_CONFIG="$PKG_CONFIG --static"
|
|
+PKG_CHECK_MODULES($@)
|
|
+PKG_CONFIG=$_save_PKG_CONFIG[]dnl
|
|
+])dnl PKG_CHECK_MODULES_STATIC
|
|
+
|
|
+
|
|
+dnl PKG_INSTALLDIR([DIRECTORY])
|
|
+dnl -------------------------
|
|
+dnl Since: 0.27
|
|
+dnl
|
|
+dnl Substitutes the variable pkgconfigdir as the location where a module
|
|
+dnl should install pkg-config .pc files. By default the directory is
|
|
+dnl $libdir/pkgconfig, but the default can be changed by passing
|
|
+dnl DIRECTORY. The user can override through the --with-pkgconfigdir
|
|
+dnl parameter.
|
|
+AC_DEFUN([PKG_INSTALLDIR],
|
|
+[m4_pushdef([pkg_default], [m4_default([$1], ['${libdir}/pkgconfig'])])
|
|
+m4_pushdef([pkg_description],
|
|
+ [pkg-config installation directory @<:@]pkg_default[@:>@])
|
|
+AC_ARG_WITH([pkgconfigdir],
|
|
+ [AS_HELP_STRING([--with-pkgconfigdir], pkg_description)],,
|
|
+ [with_pkgconfigdir=]pkg_default)
|
|
+AC_SUBST([pkgconfigdir], [$with_pkgconfigdir])
|
|
+m4_popdef([pkg_default])
|
|
+m4_popdef([pkg_description])
|
|
+])dnl PKG_INSTALLDIR
|
|
+
|
|
+
|
|
+dnl PKG_NOARCH_INSTALLDIR([DIRECTORY])
|
|
+dnl --------------------------------
|
|
+dnl Since: 0.27
|
|
+dnl
|
|
+dnl Substitutes the variable noarch_pkgconfigdir as the location where a
|
|
+dnl module should install arch-independent pkg-config .pc files. By
|
|
+dnl default the directory is $datadir/pkgconfig, but the default can be
|
|
+dnl changed by passing DIRECTORY. The user can override through the
|
|
+dnl --with-noarch-pkgconfigdir parameter.
|
|
+AC_DEFUN([PKG_NOARCH_INSTALLDIR],
|
|
+[m4_pushdef([pkg_default], [m4_default([$1], ['${datadir}/pkgconfig'])])
|
|
+m4_pushdef([pkg_description],
|
|
+ [pkg-config arch-independent installation directory @<:@]pkg_default[@:>@])
|
|
+AC_ARG_WITH([noarch-pkgconfigdir],
|
|
+ [AS_HELP_STRING([--with-noarch-pkgconfigdir], pkg_description)],,
|
|
+ [with_noarch_pkgconfigdir=]pkg_default)
|
|
+AC_SUBST([noarch_pkgconfigdir], [$with_noarch_pkgconfigdir])
|
|
+m4_popdef([pkg_default])
|
|
+m4_popdef([pkg_description])
|
|
+])dnl PKG_NOARCH_INSTALLDIR
|
|
+
|
|
+
|
|
+dnl PKG_CHECK_VAR(VARIABLE, MODULE, CONFIG-VARIABLE,
|
|
+dnl [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
|
|
+dnl -------------------------------------------
|
|
+dnl Since: 0.28
|
|
+dnl
|
|
+dnl Retrieves the value of the pkg-config variable for the given module.
|
|
+AC_DEFUN([PKG_CHECK_VAR],
|
|
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
|
|
+AC_ARG_VAR([$1], [value of $3 for $2, overriding pkg-config])dnl
|
|
+
|
|
+_PKG_CONFIG([$1], [variable="][$3]["], [$2])
|
|
+AS_VAR_COPY([$1], [pkg_cv_][$1])
|
|
+
|
|
+AS_VAR_IF([$1], [""], [$5], [$4])dnl
|
|
+])dnl PKG_CHECK_VAR
|
|
diff --git a/gdb/Makefile.in b/gdb/Makefile.in
|
|
--- a/gdb/Makefile.in
|
|
+++ b/gdb/Makefile.in
|
|
@@ -587,7 +587,8 @@ INTERNAL_CFLAGS_BASE = \
|
|
$(GDB_CFLAGS) $(OPCODES_CFLAGS) $(READLINE_CFLAGS) $(ZLIBINC) \
|
|
$(BFD_CFLAGS) $(INCLUDE_CFLAGS) $(LIBDECNUMBER_CFLAGS) \
|
|
$(INTL_CFLAGS) $(INCGNU) $(ENABLE_CFLAGS) $(INTERNAL_CPPFLAGS) \
|
|
- $(SRCHIGH_CFLAGS) $(TOP_CFLAGS) $(PTHREAD_CFLAGS)
|
|
+ $(SRCHIGH_CFLAGS) $(TOP_CFLAGS) $(PTHREAD_CFLAGS) \
|
|
+ @DEBUGINFOD_CFLAGS@
|
|
INTERNAL_WARN_CFLAGS = $(INTERNAL_CFLAGS_BASE) $(GDB_WARN_CFLAGS)
|
|
INTERNAL_CFLAGS = $(INTERNAL_WARN_CFLAGS) $(GDB_WERROR_CFLAGS)
|
|
|
|
@@ -613,7 +614,7 @@ CLIBS = $(SIM) $(READLINE) $(OPCODES) $(BFD) $(LIBCTF) $(ZLIB) \
|
|
$(LIBEXPAT) $(LIBLZMA) $(LIBBABELTRACE) $(LIBIPT) \
|
|
$(LIBIBERTY) $(WIN32LIBS) $(LIBGNU) $(LIBICONV) $(LIBMPFR) \
|
|
$(SRCHIGH_LIBS) $(LIBXXHASH) $(PTHREAD_LIBS) \
|
|
- @LIBDEBUGINFOD@
|
|
+ @DEBUGINFOD_LIBS@
|
|
CDEPS = $(NAT_CDEPS) $(SIM) $(BFD) $(READLINE_DEPS) $(LIBCTF) \
|
|
$(OPCODES) $(INTL_DEPS) $(LIBIBERTY) $(CONFIG_DEPS) $(LIBGNU)
|
|
|
|
diff --git a/gdb/configure b/gdb/configure
|
|
--- a/gdb/configure
|
|
+++ b/gdb/configure
|
|
@@ -758,7 +758,11 @@ REPORT_BUGS_TEXI
|
|
REPORT_BUGS_TO
|
|
PKGVERSION
|
|
CODESIGN_CERT
|
|
-LIBDEBUGINFOD
|
|
+DEBUGINFOD_LIBS
|
|
+DEBUGINFOD_CFLAGS
|
|
+PKG_CONFIG_LIBDIR
|
|
+PKG_CONFIG_PATH
|
|
+PKG_CONFIG
|
|
HAVE_NATIVE_GCORE_TARGET
|
|
TARGET_OBS
|
|
subdirs
|
|
@@ -937,6 +941,9 @@ MAKEINFOFLAGS
|
|
PKG_CONFIG
|
|
PKG_CONFIG_PATH
|
|
PKG_CONFIG_LIBDIR
|
|
+PKG_CONFIG_CFLAGS
|
|
+DEBUGINFOD_CFLAGS
|
|
+DEBUGINFOD_LIBS
|
|
RPM_CFLAGS
|
|
RPM_LIBS
|
|
YACC
|
|
@@ -1683,6 +1690,10 @@ Some influential environment variables:
|
|
directories to add to pkg-config's search path
|
|
PKG_CONFIG_LIBDIR
|
|
path overriding pkg-config's built-in search path
|
|
+ DEBUGINFOD_CFLAGS
|
|
+ C compiler flags for DEBUGINFOD, overriding pkg-config
|
|
+ DEBUGINFOD_LIBS
|
|
+ linker flags for DEBUGINFOD, overriding pkg-config
|
|
RPM_CFLAGS C compiler flags for RPM, overriding pkg-config
|
|
RPM_LIBS linker flags for RPM, overriding pkg-config
|
|
YACC The `Yet Another Compiler Compiler' implementation to use.
|
|
@@ -2275,52 +2286,6 @@ rm -f conftest.val
|
|
|
|
} # ac_fn_c_compute_int
|
|
|
|
-# ac_fn_c_check_decl LINENO SYMBOL VAR INCLUDES
|
|
-# ---------------------------------------------
|
|
-# Tests whether SYMBOL is declared in INCLUDES, setting cache variable VAR
|
|
-# accordingly.
|
|
-ac_fn_c_check_decl ()
|
|
-{
|
|
- as_lineno=${as_lineno-"$1"} as_lineno_stack=as_lineno_stack=$as_lineno_stack
|
|
- as_decl_name=`echo $2|sed 's/ *(.*//'`
|
|
- as_decl_use=`echo $2|sed -e 's/(/((/' -e 's/)/) 0&/' -e 's/,/) 0& (/g'`
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $as_decl_name is declared" >&5
|
|
-$as_echo_n "checking whether $as_decl_name is declared... " >&6; }
|
|
-if eval \${$3+:} false; then :
|
|
- $as_echo_n "(cached) " >&6
|
|
-else
|
|
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
-/* end confdefs.h. */
|
|
-$4
|
|
-int
|
|
-main ()
|
|
-{
|
|
-#ifndef $as_decl_name
|
|
-#ifdef __cplusplus
|
|
- (void) $as_decl_use;
|
|
-#else
|
|
- (void) $as_decl_name;
|
|
-#endif
|
|
-#endif
|
|
-
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-if ac_fn_c_try_compile "$LINENO"; then :
|
|
- eval "$3=yes"
|
|
-else
|
|
- eval "$3=no"
|
|
-fi
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
-fi
|
|
-eval ac_res=\$$3
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_res" >&5
|
|
-$as_echo "$ac_res" >&6; }
|
|
- eval $as_lineno_stack; ${as_lineno_stack:+:} unset as_lineno
|
|
-
|
|
-} # ac_fn_c_check_decl
|
|
-
|
|
# ac_fn_c_check_func LINENO FUNC VAR
|
|
# ----------------------------------
|
|
# Tests whether FUNC exists, setting the cache variable VAR accordingly
|
|
@@ -2388,6 +2353,52 @@ $as_echo "$ac_res" >&6; }
|
|
|
|
} # ac_fn_c_check_func
|
|
|
|
+# ac_fn_c_check_decl LINENO SYMBOL VAR INCLUDES
|
|
+# ---------------------------------------------
|
|
+# Tests whether SYMBOL is declared in INCLUDES, setting cache variable VAR
|
|
+# accordingly.
|
|
+ac_fn_c_check_decl ()
|
|
+{
|
|
+ as_lineno=${as_lineno-"$1"} as_lineno_stack=as_lineno_stack=$as_lineno_stack
|
|
+ as_decl_name=`echo $2|sed 's/ *(.*//'`
|
|
+ as_decl_use=`echo $2|sed -e 's/(/((/' -e 's/)/) 0&/' -e 's/,/) 0& (/g'`
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $as_decl_name is declared" >&5
|
|
+$as_echo_n "checking whether $as_decl_name is declared... " >&6; }
|
|
+if eval \${$3+:} false; then :
|
|
+ $as_echo_n "(cached) " >&6
|
|
+else
|
|
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
+/* end confdefs.h. */
|
|
+$4
|
|
+int
|
|
+main ()
|
|
+{
|
|
+#ifndef $as_decl_name
|
|
+#ifdef __cplusplus
|
|
+ (void) $as_decl_use;
|
|
+#else
|
|
+ (void) $as_decl_name;
|
|
+#endif
|
|
+#endif
|
|
+
|
|
+ ;
|
|
+ return 0;
|
|
+}
|
|
+_ACEOF
|
|
+if ac_fn_c_try_compile "$LINENO"; then :
|
|
+ eval "$3=yes"
|
|
+else
|
|
+ eval "$3=no"
|
|
+fi
|
|
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
+fi
|
|
+eval ac_res=\$$3
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_res" >&5
|
|
+$as_echo "$ac_res" >&6; }
|
|
+ eval $as_lineno_stack; ${as_lineno_stack:+:} unset as_lineno
|
|
+
|
|
+} # ac_fn_c_check_decl
|
|
+
|
|
# ac_fn_c_check_member LINENO AGGR MEMBER VAR INCLUDES
|
|
# ----------------------------------------------------
|
|
# Tries to find if the field MEMBER exists in type AGGR, after including
|
|
@@ -7338,7 +7349,127 @@ esac
|
|
|
|
# Handle optional debuginfod support
|
|
|
|
-# Enable debuginfod
|
|
+
|
|
+
|
|
+
|
|
+
|
|
+
|
|
+
|
|
+if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
|
|
+ if test -n "$ac_tool_prefix"; then
|
|
+ # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
|
|
+set dummy ${ac_tool_prefix}pkg-config; ac_word=$2
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
|
+$as_echo_n "checking for $ac_word... " >&6; }
|
|
+if ${ac_cv_path_PKG_CONFIG+:} false; then :
|
|
+ $as_echo_n "(cached) " >&6
|
|
+else
|
|
+ case $PKG_CONFIG in
|
|
+ [\\/]* | ?:[\\/]*)
|
|
+ ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
|
|
+ ;;
|
|
+ *)
|
|
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
|
+for as_dir in $PATH
|
|
+do
|
|
+ IFS=$as_save_IFS
|
|
+ test -z "$as_dir" && as_dir=.
|
|
+ for ac_exec_ext in '' $ac_executable_extensions; do
|
|
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
|
+ ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
|
|
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
|
+ break 2
|
|
+ fi
|
|
+done
|
|
+ done
|
|
+IFS=$as_save_IFS
|
|
+
|
|
+ ;;
|
|
+esac
|
|
+fi
|
|
+PKG_CONFIG=$ac_cv_path_PKG_CONFIG
|
|
+if test -n "$PKG_CONFIG"; then
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PKG_CONFIG" >&5
|
|
+$as_echo "$PKG_CONFIG" >&6; }
|
|
+else
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+fi
|
|
+
|
|
+
|
|
+fi
|
|
+if test -z "$ac_cv_path_PKG_CONFIG"; then
|
|
+ ac_pt_PKG_CONFIG=$PKG_CONFIG
|
|
+ # Extract the first word of "pkg-config", so it can be a program name with args.
|
|
+set dummy pkg-config; ac_word=$2
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
|
+$as_echo_n "checking for $ac_word... " >&6; }
|
|
+if ${ac_cv_path_ac_pt_PKG_CONFIG+:} false; then :
|
|
+ $as_echo_n "(cached) " >&6
|
|
+else
|
|
+ case $ac_pt_PKG_CONFIG in
|
|
+ [\\/]* | ?:[\\/]*)
|
|
+ ac_cv_path_ac_pt_PKG_CONFIG="$ac_pt_PKG_CONFIG" # Let the user override the test with a path.
|
|
+ ;;
|
|
+ *)
|
|
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
|
+for as_dir in $PATH
|
|
+do
|
|
+ IFS=$as_save_IFS
|
|
+ test -z "$as_dir" && as_dir=.
|
|
+ for ac_exec_ext in '' $ac_executable_extensions; do
|
|
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
|
+ ac_cv_path_ac_pt_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
|
|
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
|
+ break 2
|
|
+ fi
|
|
+done
|
|
+ done
|
|
+IFS=$as_save_IFS
|
|
+
|
|
+ ;;
|
|
+esac
|
|
+fi
|
|
+ac_pt_PKG_CONFIG=$ac_cv_path_ac_pt_PKG_CONFIG
|
|
+if test -n "$ac_pt_PKG_CONFIG"; then
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_PKG_CONFIG" >&5
|
|
+$as_echo "$ac_pt_PKG_CONFIG" >&6; }
|
|
+else
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+fi
|
|
+
|
|
+ if test "x$ac_pt_PKG_CONFIG" = x; then
|
|
+ PKG_CONFIG=""
|
|
+ else
|
|
+ case $cross_compiling:$ac_tool_warned in
|
|
+yes:)
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
|
|
+$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
|
|
+ac_tool_warned=yes ;;
|
|
+esac
|
|
+ PKG_CONFIG=$ac_pt_PKG_CONFIG
|
|
+ fi
|
|
+else
|
|
+ PKG_CONFIG="$ac_cv_path_PKG_CONFIG"
|
|
+fi
|
|
+
|
|
+fi
|
|
+if test -n "$PKG_CONFIG"; then
|
|
+ _pkg_min_version=0.9.0
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking pkg-config is at least version $_pkg_min_version" >&5
|
|
+$as_echo_n "checking pkg-config is at least version $_pkg_min_version... " >&6; }
|
|
+ if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
|
+$as_echo "yes" >&6; }
|
|
+ else
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+ PKG_CONFIG=""
|
|
+ fi
|
|
+fi
|
|
+
|
|
+# Handle optional debuginfod support
|
|
|
|
# Check whether --with-debuginfod was given.
|
|
if test "${with_debuginfod+set}" = set; then :
|
|
@@ -7352,72 +7483,93 @@ $as_echo_n "checking whether to use debuginfod... " >&6; }
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $with_debuginfod" >&5
|
|
$as_echo "$with_debuginfod" >&6; }
|
|
|
|
-if test "${with_debuginfod}" = no; then
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: debuginfod support disabled; some features may be unavailable." >&5
|
|
-$as_echo "$as_me: WARNING: debuginfod support disabled; some features may be unavailable." >&2;}
|
|
-else
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for debuginfod_begin in -ldebuginfod" >&5
|
|
-$as_echo_n "checking for debuginfod_begin in -ldebuginfod... " >&6; }
|
|
-if ${ac_cv_lib_debuginfod_debuginfod_begin+:} false; then :
|
|
- $as_echo_n "(cached) " >&6
|
|
-else
|
|
- ac_check_lib_save_LIBS=$LIBS
|
|
-LIBS="-ldebuginfod $LIBS"
|
|
-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
-/* end confdefs.h. */
|
|
+if test "x$with_debuginfod" != xno; then
|
|
|
|
-/* Override any GCC internal prototype to avoid an error.
|
|
- Use char because int might match the return type of a GCC
|
|
- builtin and then its argument prototype would still apply. */
|
|
-#ifdef __cplusplus
|
|
-extern "C"
|
|
-#endif
|
|
-char debuginfod_begin ();
|
|
-int
|
|
-main ()
|
|
-{
|
|
-return debuginfod_begin ();
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-if ac_fn_c_try_link "$LINENO"; then :
|
|
- ac_cv_lib_debuginfod_debuginfod_begin=yes
|
|
+pkg_failed=no
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libdebuginfod >= 0.179" >&5
|
|
+$as_echo_n "checking for libdebuginfod >= 0.179... " >&6; }
|
|
+
|
|
+if test -n "$DEBUGINFOD_CFLAGS"; then
|
|
+ pkg_cv_DEBUGINFOD_CFLAGS="$DEBUGINFOD_CFLAGS"
|
|
+ elif test -n "$PKG_CONFIG"; then
|
|
+ if test -n "$PKG_CONFIG" && \
|
|
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libdebuginfod >= 0.179\""; } >&5
|
|
+ ($PKG_CONFIG --exists --print-errors "libdebuginfod >= 0.179") 2>&5
|
|
+ ac_status=$?
|
|
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
|
+ test $ac_status = 0; }; then
|
|
+ pkg_cv_DEBUGINFOD_CFLAGS=`$PKG_CONFIG --cflags "libdebuginfod >= 0.179" 2>/dev/null`
|
|
+ test "x$?" != "x0" && pkg_failed=yes
|
|
else
|
|
- ac_cv_lib_debuginfod_debuginfod_begin=no
|
|
+ pkg_failed=yes
|
|
fi
|
|
-rm -f core conftest.err conftest.$ac_objext \
|
|
- conftest$ac_exeext conftest.$ac_ext
|
|
-LIBS=$ac_check_lib_save_LIBS
|
|
+ else
|
|
+ pkg_failed=untried
|
|
+fi
|
|
+if test -n "$DEBUGINFOD_LIBS"; then
|
|
+ pkg_cv_DEBUGINFOD_LIBS="$DEBUGINFOD_LIBS"
|
|
+ elif test -n "$PKG_CONFIG"; then
|
|
+ if test -n "$PKG_CONFIG" && \
|
|
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libdebuginfod >= 0.179\""; } >&5
|
|
+ ($PKG_CONFIG --exists --print-errors "libdebuginfod >= 0.179") 2>&5
|
|
+ ac_status=$?
|
|
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
|
+ test $ac_status = 0; }; then
|
|
+ pkg_cv_DEBUGINFOD_LIBS=`$PKG_CONFIG --libs "libdebuginfod >= 0.179" 2>/dev/null`
|
|
+ test "x$?" != "x0" && pkg_failed=yes
|
|
+else
|
|
+ pkg_failed=yes
|
|
fi
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_debuginfod_debuginfod_begin" >&5
|
|
-$as_echo "$ac_cv_lib_debuginfod_debuginfod_begin" >&6; }
|
|
-if test "x$ac_cv_lib_debuginfod_debuginfod_begin" = xyes; then :
|
|
- have_debuginfod_lib=yes
|
|
+ else
|
|
+ pkg_failed=untried
|
|
fi
|
|
|
|
- ac_fn_c_check_decl "$LINENO" "debuginfod_begin" "ac_cv_have_decl_debuginfod_begin" "#include <elfutils/debuginfod.h>
|
|
-"
|
|
-if test "x$ac_cv_have_decl_debuginfod_begin" = xyes; then :
|
|
- have_debuginfod_h=yes
|
|
-fi
|
|
|
|
- if test "x$have_debuginfod_lib" = "xyes" -a \
|
|
- "x$have_debuginfod_h" = "xyes"; then
|
|
|
|
-$as_echo "#define HAVE_LIBDEBUGINFOD 1" >>confdefs.h
|
|
+if test $pkg_failed = yes; then
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
|
|
- LIBDEBUGINFOD="-ldebuginfod"
|
|
+if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
|
+ _pkg_short_errors_supported=yes
|
|
+else
|
|
+ _pkg_short_errors_supported=no
|
|
+fi
|
|
+ if test $_pkg_short_errors_supported = yes; then
|
|
+ DEBUGINFOD_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "libdebuginfod >= 0.179" 2>&1`
|
|
+ else
|
|
+ DEBUGINFOD_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "libdebuginfod >= 0.179" 2>&1`
|
|
+ fi
|
|
+ # Put the nasty error message in config.log where it belongs
|
|
+ echo "$DEBUGINFOD_PKG_ERRORS" >&5
|
|
|
|
- else
|
|
+ if test "x$with_debuginfod" = xyes; then
|
|
+ as_fn_error $? "\"--with-debuginfod was given, but libdebuginfod is missing or unusable.\"" "$LINENO" 5
|
|
+ else
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: libdebuginfod is missing or unusable; some features may be unavailable." >&5
|
|
+$as_echo "$as_me: WARNING: libdebuginfod is missing or unusable; some features may be unavailable." >&2;}
|
|
+ fi
|
|
+elif test $pkg_failed = untried; then
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
+$as_echo "no" >&6; }
|
|
+ if test "x$with_debuginfod" = xyes; then
|
|
+ as_fn_error $? "\"--with-debuginfod was given, but libdebuginfod is missing or unusable.\"" "$LINENO" 5
|
|
+ else
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: libdebuginfod is missing or unusable; some features may be unavailable." >&5
|
|
+$as_echo "$as_me: WARNING: libdebuginfod is missing or unusable; some features may be unavailable." >&2;}
|
|
+ fi
|
|
+else
|
|
+ DEBUGINFOD_CFLAGS=$pkg_cv_DEBUGINFOD_CFLAGS
|
|
+ DEBUGINFOD_LIBS=$pkg_cv_DEBUGINFOD_LIBS
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
|
+$as_echo "yes" >&6; }
|
|
|
|
- if test "$with_debuginfod" = yes; then
|
|
- as_fn_error $? "debuginfod is missing or unusable" "$LINENO" 5
|
|
- else
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: debuginfod is missing or unusable; some features may be unavailable." >&5
|
|
-$as_echo "$as_me: WARNING: debuginfod is missing or unusable; some features may be unavailable." >&2;}
|
|
- fi
|
|
- fi
|
|
+$as_echo "#define HAVE_LIBDEBUGINFOD 1" >>confdefs.h
|
|
+
|
|
+fi
|
|
+else
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: debuginfod support disabled; some features may be unavailable." >&5
|
|
+$as_echo "$as_me: WARNING: debuginfod support disabled; some features may be unavailable." >&2;}
|
|
fi
|
|
|
|
|