import gcc-toolset-10-elfutils-0.180-1.el8
This commit is contained in:
commit
351db152b7
1
.gcc-toolset-10-elfutils.metadata
Normal file
1
.gcc-toolset-10-elfutils.metadata
Normal file
@ -0,0 +1 @@
|
||||
c1ed871515b0f7fcdf2d94fea23e4b8ba67e8fe3 SOURCES/elfutils-0.180.tar.bz2
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/elfutils-0.180.tar.bz2
|
1305
SOURCES/elfutils-0.180-dts.patch
Normal file
1305
SOURCES/elfutils-0.180-dts.patch
Normal file
File diff suppressed because it is too large
Load Diff
52
SOURCES/elfutils-dts-libs-version.patch
Normal file
52
SOURCES/elfutils-dts-libs-version.patch
Normal file
@ -0,0 +1,52 @@
|
||||
diff --git a/debuginfod/Makefile.am b/debuginfod/Makefile.am
|
||||
index 52ead30a..9d7ce408 100644
|
||||
--- a/debuginfod/Makefile.am
|
||||
+++ b/debuginfod/Makefile.am
|
||||
@@ -34,7 +34,7 @@ AM_CPPFLAGS += -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
|
||||
-I$(srcdir)/../libdw -I$(srcdir)/../libdwelf \
|
||||
$(libmicrohttpd_CFLAGS) $(libcurl_CFLAGS) $(sqlite3_CFLAGS) \
|
||||
$(libarchive_CFLAGS)
|
||||
-VERSION = 1
|
||||
+VERSION = dts.1
|
||||
|
||||
# Disable eu- prefixing for artifacts (binaries & man pages) in this
|
||||
# directory, since they do not conflict with binutils tools.
|
||||
diff --git a/libasm/Makefile.am b/libasm/Makefile.am
|
||||
index a92b63ad..a92f06de 100644
|
||||
--- a/libasm/Makefile.am
|
||||
+++ b/libasm/Makefile.am
|
||||
@@ -31,7 +31,7 @@ include $(top_srcdir)/config/eu.am
|
||||
AM_CPPFLAGS += -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl -I$(top_srcdir)/libdw -I$(top_srcdir)/libdwelf
|
||||
|
||||
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
||||
-VERSION = 1
|
||||
+VERSION = dts.1
|
||||
|
||||
lib_LIBRARIES = libasm.a
|
||||
noinst_LIBRARIES = libasm_pic.a
|
||||
diff --git a/libdw/Makefile.am b/libdw/Makefile.am
|
||||
index ef566399..c6493a08 100644
|
||||
--- a/libdw/Makefile.am
|
||||
+++ b/libdw/Makefile.am
|
||||
@@ -32,7 +32,7 @@ if BUILD_STATIC
|
||||
AM_CFLAGS += $(fpic_CFLAGS)
|
||||
endif
|
||||
AM_CPPFLAGS += -I$(srcdir)/../libelf -I$(srcdir)/../libdwelf -pthread
|
||||
-VERSION = 1
|
||||
+VERSION = dts.1
|
||||
|
||||
lib_LIBRARIES = libdw.a
|
||||
noinst_LIBRARIES = libdw_pic.a
|
||||
diff --git a/libelf/Makefile.am b/libelf/Makefile.am
|
||||
index 51e86dc8..988d3ebe 100644
|
||||
--- a/libelf/Makefile.am
|
||||
+++ b/libelf/Makefile.am
|
||||
@@ -32,7 +32,7 @@ if BUILD_STATIC
|
||||
AM_CFLAGS += $(fpic_CFLAGS)
|
||||
endif
|
||||
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
||||
-VERSION = 1
|
||||
+VERSION = dts.1
|
||||
|
||||
lib_LIBRARIES = libelf.a
|
||||
noinst_LIBRARIES = libelf_pic.a
|
5
SOURCES/libasm.a
Normal file
5
SOURCES/libasm.a
Normal file
@ -0,0 +1,5 @@
|
||||
/* GNU ld script
|
||||
|
||||
Libraries in Developer Toolset are linked in statically to allow
|
||||
compiled binaries to run even when DTS is not installed. */
|
||||
INPUT(libasm.ar)
|
5
SOURCES/libasm.so
Normal file
5
SOURCES/libasm.so
Normal file
@ -0,0 +1,5 @@
|
||||
/* GNU ld script
|
||||
|
||||
Libraries in Developer Toolset are linked in statically to allow
|
||||
compiled binaries to run even when DTS is not installed. */
|
||||
INPUT(libasm.ar)
|
7
SOURCES/libdebuginfod.a
Normal file
7
SOURCES/libdebuginfod.a
Normal file
@ -0,0 +1,7 @@
|
||||
/* GNU ld script
|
||||
|
||||
Static libraries in Developer Toolset are named .ar to prevent
|
||||
brp-strip-static-archive from stripping them. But we still want
|
||||
them to be found in cases like -static -lxyz, hence this linker
|
||||
script. */
|
||||
INPUT(libdebuginfod.ar)
|
6
SOURCES/libdebuginfod.so
Normal file
6
SOURCES/libdebuginfod.so
Normal file
@ -0,0 +1,6 @@
|
||||
/* GNU ld script
|
||||
|
||||
Libraries in Developer Toolset are linked in statically to allow
|
||||
compiled binaries to run even when DTS is not installed. */
|
||||
INPUT(libdebuginfod.ar)
|
||||
INPUT(-lcurl)
|
7
SOURCES/libdw.a
Normal file
7
SOURCES/libdw.a
Normal file
@ -0,0 +1,7 @@
|
||||
/* GNU ld script
|
||||
|
||||
Static libraries in Developer Toolset are named .ar to prevent
|
||||
brp-strip-static-archive from stripping them. But we still want
|
||||
them to be found in cases like -static -lxyz, hence this linker
|
||||
script. */
|
||||
GROUP(libdw.ar -lpthread -ldl)
|
7
SOURCES/libdw.so
Normal file
7
SOURCES/libdw.so
Normal file
@ -0,0 +1,7 @@
|
||||
/* GNU ld script
|
||||
|
||||
Libraries in Developer Toolset are linked in statically to allow
|
||||
compiled binaries to run even when DTS is not installed. */
|
||||
GROUP(libdw.ar -lpthread -ldl)
|
||||
INPUT(-llzma -lbz2 -lz)
|
||||
INPUT(-lelf)
|
7
SOURCES/libelf.a
Normal file
7
SOURCES/libelf.a
Normal file
@ -0,0 +1,7 @@
|
||||
/* GNU ld script
|
||||
|
||||
Static libraries in Developer Toolset are named .ar to prevent
|
||||
brp-strip-static-archive from stripping them. But we still want
|
||||
them to be found in cases like -static -lxyz, hence this linker
|
||||
script. */
|
||||
INPUT(libelf.ar)
|
6
SOURCES/libelf.so
Normal file
6
SOURCES/libelf.so
Normal file
@ -0,0 +1,6 @@
|
||||
/* GNU ld script
|
||||
|
||||
Libraries in Developer Toolset are linked in statically to allow
|
||||
compiled binaries to run even when DTS is not installed. */
|
||||
INPUT(libelf.ar)
|
||||
INPUT(-lz)
|
1441
SPECS/elfutils.spec
Normal file
1441
SPECS/elfutils.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user