New upstream release 1.5

Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
This commit is contained in:
Marc-André Lureau 2022-08-05 11:16:23 +04:00
parent a07082f258
commit 5651be3c72
5 changed files with 39 additions and 106 deletions

View File

@ -1,51 +0,0 @@
From 3365b4bd58dd7f13e786caf3c7234cf8116263d9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
Date: Wed, 25 Jul 2018 12:45:24 +0200
Subject: [PATCH] gcab: Fix regression from commit a15d91073fd5d6be25
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Apparently, rewinding should reset the CDATA state.
See also:
https://bugzilla.redhat.com/show_bug.cgi?id=1608301
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
---
libgcab/gcab-folder.c | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/libgcab/gcab-folder.c b/libgcab/gcab-folder.c
index 1b09fa3..c0d6600 100644
--- a/libgcab/gcab-folder.c
+++ b/libgcab/gcab-folder.c
@@ -423,6 +423,7 @@ gcab_folder_extract (GCabFolder *self,
g_autoptr(GSList) files = NULL;
g_autoptr(cdata_t) cdata = g_new0 (cdata_t, 1);
guint32 nubytes = 0;
+ guint8 *reserved;
/* never loaded from a stream */
g_assert (self->cfolder != NULL);
@@ -433,7 +434,7 @@ gcab_folder_extract (GCabFolder *self,
files = g_slist_sort (g_slist_copy (self->files), (GCompareFunc)sort_by_offset);
/* this is allocated for every block, but currently unused */
- cdata->reserved = g_malloc (res_data);
+ cdata->reserved = reserved = g_malloc (res_data);
for (f = files; f != NULL; f = f->next) {
GCabFile *file = f->data;
@@ -454,6 +455,8 @@ gcab_folder_extract (GCabFolder *self,
if (!g_seekable_seek (G_SEEKABLE (data), self->cfolder->offsetdata,
G_SEEK_SET, cancellable, error))
return FALSE;
+ bzero(cdata, sizeof(cdata_t));
+ cdata->reserved = reserved;
nubytes = 0;
}
--
2.18.0.321.gffc6fa0e39

View File

@ -0,0 +1,32 @@
From 15464009a220b67543787a9dbbbdbef4704be3fc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
Date: Fri, 5 Aug 2022 11:13:41 +0400
Subject: [PATCH] meson: git version is optional
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Fix commit a755e2ae77035aad9644adadaec5ecf15e9656ba ("meson: fix new
warning about run_command()")
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 15fd5cd..5eba715 100644
--- a/meson.build
+++ b/meson.build
@@ -8,7 +8,7 @@ project('gcab', 'c',
git_version = []
git = find_program('git', required: false)
if git.found()
- git_version = run_command(git, 'describe', '--abbrev=4', '--dirty', check: true).stdout().strip().split('-')
+ git_version = run_command(git, 'describe', '--abbrev=4', '--dirty', check: false).stdout().strip().split('-')
endif
# libtool versioning
--
2.37.1

View File

@ -1,52 +0,0 @@
From 5619f4cd2ca3108c8dea17ba656b5ce44a60ca29 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
Date: Fri, 11 Jan 2019 19:42:40 +0400
Subject: [PATCH] Revert "decomp: fix gcc warning strict-overflow"
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The warning doesn't happen with current build-sys.
The overlapping behaviour is undefined with memcpy. memmove doesn't
have the same semantic either than the loop. Let's revert!
Fixes:
https://gitlab.gnome.org/GNOME/gcab/issues/12
This reverts commit e48074952743f53d8ac529d4debc421e7e0f6937.
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
---
libgcab/decomp.c | 8 ++------
1 file changed, 2 insertions(+), 6 deletions(-)
diff --git a/libgcab/decomp.c b/libgcab/decomp.c
index 64d97f8..0c2b184 100644
--- a/libgcab/decomp.c
+++ b/libgcab/decomp.c
@@ -1015,9 +1015,7 @@ int LZXfdi_decomp(int inlen, int outlen, fdi_decomp_state *decomp_state) {
window_posn += match_length;
/* copy match data - no worries about destination wraps */
- memcpy(rundest, runsrc, match_length);
- rundest += match_length;
- runsrc += match_length;
+ while (match_length-- > 0) *rundest++ = *runsrc++;
}
}
break;
@@ -1106,9 +1104,7 @@ int LZXfdi_decomp(int inlen, int outlen, fdi_decomp_state *decomp_state) {
window_posn += match_length;
/* copy match data - no worries about destination wraps */
- memcpy(rundest, runsrc, match_length);
- rundest += match_length;
- runsrc += match_length;
+ while (match_length-- > 0) *rundest++ = *runsrc++;
}
}
break;
--
2.20.1.98.gecbdaf0899

View File

@ -1,12 +1,13 @@
Name: gcab
Version: 1.4
Release: 7%{?dist}
Version: 1.5
Release: 1%{?dist}
Summary: Cabinet file library and tool
License: LGPLv2+
#VCS: git:git://git.gnome.org/gcab
URL: http://ftp.gnome.org/pub/GNOME/sources/gcab
Source0: http://ftp.gnome.org/pub/GNOME/sources/gcab/%{version}/%{name}-%{version}.tar.xz
Patch0000: 0001-meson-git-version-is-optional.patch
BuildRequires: git-core
BuildRequires: gettext
@ -77,6 +78,9 @@ Libraries, includes, etc. to compile with the gcab library.
%{_libdir}/pkgconfig/libgcab-1.0.pc
%changelog
* Fri Aug 05 2022 Marc-André Lureau <marcandre.lureau@redhat.com> - 1.5-1
- new version
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (gcab-1.4.tar.xz) = 66a2e0d0a5888c555153356ce808f602053e71b76af19794db7e3bbf9516fe791805068838b4e208698cd645ada7a08610ac95f846fa81e00a9b955016306299
SHA512 (gcab-1.5.tar.xz) = 2a9b7d2720abbb5527d478ac760898ae254d08b7aa929fbb21753296e5a07c51d62e134a3f8b1b21d9b557d4093505194e09823ddbaf58465d37b372f37534b7