0.7 release update
This commit is contained in:
parent
16ffc9e76b
commit
378eafd083
@ -1,31 +0,0 @@
|
||||
From 258e58715f404964a8417b2235431f565ae295e2 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@gmail.com>
|
||||
Date: Thu, 30 Jul 2015 23:45:28 +0200
|
||||
Subject: [PATCH] gcab-file: fix wrong file modification day
|
||||
|
||||
The day of the struct tm is not (0-30) but (1-31), no need to add +1!
|
||||
This fixes creation of cabinet file and MSI that Windows Installer
|
||||
rejects because of invalid date (29-02-2005 for ex).
|
||||
|
||||
See bug:
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=753040
|
||||
---
|
||||
libgcab/gcab-file.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libgcab/gcab-file.c b/libgcab/gcab-file.c
|
||||
index d97539d..b55fbb5 100644
|
||||
--- a/libgcab/gcab-file.c
|
||||
+++ b/libgcab/gcab-file.c
|
||||
@@ -142,7 +142,7 @@ gcab_file_update_info (GCabFile *self, GFileInfo *info)
|
||||
self->cfile.usize = g_file_info_get_size (info);
|
||||
self->cfile.fattr = GCAB_FILE_ATTRIBUTE_ARCH;
|
||||
self->cfile.date = ((m->tm_year + 1900 - 1980 ) << 9 ) +
|
||||
- ((m->tm_mon+1) << 5 ) + (m->tm_mday+1);
|
||||
+ ((m->tm_mon+1) << 5 ) + (m->tm_mday);
|
||||
self->cfile.time = (m->tm_hour << 11) + (m->tm_min << 5) + (m->tm_sec / 2);
|
||||
|
||||
return TRUE;
|
||||
--
|
||||
2.4.3
|
||||
|
12
gcab.spec
12
gcab.spec
@ -1,13 +1,12 @@
|
||||
Name: gcab
|
||||
Version: 0.6
|
||||
Release: 6%{?dist}
|
||||
Version: 0.7
|
||||
Release: 1%{?dist}
|
||||
Summary: Cabinet file library and tool
|
||||
|
||||
License: LGPLv2+
|
||||
#VCS: git:git://git.gnome.org/gcab
|
||||
URL: http://ftp.gnome.org/pub/GNOME/sources/gcab
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/gcab/%{version}/%{name}-%{version}.tar.xz
|
||||
Patch0: 0001-gcab-file-fix-wrong-file-modification-day.patch
|
||||
|
||||
BuildRequires: intltool
|
||||
BuildRequires: vala-tools
|
||||
@ -37,11 +36,9 @@ Libraries, includes, etc. to compile with the gcab library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
# --enable-fast-install is needed to fix libtool "cannot relink `gcab'"
|
||||
%configure --disable-silent-rules --disable-static --enable-fast-install
|
||||
%configure --disable-silent-rules --disable-static
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
@ -75,6 +72,9 @@ rm -f %{buildroot}%{_libdir}/*.la
|
||||
%{_libdir}/pkgconfig/libgcab-1.0.pc
|
||||
|
||||
%changelog
|
||||
* Wed Mar 09 2016 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.7-1
|
||||
- 0.7 release update.
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user