auto-import changelog data from gc-6.2-0.fdr.3.rh80.src.rpm
6.2-0.fdr.3 - OK, put manpage in man3. 6.2-0.fdr.2 - drop manpage pending feedback from developer. 6.2-0.fdr.1 - fix manpage location - remove .la file (it appears unnecessary after all, thanks to opendl patch) - remove cvs tag from description - touchup -devel desc/summary. - macro update to support Fedora Core 6.2-0.fdr.0 - 6.2 release. - update license (BSD) - Consider building with: --enable-parallel-mark (for now, no).
This commit is contained in:
parent
1882b007bd
commit
b9e4ab6524
@ -0,0 +1 @@
|
||||
gc6.2.tar.gz
|
55
gc-6.2-opendl.patch
Normal file
55
gc-6.2-opendl.patch
Normal file
@ -0,0 +1,55 @@
|
||||
--- gc6.2/Makefile.am.dl 2003-06-13 13:25:35.000000000 -0500
|
||||
+++ gc6.2/Makefile.am 2003-09-11 14:15:56.000000000 -0500
|
||||
@@ -55,7 +55,7 @@
|
||||
|
||||
# Include THREADLIBS here to ensure that the correct versions of
|
||||
# linuxthread semaphore functions get linked:
|
||||
-libgc_la_LIBADD = @addobjs@ $(THREADLIBS)
|
||||
+libgc_la_LIBADD = @addobjs@ $(THREADLIBS) $(EXTRA_TEST_LIBS)
|
||||
libgc_la_DEPENDENCIES = @addobjs@
|
||||
libgc_la_LDFLAGS = -version-info 1:2:0
|
||||
|
||||
@@ -91,9 +91,9 @@
|
||||
## are included in the distribution
|
||||
# gctest_OBJECTS = test.o
|
||||
gctest_SOURCES = tests/test.c
|
||||
-gctest_LDADD = ./libgc.la $(THREADLIBS) $(EXTRA_TEST_LIBS)
|
||||
+gctest_LDADD = ./libgc.la
|
||||
test_cpp_SOURCES = tests/test_cpp.cc
|
||||
-test_cpp_LDADD = ./libgc.la ./libgccpp.la $(THREADLIBS) $(EXTRA_TEST_LIBS)
|
||||
+test_cpp_LDADD = ./libgc.la ./libgccpp.la
|
||||
|
||||
TESTS = gctest $(extra_checks)
|
||||
|
||||
--- gc6.2/Makefile.in.dl 2003-06-21 17:47:00.000000000 -0500
|
||||
+++ gc6.2/Makefile.in 2003-09-11 14:18:46.000000000 -0500
|
||||
@@ -188,7 +188,7 @@
|
||||
|
||||
# Include THREADLIBS here to ensure that the correct versions of
|
||||
# linuxthread semaphore functions get linked:
|
||||
-libgc_la_LIBADD = @addobjs@ $(THREADLIBS)
|
||||
+libgc_la_LIBADD = @addobjs@ $(THREADLIBS) $(EXTRA_TEST_LIBS)
|
||||
libgc_la_DEPENDENCIES = @addobjs@
|
||||
libgc_la_LDFLAGS = -version-info 1:2:0
|
||||
|
||||
@@ -199,7 +199,7 @@
|
||||
|
||||
|
||||
libgccpp_la_SOURCES = gc_cpp.cc
|
||||
-libgccpp_la_LIBADD = $(THREADLIBS)
|
||||
+libgccpp_la_LIBADD = $(THREADLIBS) $(EXTRA_TEST_LIBS)
|
||||
libgccpp_la_LDFLAGS = -version-info 1:2:0
|
||||
|
||||
AM_CXXFLAGS = @GC_CFLAGS@
|
||||
@@ -212,9 +212,9 @@
|
||||
|
||||
# gctest_OBJECTS = test.o
|
||||
gctest_SOURCES = tests/test.c
|
||||
-gctest_LDADD = ./libgc.la $(THREADLIBS) $(EXTRA_TEST_LIBS)
|
||||
+gctest_LDADD = ./libgc.la
|
||||
test_cpp_SOURCES = tests/test_cpp.cc
|
||||
-test_cpp_LDADD = ./libgc.la ./libgccpp.la $(THREADLIBS) $(EXTRA_TEST_LIBS)
|
||||
+test_cpp_LDADD = ./libgc.la ./libgccpp.la
|
||||
|
||||
TESTS = gctest $(extra_checks)
|
||||
|
116
gc.spec
Normal file
116
gc.spec
Normal file
@ -0,0 +1,116 @@
|
||||
# $Id: gc.spec,v 1.1 2004/11/08 04:21:39 cvsextras Exp $
|
||||
|
||||
## kde-redhat macros BEGIN
|
||||
%if "%(grep "Red Hat Linux" /etc/redhat-release )" != "%{nil}"
|
||||
# legacy Red Hat Linux releases
|
||||
%define rhrelease %(perl -pe '/(\\d+)\\.?(\\d+)?/; $_="$1".($2||0)' /etc/redhat-release )
|
||||
%define release_tag .fdr.%{fedora_release}.rh%{rhrelease}
|
||||
%else
|
||||
# Fedore Core
|
||||
%define rhrelease %(perl -pe '/(\\d+)\\.?(\\d+)?/; $_="$1".(defined($2)&&".$2")' /etc/redhat-release )
|
||||
%define release_tag .fdr.%{fedora_release}.%{rhrelease}
|
||||
%endif
|
||||
# rpmbuild --without rhrelease to avoid the mess.
|
||||
%{?_without_rhrelease:%define release_tag .fdr.%{fedora_release}}
|
||||
## kde-redhat macros END
|
||||
|
||||
# pkg/rpm release. Increment for each new version/release
|
||||
%define fedora_release 3
|
||||
|
||||
Summary: C++ Garbage Collector
|
||||
Name: gc
|
||||
Epoch: 0
|
||||
Version: 6.2
|
||||
Release: 0%{?release_tag}.rh80
|
||||
Group: System Environment/Libraries
|
||||
License: BSD
|
||||
Url: http://www.hpl.hp.com/personal/Hans_Boehm/gc/
|
||||
Source: http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc6.2.tar.gz
|
||||
Prefix: %{_prefix}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
|
||||
Patch1: gc-6.2-opendl.patch
|
||||
|
||||
%description
|
||||
The Boehm-Demers-Weiser conservative garbage collector can be used as a garbage
|
||||
collecting replacement for C malloc or C++ new.
|
||||
|
||||
%package devel
|
||||
Summary: Libraries and header files for gc development
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
%description devel
|
||||
Libraries and header files for gc development.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}%{version}%{?beta}
|
||||
|
||||
%patch1 -p1 -b .dl
|
||||
|
||||
|
||||
%build
|
||||
|
||||
%configure \
|
||||
--enable-cplusplus
|
||||
# --enable-parallel-mark
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
make check
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make install DESTDIR="$RPM_BUILD_ROOT"
|
||||
|
||||
install -p -D -m644 doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
|
||||
|
||||
## Unpackaged files
|
||||
rm -rf $RPM_BUILD_ROOT%{_datadir}/gc
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf "$RPM_BUILD_ROOT"
|
||||
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc doc/README doc/README.changes doc/README.contributors
|
||||
%{_libdir}/lib*.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%doc doc/*.html
|
||||
%{_includedir}/*
|
||||
%{_libdir}/lib*.so
|
||||
%{_libdir}/lib*.*a
|
||||
%{_mandir}/man?/*
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Oct 02 2003 Rex Dieter <rexdieter at sf.net> 0:6.2-0.fdr.3
|
||||
- OK, put manpage in man3.
|
||||
|
||||
* Thu Oct 02 2003 Rex Dieter <rexdieter at sf.net> 0:6.2-0.fdr.2
|
||||
- drop manpage pending feedback from developer.
|
||||
|
||||
* Tue Sep 30 2003 Rex Dieter <rexdieter at sf.net> 0:6.2-0.fdr.1
|
||||
- fix manpage location
|
||||
- remove .la file (it appears unnecessary after all, thanks to opendl patch)
|
||||
- remove cvs tag from description
|
||||
- touchup -devel desc/summary.
|
||||
- macro update to support Fedora Core
|
||||
|
||||
* Thu Sep 11 2003 Rex Dieter <rexdieter at sf.net> 0:6.2-0.fdr.0
|
||||
- 6.2 release.
|
||||
- update license (BSD)
|
||||
- Consider building with: --enable-parallel-mark
|
||||
(for now, no).
|
||||
|
Loading…
Reference in New Issue
Block a user