- gcc(4.1) patch

This commit is contained in:
Rex Dieter 2006-02-10 13:15:41 +00:00
parent 3467aad4a4
commit 8ecd762246
2 changed files with 18 additions and 3 deletions

11
gc-6.6-gcc41.patch Normal file
View File

@ -0,0 +1,11 @@
--- gc6.6/include/gc_cpp.h.gcc41 2004-10-21 17:47:45.000000000 -0500
+++ gc6.6/include/gc_cpp.h 2006-02-10 07:12:07.000000000 -0600
@@ -180,7 +180,7 @@
inline void* operator new[]( size_t size, void *p );
inline void operator delete[]( void* obj );
# ifdef GC_PLACEMENT_DELETE
- inline void gc::operator delete[]( void*, void* );
+ inline void operator delete[]( void*, void* );
# endif
#endif /* GC_OPERATOR_NEW_ARRAY */
};

10
gc.spec
View File

@ -3,7 +3,7 @@ Summary: C++ Garbage Collector
Name: gc
Version: 6.6
Release: 4%{?dist}.1
Release: 5%{?dist}
Group: System Environment/Libraries
License: BSD
Url: http://www.hpl.hp.com/personal/Hans_Boehm/gc/
@ -12,6 +12,9 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# force no undefined symbols (#166344)
Patch1: gc-6.6-no-undefined.patch
# gcc(4.1) patch
Patch2: gc-6.6-gcc41.patch
BuildRequires: libtool
BuildRequires: automake
@ -35,6 +38,7 @@ Libraries and header files for %{name} development.
%setup -q -n %{name}%{version}
%patch1 -p1 -b .no-undefined
%patch2 -p1 -b .gcc41
cp -f %{_datadir}/aclocal/libtool.m4 .
libtoolize --copy --force
@ -97,8 +101,8 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Fri Feb 10 2006 Rex Dieter <rexdieter[AT]users.sf.net> 6.6-4.1
- fc5: gcc/glibc respin
* Fri Feb 10 2006 Rex Dieter <rexdieter[AT]users.sf.net> 6.6-5
- gcc(4.1) patch
* Thu Dec 01 2005 Rex Dieter <rexdieter[AT]users.sf.net> 6.6-4
- Provides: libgc(-devel)