- BR: gawk
- fixup compat_header patch to avoid needing auto* tools
This commit is contained in:
parent
50a91f160c
commit
6946bd5e11
@ -1,18 +1,18 @@
|
|||||||
diff -up /dev/null gc-7.0/include/extra/gc.h
|
diff -up /dev/null gc-7.0/include/extra/gc.h
|
||||||
--- /dev/null 2007-08-28 14:44:51.958644302 -0500
|
--- /dev/null 2007-08-28 14:44:51.958644302 -0500
|
||||||
+++ gc-7.0/include/extra/gc.h 2007-08-29 10:02:34.000000000 -0500
|
+++ gc-7.0/include/extra/gc.h 2007-08-29 10:56:16.000000000 -0500
|
||||||
@@ -0,0 +1,2 @@
|
@@ -0,0 +1,2 @@
|
||||||
+/* This file is installed for backward compatibility. */
|
+/* This file is installed for backward compatibility. */
|
||||||
+#include <gc/gc.h>
|
+#include <gc/gc.h>
|
||||||
diff -up /dev/null gc-7.0/include/extra/gc_cpp.h
|
diff -up /dev/null gc-7.0/include/extra/gc_cpp.h
|
||||||
--- /dev/null 2007-08-28 14:44:51.958644302 -0500
|
--- /dev/null 2007-08-28 14:44:51.958644302 -0500
|
||||||
+++ gc-7.0/include/extra/gc_cpp.h 2007-08-29 10:02:34.000000000 -0500
|
+++ gc-7.0/include/extra/gc_cpp.h 2007-08-29 10:56:16.000000000 -0500
|
||||||
@@ -0,0 +1,2 @@
|
@@ -0,0 +1,2 @@
|
||||||
+/* This file is installed for backward compatibility. */
|
+/* This file is installed for backward compatibility. */
|
||||||
+#include <gc/gc_cpp.h>
|
+#include <gc/gc_cpp.h>
|
||||||
diff -up gc-7.0/include/include.am.compat_header gc-7.0/include/include.am
|
diff -up gc-7.0/include/include.am.compat_header gc-7.0/include/include.am
|
||||||
--- gc-7.0/include/include.am.compat_header 2005-10-10 17:33:34.000000000 -0500
|
--- gc-7.0/include/include.am.compat_header 2005-10-10 17:33:34.000000000 -0500
|
||||||
+++ gc-7.0/include/include.am 2007-08-29 10:03:21.000000000 -0500
|
+++ gc-7.0/include/include.am 2007-08-29 10:56:16.000000000 -0500
|
||||||
@@ -52,3 +52,9 @@ dist_noinst_HEADERS += \
|
@@ -52,3 +52,9 @@ dist_noinst_HEADERS += \
|
||||||
include/cord.h \
|
include/cord.h \
|
||||||
include/ec.h \
|
include/ec.h \
|
||||||
@ -23,3 +23,18 @@ diff -up gc-7.0/include/include.am.compat_header gc-7.0/include/include.am
|
|||||||
+ include/extra/gc.h \
|
+ include/extra/gc.h \
|
||||||
+ include/extra/gc_cpp.h
|
+ include/extra/gc_cpp.h
|
||||||
+
|
+
|
||||||
|
diff -up gc-7.0/Makefile.in.compat_header gc-7.0/Makefile.in
|
||||||
|
--- gc-7.0/Makefile.in.compat_header 2007-06-28 16:12:36.000000000 -0500
|
||||||
|
+++ gc-7.0/Makefile.in 2007-08-29 10:58:17.000000000 -0500
|
||||||
|
@@ -462,7 +462,10 @@ EXTRA_DIST = gc_cpp.cpp README.QUICK BCC
|
||||||
|
# C Library
|
||||||
|
# ---------
|
||||||
|
lib_LTLIBRARIES = libgc.la $(am__append_4) libcord.la
|
||||||
|
-include_HEADERS =
|
||||||
|
+# unprefixed header
|
||||||
|
+include_HEADERS = \
|
||||||
|
+ include/extra/gc.h \
|
||||||
|
+ include/extra/gc_cpp.h
|
||||||
|
|
||||||
|
# installed headers
|
||||||
|
#
|
||||||
|
11
gc.spec
11
gc.spec
@ -3,7 +3,7 @@ Summary: A garbage collector for C and C++
|
|||||||
Name: gc
|
Name: gc
|
||||||
Version: 7.0
|
Version: 7.0
|
||||||
|
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
Url: http://www.hpl.hp.com/personal/Hans_Boehm/gc/
|
Url: http://www.hpl.hp.com/personal/Hans_Boehm/gc/
|
||||||
@ -14,11 +14,12 @@ Patch1: gc-7.0-gcinit.patch
|
|||||||
# http://www.hpl.hp.com/hosted/linux/mail-archives/gc/2007-August/001838.html
|
# http://www.hpl.hp.com/hosted/linux/mail-archives/gc/2007-August/001838.html
|
||||||
Patch2: gc-7.0-compat_header.patch
|
Patch2: gc-7.0-compat_header.patch
|
||||||
|
|
||||||
|
BuildRequires: gawk
|
||||||
|
|
||||||
# rpmforge compatibility
|
# rpmforge compatibility
|
||||||
Obsoletes: libgc < %{version}-%{release}
|
Obsoletes: libgc < %{version}-%{release}
|
||||||
Provides: libgc = %{version}-%{release}
|
Provides: libgc = %{version}-%{release}
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The Boehm-Demers-Weiser conservative garbage collector can be
|
The Boehm-Demers-Weiser conservative garbage collector can be
|
||||||
used as a garbage collecting replacement for C malloc or C++ new.
|
used as a garbage collecting replacement for C malloc or C++ new.
|
||||||
@ -41,8 +42,6 @@ Provides: libgc-devel = %{version}-%{release}
|
|||||||
%patch2 -p1 -b .compat_header
|
%patch2 -p1 -b .compat_header
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
%configure \
|
%configure \
|
||||||
@ -100,6 +99,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 7.0-6
|
||||||
|
- BR: gawk
|
||||||
|
- fixup compat_header patch to avoid needing auto* tools
|
||||||
|
|
||||||
* Wed Aug 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 7.0-5
|
* Wed Aug 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 7.0-5
|
||||||
- compat_header patch (supercedes previous pkgconfig patch)
|
- compat_header patch (supercedes previous pkgconfig patch)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user