- gc-7.0
This commit is contained in:
parent
38511c65be
commit
55ef09a879
@ -1,2 +1,3 @@
|
|||||||
clog
|
clog
|
||||||
gc6.8.tar.gz
|
gc6.8.tar.gz
|
||||||
|
gc-7.0.tar.gz
|
||||||
|
@ -1,67 +0,0 @@
|
|||||||
--- gc6.7/Makefile.am.no-undefined 2006-02-18 18:50:37.000000000 -0600
|
|
||||||
+++ gc6.7/Makefile.am 2006-03-03 22:51:58.000000000 -0600
|
|
||||||
@@ -57,7 +57,7 @@
|
|
||||||
# linuxthread semaphore functions get linked:
|
|
||||||
libgc_la_LIBADD = @addobjs@ $(THREADDLLIBS) $(UNWINDLIBS)
|
|
||||||
libgc_la_DEPENDENCIES = @addobjs@
|
|
||||||
-libgc_la_LDFLAGS = -version-info 1:2:0
|
|
||||||
+libgc_la_LDFLAGS = -version-info 1:2:0 -no-undefined -Wl,--no-undefined
|
|
||||||
|
|
||||||
EXTRA_libgc_la_SOURCES = alpha_mach_dep.S \
|
|
||||||
mips_sgi_mach_dep.s mips_ultrix_mach_dep.s powerpc_darwin_mach_dep.s \
|
|
||||||
@@ -65,8 +65,8 @@
|
|
||||||
sparc_sunos4_mach_dep.s ia64_save_regs_in_stack.s
|
|
||||||
|
|
||||||
libgccpp_la_SOURCES = gc_cpp.cc
|
|
||||||
-libgccpp_la_LIBADD = $(THREADDLLIBS) $(UNWINDLIBS)
|
|
||||||
-libgccpp_la_LDFLAGS = -version-info 1:2:0
|
|
||||||
+libgccpp_la_LIBADD = ./libgc.la
|
|
||||||
+libgccpp_la_LDFLAGS = -version-info 1:2:0 -no-undefined -Wl,--no-undefined
|
|
||||||
|
|
||||||
EXTRA_DIST += alpha_mach_dep.S mips_sgi_mach_dep.s sparc_mach_dep.S
|
|
||||||
|
|
||||||
@@ -91,9 +91,9 @@
|
|
||||||
## are included in the distribution
|
|
||||||
# gctest_OBJECTS = test.o
|
|
||||||
gctest_SOURCES = tests/test.c
|
|
||||||
-gctest_LDADD = ./libgc.la $(THREADDLLIBS) $(UNWINDLIBS) $(EXTRA_TEST_LIBS)
|
|
||||||
+gctest_LDADD = ./libgc.la $(EXTRA_TEST_LIBS)
|
|
||||||
test_cpp_SOURCES = tests/test_cpp.cc
|
|
||||||
-test_cpp_LDADD = ./libgc.la ./libgccpp.la $(THREADDLLIBS) $(UNWINDLIBS) $(EXTRA_TEST_LIBS)
|
|
||||||
+test_cpp_LDADD = ./libgccpp.la $(EXTRA_TEST_LIBS)
|
|
||||||
|
|
||||||
TESTS = $(check_PROGRAMS)
|
|
||||||
|
|
||||||
--- gc6.7/Makefile.in.no-undefined 2006-02-18 18:50:57.000000000 -0600
|
|
||||||
+++ gc6.7/Makefile.in 2006-03-03 22:54:41.000000000 -0600
|
|
||||||
@@ -340,15 +340,15 @@
|
|
||||||
# linuxthread semaphore functions get linked:
|
|
||||||
libgc_la_LIBADD = @addobjs@ $(THREADDLLIBS) $(UNWINDLIBS)
|
|
||||||
libgc_la_DEPENDENCIES = @addobjs@
|
|
||||||
-libgc_la_LDFLAGS = -version-info 1:2:0
|
|
||||||
+libgc_la_LDFLAGS = -version-info 1:2:0 -no-undefined -Wl,--no-undefined
|
|
||||||
EXTRA_libgc_la_SOURCES = alpha_mach_dep.S \
|
|
||||||
mips_sgi_mach_dep.s mips_ultrix_mach_dep.s powerpc_darwin_mach_dep.s \
|
|
||||||
rs6000_mach_dep.s sparc_mach_dep.S sparc_netbsd_mach_dep.s \
|
|
||||||
sparc_sunos4_mach_dep.s ia64_save_regs_in_stack.s
|
|
||||||
|
|
||||||
libgccpp_la_SOURCES = gc_cpp.cc
|
|
||||||
-libgccpp_la_LIBADD = $(THREADDLLIBS) $(UNWINDLIBS)
|
|
||||||
-libgccpp_la_LDFLAGS = -version-info 1:2:0
|
|
||||||
+libgccpp_la_LIBADD = ./libgc.la
|
|
||||||
+libgccpp_la_LDFLAGS = -version-info 1:2:0 -no-undefined -Wl,--no-undefined
|
|
||||||
AM_CXXFLAGS = @GC_CFLAGS@
|
|
||||||
AM_CFLAGS = @GC_CFLAGS@
|
|
||||||
@CPLUSPLUS_FALSE@extra_checks =
|
|
||||||
@@ -356,9 +356,9 @@
|
|
||||||
|
|
||||||
# gctest_OBJECTS = test.o
|
|
||||||
gctest_SOURCES = tests/test.c
|
|
||||||
-gctest_LDADD = ./libgc.la $(THREADDLLIBS) $(UNWINDLIBS) $(EXTRA_TEST_LIBS)
|
|
||||||
+gctest_LDADD = ./libgc.la $(EXTRA_TEST_LIBS)
|
|
||||||
test_cpp_SOURCES = tests/test_cpp.cc
|
|
||||||
-test_cpp_LDADD = ./libgc.la ./libgccpp.la $(THREADDLLIBS) $(UNWINDLIBS) $(EXTRA_TEST_LIBS)
|
|
||||||
+test_cpp_LDADD = ./libgccpp.la $(EXTRA_TEST_LIBS)
|
|
||||||
TESTS = $(check_PROGRAMS)
|
|
||||||
all_objs = @addobjs@ $(libgc_la_OBJECTS)
|
|
||||||
@COMPILER_XLC_FALSE@ASM_CPP_OPTIONS = -Wp,-P -x assembler-with-cpp
|
|
50
gc.spec
50
gc.spec
@ -1,33 +1,29 @@
|
|||||||
|
|
||||||
Summary: C++ Garbage Collector
|
Summary: A garbage collector for C and C++
|
||||||
Name: gc
|
Name: gc
|
||||||
Version: 6.8
|
Version: 7.0
|
||||||
|
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
Url: http://www.hpl.hp.com/personal/Hans_Boehm/gc/
|
Url: http://www.hpl.hp.com/personal/Hans_Boehm/gc/
|
||||||
Source: http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc%{version}.tar.gz
|
Source0: http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-%{version}.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
# force no undefined symbols (#166344)
|
# rpmforge compatibility
|
||||||
Patch1: gc-6.7-no-undefined.patch
|
|
||||||
|
|
||||||
BuildRequires: libtool
|
|
||||||
BuildRequires: automake
|
|
||||||
|
|
||||||
Obsoletes: libgc < %{version}-%{release}
|
Obsoletes: libgc < %{version}-%{release}
|
||||||
Provides: libgc = %{version}-%{release}
|
Provides: libgc = %{version}-%{release}
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The Boehm-Demers-Weiser conservative garbage collector can be used as a garbage
|
The Boehm-Demers-Weiser conservative garbage collector can be
|
||||||
collecting replacement for C malloc or C++ new.
|
used as a garbage collecting replacement for C malloc or C++ new.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Libraries and header files for %{name} development
|
Summary: Libraries and header files for %{name} development
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
Obsoletes: libgc-devel < %{version}-%{release}
|
Obsoletes: libgc-devel < %{version}-%{release}
|
||||||
Provides: libgc-devel = %{version}-%{release}
|
Provides: libgc-devel = %{version}-%{release}
|
||||||
%description devel
|
%description devel
|
||||||
@ -35,20 +31,7 @@ Provides: libgc-devel = %{version}-%{release}
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}%{version}
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1 -b .no-undefined
|
|
||||||
|
|
||||||
cp -f %{_datadir}/aclocal/libtool.m4 .
|
|
||||||
libtoolize --copy --force
|
|
||||||
%if 1
|
|
||||||
autoreconf
|
|
||||||
%else
|
|
||||||
aclocal
|
|
||||||
automake
|
|
||||||
autoconf
|
|
||||||
#autoheader
|
|
||||||
%endif
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -65,10 +48,6 @@ autoconf
|
|||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
%check || :
|
|
||||||
make check
|
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
@ -81,6 +60,10 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/gc
|
|||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
|
||||||
|
|
||||||
|
|
||||||
|
%check
|
||||||
|
make check
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
@ -92,7 +75,8 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc doc/README doc/README.changes doc/README.contributors
|
%doc doc/README
|
||||||
|
%doc doc/README.changes doc/README.contributors
|
||||||
%doc doc/README.environment doc/README.linux
|
%doc doc/README.environment doc/README.linux
|
||||||
%{_libdir}/lib*.so.*
|
%{_libdir}/lib*.so.*
|
||||||
|
|
||||||
@ -101,10 +85,14 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc doc/*.html
|
%doc doc/*.html
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
%{_libdir}/lib*.so
|
%{_libdir}/lib*.so
|
||||||
|
%{_libdir}/pkgconfig/*
|
||||||
%{_mandir}/man?/*
|
%{_mandir}/man?/*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 7.0-1
|
||||||
|
- gc-7.0
|
||||||
|
|
||||||
* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]users.sf.net> 6.8-3
|
* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]users.sf.net> 6.8-3
|
||||||
- Obsoletes/Provides: libgc(-devel) (rpmforge compatibility)
|
- Obsoletes/Provides: libgc(-devel) (rpmforge compatibility)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user