- gcinit patch, ABI compatibility (#248700)
This commit is contained in:
parent
55ef09a879
commit
2d28b47424
24
gc-7.0-gcinit.patch
Normal file
24
gc-7.0-gcinit.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- gc-7.0/malloc.c~ 2007-06-06 22:48:35.000000000 +0200
|
||||
+++ gc-7.0/malloc.c 2007-07-24 12:56:29.000000000 +0200
|
||||
@@ -263,6 +263,9 @@
|
||||
size_t lg;
|
||||
DCL_LOCK_STATE;
|
||||
|
||||
+ if (!GC_is_initialized)
|
||||
+ GC_init();
|
||||
+
|
||||
if(SMALL_OBJ(lb)) {
|
||||
lg = GC_size_map[lb];
|
||||
opp = (void **)&(GC_objfreelist[lg]);
|
||||
--- gc-7.0/thread_local_alloc.c~ 2007-06-28 07:05:00.000000000 +0200
|
||||
+++ gc-7.0/thread_local_alloc.c 2007-07-24 13:01:28.000000000 +0200
|
||||
@@ -141,6 +141,9 @@
|
||||
void *result;
|
||||
void **tiny_fl;
|
||||
|
||||
+ if (!GC_is_initialized)
|
||||
+ GC_init();
|
||||
+
|
||||
# if defined(REDIRECT_MALLOC) && !defined(USE_PTHREAD_SPECIFIC)
|
||||
GC_key_t k = GC_thread_key;
|
||||
if (EXPECT(0 == k, 0)) {
|
9
gc.spec
9
gc.spec
@ -3,13 +3,15 @@ Summary: A garbage collector for C and C++
|
||||
Name: gc
|
||||
Version: 7.0
|
||||
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Group: System Environment/Libraries
|
||||
License: BSD
|
||||
Url: http://www.hpl.hp.com/personal/Hans_Boehm/gc/
|
||||
Source0: http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch1: gc-7.0-gcinit.patch
|
||||
|
||||
# rpmforge compatibility
|
||||
Obsoletes: libgc < %{version}-%{release}
|
||||
Provides: libgc = %{version}-%{release}
|
||||
@ -33,6 +35,8 @@ Provides: libgc-devel = %{version}-%{release}
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .gcinit
|
||||
|
||||
|
||||
%build
|
||||
|
||||
@ -90,6 +94,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jul 24 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 7.0-2
|
||||
- gcinit patch, ABI compatibility (#248700)
|
||||
|
||||
* Mon Jul 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 7.0-1
|
||||
- gc-7.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user