parent
0ca990fc6b
commit
98fd9942b1
22
gawk-3.1.8-syntax.patch
Normal file
22
gawk-3.1.8-syntax.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- gawk-3.1.7/awkgram.y.orig 2010-06-25 10:08:11.000000000 +0200
|
||||
+++ gawk-3.1.7/awkgram.y 2010-06-25 10:10:34.000000000 +0200
|
||||
@@ -164,7 +164,7 @@
|
||||
%nonassoc LEX_IN
|
||||
%left FUNC_CALL LEX_BUILTIN LEX_LENGTH
|
||||
%nonassoc ','
|
||||
-%nonassoc MATCHOP
|
||||
+%left MATCHOP
|
||||
%nonassoc RELOP '<' '>' IO_IN IO_OUT
|
||||
%left CONCAT_OP
|
||||
%left YSTRING YNUMBER
|
||||
@@ -702,8 +702,8 @@
|
||||
*/
|
||||
print_expression_list
|
||||
: opt_expression_list
|
||||
- | '(' exp comma expression_list r_paren
|
||||
- { $$ = node($2, Node_expression_list, $4); }
|
||||
+ | '(' expression_list r_paren
|
||||
+ { $$ = $2; }
|
||||
;
|
||||
|
||||
output_redir
|
12
gawk.spec
12
gawk.spec
@ -1,7 +1,7 @@
|
||||
Summary: The GNU version of the awk text processing utility
|
||||
Name: gawk
|
||||
Version: 3.1.8
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
# Most of source files are licensed under GPLv3+,
|
||||
# several files are GPL or LGPLv2.1+ licensed,
|
||||
# gettext.h is LGPL and random.c is BSD licensed
|
||||
@ -9,8 +9,10 @@ License: GPLv3+ and GPL and LGPLv3+ and LGPL and BSD
|
||||
Group: Applications/Text
|
||||
URL: http://www.gnu.org/software/gawk/gawk.html
|
||||
Source0: http://ftp.gnu.org/gnu/gawk/gawk-%{version}.tar.bz2
|
||||
# Patch from Arnold, the upstream maintainer:
|
||||
Patch0: gawk-3.1.8-syntax.patch
|
||||
# http://lists.gnu.org/archive/html/bug-gnu-utils/2010-11/msg00005.html
|
||||
Patch: gawk-3.1.8-double-free-wstptr.patch
|
||||
Patch1: gawk-3.1.8-double-free-wstptr.patch
|
||||
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
@ -25,7 +27,8 @@ considered to be a standard Linux tool for processing text.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch -p0 -b .double-free-wstptr
|
||||
%patch0 -p1 -b .syntax
|
||||
%patch1 -p0 -b .double-free-wstptr
|
||||
|
||||
%build
|
||||
%configure --bindir=/bin --disable-libsigsegv
|
||||
@ -74,6 +77,9 @@ fi
|
||||
%{_datadir}/awk
|
||||
|
||||
%changelog
|
||||
* Tue Nov 02 2010 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 3.1.8-3
|
||||
- fix syntax issues #528623, #528625
|
||||
|
||||
* Tue Nov 02 2010 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 3.1.8-2
|
||||
- fix #629196: Double free in free_wstr
|
||||
- fix license tag, add description
|
||||
|
Loading…
Reference in New Issue
Block a user