- new upstream version
- drop upstreamed patches
This commit is contained in:
parent
b957b98230
commit
5370755b34
@ -1 +1 @@
|
|||||||
gawk-3.1.7.tar.xz
|
gawk-3.1.8.tar.bz2
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
--- gawk-3.1.7/builtin.c.orig 2010-04-01 15:52:45.000000000 +0200
|
|
||||||
+++ gawk-3.1.7/builtin.c 2010-04-01 15:57:17.000000000 +0200
|
|
||||||
@@ -1218,9 +1218,18 @@ check_pos:
|
|
||||||
if (fw == 0 && ! have_prec)
|
|
||||||
;
|
|
||||||
else if (gawk_mb_cur_max > 1 && (cs1 == 's' || cs1 == 'c')) {
|
|
||||||
+ int nchars_needed = 0;
|
|
||||||
+
|
|
||||||
assert(cp == arg->stptr || cp == cpbuf);
|
|
||||||
- copy_count = mbc_byte_count(arg->stptr,
|
|
||||||
- cs1 == 's' ? arg->stlen : 1);
|
|
||||||
+
|
|
||||||
+ if (cs1 == 'c')
|
|
||||||
+ nchars_needed = 1;
|
|
||||||
+ else if (have_prec)
|
|
||||||
+ nchars_needed = prec;
|
|
||||||
+ else
|
|
||||||
+ nchars_needed = arg->stlen;
|
|
||||||
+
|
|
||||||
+ copy_count = mbc_byte_count(arg->stptr, nchars_needed);
|
|
||||||
}
|
|
||||||
bchunk(cp, copy_count);
|
|
||||||
while (fw > prec) {
|
|
@ -1,33 +0,0 @@
|
|||||||
Sun Oct 4 21:46:11 2009 Arnold D. Robbins <arnold@skeeve.com>
|
|
||||||
|
|
||||||
* main.c (main): Don't reset argv[0] to myname. In call
|
|
||||||
to `init_args', pass argv[0] if do_posix. Based on
|
|
||||||
Fedora bug report.
|
|
||||||
|
|
||||||
Index: main.c
|
|
||||||
===================================================================
|
|
||||||
RCS file: /d/mongo/cvsrep/gawk-stable/main.c,v
|
|
||||||
retrieving revision 1.24
|
|
||||||
diff -u -r1.24 main.c
|
|
||||||
--- main.c 9 Jul 2009 19:54:38 -0000 1.24
|
|
||||||
+++ main.c 4 Oct 2009 19:46:06 -0000
|
|
||||||
@@ -306,7 +306,6 @@
|
|
||||||
#undef STACK_SIZE
|
|
||||||
|
|
||||||
myname = gawk_name(argv[0]);
|
|
||||||
- argv[0] = (char *) myname;
|
|
||||||
os_arg_fixup(&argc, &argv); /* emulate redirection, expand wildcards */
|
|
||||||
|
|
||||||
/* remove sccs gunk */
|
|
||||||
@@ -586,7 +585,9 @@
|
|
||||||
optind++;
|
|
||||||
}
|
|
||||||
|
|
||||||
- init_args(optind, argc, myname, argv);
|
|
||||||
+ init_args(optind, argc,
|
|
||||||
+ do_posix ? argv[0] : myname,
|
|
||||||
+ argv);
|
|
||||||
(void) tokexpand();
|
|
||||||
|
|
||||||
#if defined(LC_NUMERIC)
|
|
||||||
|
|
15
gawk.spec
15
gawk.spec
@ -1,14 +1,11 @@
|
|||||||
Summary: The GNU version of the awk text processing utility
|
Summary: The GNU version of the awk text processing utility
|
||||||
Name: gawk
|
Name: gawk
|
||||||
Version: 3.1.7
|
Version: 3.1.8
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/Text
|
Group: Applications/Text
|
||||||
URL: http://www.gnu.org/software/gawk/gawk.html
|
URL: http://www.gnu.org/software/gawk/gawk.html
|
||||||
Source0: http://ftp.gnu.org/gnu/gawk/gawk-%{version}.tar.xz
|
Source0: http://ftp.gnu.org/gnu/gawk/gawk-%{version}.tar.bz2
|
||||||
# Patch from Arnold, the upstream maintainer:
|
|
||||||
Patch0: gawk-posix-mode-argv0.patch
|
|
||||||
Patch1: gawk-3.1.7-prec-utf8.patch
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
@ -24,8 +21,6 @@ considered to be a standard Linux tool for processing text.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0
|
|
||||||
%patch1 -p1 -b .prec-utf8
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --bindir=/bin --disable-libsigsegv
|
%configure --bindir=/bin --disable-libsigsegv
|
||||||
@ -74,6 +69,10 @@ fi
|
|||||||
%{_datadir}/awk
|
%{_datadir}/awk
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 7 2010 Stepan Kasal <kasal@ucw.cz> - 3.1.8-1
|
||||||
|
- new upstream version
|
||||||
|
- drop upstreamed patches
|
||||||
|
|
||||||
* Thu Apr 01 2010 Jan Zeleny <jzeleny@redhat.com> - 3.1.7-3
|
* Thu Apr 01 2010 Jan Zeleny <jzeleny@redhat.com> - 3.1.7-3
|
||||||
- fix issue with utf8 precision recognition (#513234)
|
- fix issue with utf8 precision recognition (#513234)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user