Initial import for Rawhide

This commit is contained in:
Nicolas Chauvet 2009-04-08 10:49:10 +00:00
parent c1c2cbd8ed
commit 4e3ea8ef03
5 changed files with 181 additions and 0 deletions

View File

@ -0,0 +1 @@
gavl-1.1.0.tar.gz

View File

@ -0,0 +1,60 @@
diff -up gavl-1.1.0/configure.ac.gdither gavl-1.1.0/configure.ac
--- gavl-1.1.0/configure.ac.gdither 2008-09-30 22:41:05.000000000 +0200
+++ gavl-1.1.0/configure.ac 2009-03-24 01:32:40.000000000 +0100
@@ -189,6 +189,27 @@ TOP_SRCDIR=`cd ${srcdir} && pwd`
AC_SUBST(TOP_SRCDIR)
dnl
+dnl System libraries
+dnl
+
+AC_ARG_ENABLE(libgdither,
+ [ --enable-libgdither System libgdither (experimental)])
+if test "${enable_libgdither}" = "yes"
+then
+ PKG_CHECK_MODULES(LIBGDITHER, libgdither,
+ [
+ AC_DEFINE(HAVE_LIBGDITHER, 1, [Define to 1 if you have the `libgdither' library (-lgdither).])
+ have_libgdither="true"
+ ],
+ [
+ have_libgdither="false"
+ ]
+ )
+fi
+AM_CONDITIONAL(HAVE_LIBGDITHER, [test x$have_libgdither = xtrue])
+
+
+dnl
dnl Output variables
dnl
diff -up gavl-1.1.0/gavl/Makefile.am.gdither gavl-1.1.0/gavl/Makefile.am
--- gavl-1.1.0/gavl/Makefile.am.gdither 2008-08-20 22:18:08.000000000 +0200
+++ gavl-1.1.0/gavl/Makefile.am 2009-03-24 01:32:40.000000000 +0100
@@ -39,8 +39,15 @@ threednow_libs =
threednow_subdirs =
endif
+if HAVE_LIBGDITHER
+ MAYBE_LIBGDITHER_LA = @LIBGDITHER_LIBS@
+else
+ MAYBE_LIBGDITHER = libgdither
+ MAYBE_LIBGDITHER_LA = libgdither/libgdither.la
+endif
+
-SUBDIRS = hq c libgdither libsamplerate $(mmx_subdirs) \
+SUBDIRS = hq c $(MAYBE_LIBGDITHER) libsamplerate $(mmx_subdirs) \
$(sse_subdirs) \
$(sse2_subdirs) \
$(sse3_subdirs) \
@@ -104,7 +111,7 @@ $(sse3_libs) \
$(threednow_libs) \
c/libgavl_c.la \
hq/libgavl_hq.la \
-libgdither/libgdither.la \
+$(MAYBE_LIBGDITHER_LA) \
libsamplerate/libsamplerate.la \
-lm

118
gavl.spec Normal file
View File

@ -0,0 +1,118 @@
Name: gavl
Version: 1.1.0
Release: 1%{?dist}
Summary: A library for handling uncompressed audio and video data
Group: System Environment/Libraries
License: GPLv3+
URL: http://gmerlin.sourceforge.net/
Source0: http://downloads.sourceforge.net/gmerlin/gavl-%{version}.tar.gz
Patch1: gavl-1.1.0-system_libgdither.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libtool
BuildRequires: doxygen
BuildRequires: libpng-devel >= 1.0.8
BuildRequires: libgdither-devel
# Gavl use an internal tweaked libsamplerate version
# ufortunately the libsamplerate doesn't want a patch
# that will break ABI
#BuildRequires: libsamplerate-devel
%description
Gavl is a library for handling and converting uncompressed audio and
video data. It provides datatypes for audio/video formats and standardized
structures to store the data. It supports converting between all formats.
Some conversion functions are available in multiple versions (MMX...),
which are selected by compile time configuration, CPU autodetection and
user options.
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: pkgconfig
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%setup -q
%patch1 -p1 -b .gdither
#Disable buildtime cpu detection
sed -i -i 's/LQT_TRY_CFLAGS/dnl LQT_TRY_CFLAGS/g' configure.ac
sed -i -i 's/LQT_OPT_CFLAGS/dnl LQT_OPT_CFLAGS/g' configure.ac
#Regenerate build tool
sh autogen.sh
%build
%configure \
--enable-debug \
--disable-static \
--with-cpuflags=none \
--disable-cpu-clip \
--enable-libgdither
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
# Prevent timestamps build difference
touch -r include/gavl/gavl.h $RPM_BUILD_ROOT%{_includedir}/gavl/gavl_version.h
%clean
rm -rf $RPM_BUILD_ROOT
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING README TODO
%{_libdir}/*.so.*
%files devel
%defattr(-,root,root,-)
%doc %{_docdir}/gavl/apiref/
%{_includedir}/gavl/
%{_libdir}/*.so
%{_libdir}/pkgconfig/gavl.pc
%changelog
* Tue Mar 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-1
- Update to 1.1.0
- Disable buildtime CPU detection.
* Tue Jul 29 2008 kwizart < kwizart at gmail.com > - 1.0.1-1
- Update to 1.0.1
* Tue Jul 22 2008 kwizart < kwizart at gmail.com > - 1.0.0-2
- Add --enable-libgdither for system libgdither
- Add --enable-debug to disable LQT_OPT_CFLAGS
- Add -DHAVE_GAVLCONFIG_H to include gavlconfig.h when needed
* Mon May 19 2008 kwizart < kwizart at gmail.com > - 1.0.0-1
- Update to 1.0.0 api stable
* Mon May 19 2008 kwizart < kwizart at gmail.com > - 0.2.7-4
- Initial package for Fedora

1
import.log Normal file
View File

@ -0,0 +1 @@
gavl-1_1_0-1_fc10:HEAD:gavl-1.1.0-1.fc10.src.rpm:1239187747

View File

@ -0,0 +1 @@
8a631a3468f4fd4213c4ec57d1795e14 gavl-1.1.0.tar.gz