Import from CS git

This commit is contained in:
eabdullin 2025-02-04 09:13:56 +00:00
parent e6e269e9c9
commit 98bbb3ffad
6 changed files with 62 additions and 63 deletions

View File

@ -1 +1 @@
ac267effbdbaf0da4245769009f038a5a922d121 SOURCES/galera-26.4.11.tar.gz ed55d57a704512140b3979d94b6ff0691c0a6227 SOURCES/galera-26.4.20.tar.gz

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/galera-26.4.11.tar.gz SOURCES/galera-26.4.20.tar.gz

25
SOURCES/docs.patch Normal file
View File

@ -0,0 +1,25 @@
The CMake prepares file AUTHORS for packing.
It only contains one line, and isn't packed in any upstream-produced packagess.
I don't find it useful and since upstream doesn't pack it either, stop packing it here.
The README file contains infromation on how to build the project from sources, and thus isn't useful for the end users.
On the other hand, the README-MySQL isn't prepared for packing by CMake, but contains useful information about the software usage and it is package in upstream-produced packages.
Offered upstream:
https://github.com/codership/galera/pull/666
https://groups.google.com/g/codership-team/c/Cn4UO3MkNQs
--- galera-26.4.18/CMakeLists.txt 2024-06-09 04:54:56.281408893 +0200
+++ galera-26.4.18/CMakeLists.txt_patched 2024-06-09 06:52:58.093217968 +0200
@@ -118,9 +118,8 @@ endif()
if (NOT ${CMAKE_SYSTEM_NAME} MATCHES ".*BSD")
install(FILES
- ${PROJECT_SOURCE_DIR}/AUTHORS
${PROJECT_SOURCE_DIR}/COPYING
- ${PROJECT_SOURCE_DIR}/README
+ ${PROJECT_SOURCE_DIR}/scripts/packages/README-MySQL
DESTINATION ${INSTALL_DOCDIR} )
install(FILES ${PROJECT_SOURCE_DIR}/asio/LICENSE_1_0.txt
DESTINATION ${INSTALL_DOCDIR}

View File

@ -1,38 +0,0 @@
#!/usr/bin/sh
# This script is simple wrapper around garbd, that parses startup configuration.
# Its main purpose is to bridge the differences between initscript and systemd unit file.
CONFIG_FILE=/etc/sysconfig/garb
source $CONFIG_FILE
# Check that node addresses and group name are configured
if [ -z "$GALERA_NODES" ]; then
echo "List of GALERA_NODES is not configured" >&2
exit 1
fi
if [ -z "$GALERA_GROUP" ]; then
echo "GALERA_GROUP name is not configured" >&2
exit 1
fi
GALERA_PORT=${GALERA_PORT:-4567}
# Find a working node
for ADDRESS in ${GALERA_NODES} 0; do
HOST=$(echo $ADDRESS | cut -d \: -f 1)
PORT=$(echo $ADDRESS | cut -s -d \: -f 2)
PORT=${PORT:-$GALERA_PORT}
ncat --send-only --recv-only $HOST $PORT >/dev/null && break
done
if [ ${ADDRESS} == "0" ]; then
echo "None of the nodes in GALERA_NODES is accessible" >&2
exit 1
fi
OPTIONS="-a gcomm://$ADDRESS"
[ -n "$GALERA_GROUP" ] && OPTIONS="$OPTIONS -g $GALERA_GROUP"
[ -n "$GALERA_OPTIONS" ] && OPTIONS="$OPTIONS -o $GALERA_OPTIONS"
[ -n "$LOG_FILE" ] && OPTIONS="$OPTIONS -l $LOG_FILE"
exec /usr/sbin/garbd $OPTIONS

View File

@ -1,10 +0,0 @@
[Unit]
Description=Galera Arbitrator Daemon
Documentation=http://www.codership.com/wiki/doku.php?id=galera_arbitrator
[Service]
ExecStart=/usr/sbin/garbd-wrapper
ExecReload=/bin/kill -HUP $MAINPID
[Install]
WantedBy=multi-user.target

View File

@ -1,5 +1,8 @@
# To both save infrastrucutre resources and workaround for i686 FTBFS
ExcludeArch: %{ix86}
Name: galera Name: galera
Version: 26.4.11 Version: 26.4.20
Release: 1%{?dist} Release: 1%{?dist}
Summary: Synchronous multi-master wsrep provider (replication engine) Summary: Synchronous multi-master wsrep provider (replication engine)
@ -12,10 +15,8 @@ URL: http://galeracluster.com/
Source0: http://releases.galeracluster.com/source/%{name}-%{version}.tar.gz Source0: http://releases.galeracluster.com/source/%{name}-%{version}.tar.gz
Source1: garbd.service
Source2: garbd-wrapper
Patch0: cmake_paths.patch Patch0: cmake_paths.patch
Patch1: docs.patch
BuildRequires: boost-devel check-devel openssl-devel cmake systemd gcc-c++ asio-devel BuildRequires: boost-devel check-devel openssl-devel cmake systemd gcc-c++ asio-devel
Requires(pre): /usr/sbin/useradd Requires(pre): /usr/sbin/useradd
@ -34,7 +35,8 @@ description of Galera replication engine see https://www.galeracluster.com web.
%prep %prep
%setup -q %setup -q
%patch0 -p1 %patch -P0 -p1
%patch -P1 -p1
%build %build
%{set_build_flags} %{set_build_flags}
@ -70,13 +72,13 @@ cmake -B %_vpath_builddir -LAH
# Fedora downstream packaging historically used "garbd" name for the service. # Fedora downstream packaging historically used "garbd" name for the service.
# #
# Let's stick with the Fedora legacy naming, AND provide an alias to the Galera upstream name # Let's stick with the Fedora legacy naming, AND provide an alias to the Galera upstream name
mv %{buildroot}/usr/lib/systemd/system/garb.service %{buildroot}/usr/lib/systemd/system/garbd.service mv %{buildroot}%{_unitdir}/garb.service %{buildroot}%{_unitdir}/garbd.service
sed -i 's/Alias=garbd.service/Alias=garb.service/g' %{buildroot}/usr/lib/systemd/system/garbd.service sed -i 's/Alias=garbd.service/Alias=garb.service/g' %{buildroot}%{_unitdir}/garbd.service
# PATCH 2: # PATCH 2:
# Fix the hardcoded paths # Fix the hardcoded paths
# In the Systemd service file: # In the Systemd service file:
sed -i 's;/usr/bin/garb-systemd;/usr/sbin/garb-systemd;g' %{buildroot}/usr/lib/systemd/system/garbd.service sed -i 's;/usr/bin/garb-systemd;/usr/sbin/garb-systemd;g' %{buildroot}%{_unitdir}/garbd.service
# In the wrapper script: # In the wrapper script:
sed -i 's;/usr/bin/garbd;/usr/sbin/garbd;g' %{buildroot}/usr/sbin/garb-systemd sed -i 's;/usr/bin/garbd;/usr/sbin/garbd;g' %{buildroot}/usr/sbin/garb-systemd
@ -103,7 +105,9 @@ sed -i 's;/usr/bin/garbd;/usr/sbin/garbd;g' %{buildroot}/usr/sbin/garb-systemd
## in particular on systems using NFS or running containers. Allocate a user ID ## in particular on systems using NFS or running containers. Allocate a user ID
## specific to this service, either statically via systemd-sysusers or dynamically ## specific to this service, either statically via systemd-sysusers or dynamically
## via the DynamicUser= service setting. ## via the DynamicUser= service setting.
sed -i 's/User=nobody/User=garb/g' %{buildroot}/usr/lib/systemd/system/garbd.service sed -i 's/User=nobody/User=garb/g' %{buildroot}%{_unitdir}/garbd.service
# Maintainers from other distributions also tries to resolve it on the upstream:
# https://github.com/codership/galera/pull/633
%check %check
@ -132,7 +136,6 @@ sed -i 's/User=nobody/User=garb/g' %{buildroot}/usr/lib/systemd/system/garbd.ser
%dir %{_libdir}/galera %dir %{_libdir}/galera
%{_sbindir}/garbd %{_sbindir}/garbd
#%{_sbindir}/garbd-wrapper
# PATCH 3: # PATCH 3:
# Make sure the wrapper script is executable # Make sure the wrapper script is executable
@ -144,14 +147,33 @@ sed -i 's/User=nobody/User=garb/g' %{buildroot}/usr/lib/systemd/system/garbd.ser
%{_libdir}/galera/libgalera_smm.so %{_libdir}/galera/libgalera_smm.so
%doc %{_docdir}/galera/AUTHORS
%doc %{_docdir}/galera/COPYING %doc %{_docdir}/galera/COPYING
%doc %{_docdir}/galera/LICENSE.asio %doc %{_docdir}/galera/LICENSE.asio
%doc %{_docdir}/galera/README %doc %{_docdir}/galera/README-MySQL
#%doc %{_docdir}/galera/README-MySQL
%changelog %changelog
* Thu Nov 14 2024 Michal Schorm <mschorm@redhat.com> - 26.4.20-1
- Rebase to 26.4.20
* Fri Oct 18 2024 Michal Schorm <mschorm@redhat.com> - 26.4.19-1
- Rebase to 26.4.19
* Fri Jun 07 2024 Michal Schorm <mschorm@redhat.com> - 26.4.18-1
- Rebase to 26.4.18
* Fri Nov 17 2023 Michal Schorm <mschorm@redhat.com> - 26.4.16-1
- Rebase to 26.4.16
* Sat Apr 29 2023 Michal Schorm <mschorm@redhat.com> - 26.4.14-1
- Rebase to 26.4.14
* Tue Nov 15 2022 Michal Schorm <mschorm@redhat.com> - 26.4.13-1
- Rebase to 26.4.13
* Wed Aug 24 2022 Michal Schorm <mschorm@redhat.com> - 26.4.12-1
- Rebase to 26.4.12
* Sun Feb 20 2022 Michal Schorm <mschorm@redhat.com> - 26.4.11-1 * Sun Feb 20 2022 Michal Schorm <mschorm@redhat.com> - 26.4.11-1
- Rebase to 26.4.11 - Rebase to 26.4.11