Update to 25.3.23
Patch upstreamed
This commit is contained in:
parent
ab4770c42f
commit
77b5226e90
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/galera-3-25.3.12.tar.gz
|
||||
/galera-3-25.3.16.tar.gz
|
||||
/galera-25.3.22.tar.gz
|
||||
/galera-25.3.23.tar.gz
|
||||
|
@ -1,267 +0,0 @@
|
||||
Reported upstream: https://github.com/codership/galera/pull/488
|
||||
|
||||
diff -up galera-25.3.22/gcs/src/SConscript.python3 galera-25.3.22/gcs/src/SConscript
|
||||
--- galera-25.3.22/gcs/src/SConscript.python3 2017-11-24 15:35:04.013358447 +0100
|
||||
+++ galera-25.3.22/gcs/src/SConscript 2017-11-24 15:35:10.701396046 +0100
|
||||
@@ -24,9 +24,9 @@ libgcs_env.Replace(CCFLAGS = libgcs_env[
|
||||
libgcs_env.Append(CCFLAGS = ' -Wno-missing-field-initializers')
|
||||
libgcs_env.Append(CCFLAGS = ' -Wno-variadic-macros')
|
||||
|
||||
-print 'gcs flags:'
|
||||
+print('gcs flags:')
|
||||
for f in ['CFLAGS', 'CXXFLAGS', 'CCFLAGS', 'CPPFLAGS']:
|
||||
- print f + ': ' + libgcs_env[f].strip()
|
||||
+ print(f + ': ' + libgcs_env[f].strip())
|
||||
|
||||
gcs4garb_env = libgcs_env.Clone()
|
||||
|
||||
diff -up galera-25.3.22/SConstruct.python3 galera-25.3.22/SConstruct
|
||||
--- galera-25.3.22/SConstruct.python3 2017-11-14 15:28:25.000000000 +0100
|
||||
+++ galera-25.3.22/SConstruct 2017-11-24 15:35:20.218449548 +0100
|
||||
@@ -33,7 +33,7 @@ import subprocess
|
||||
sysname = os.uname()[0].lower()
|
||||
machine = platform.machine()
|
||||
bits = ARGUMENTS.get('bits', platform.architecture()[0])
|
||||
-print 'Host: ' + sysname + ' ' + machine + ' ' + bits
|
||||
+print('Host: ' + sysname + ' ' + machine + ' ' + bits)
|
||||
|
||||
x86 = any(arch in machine for arch in [ 'x86', 'amd64', 'i686', 'i386', 'i86pc' ])
|
||||
|
||||
@@ -150,10 +150,10 @@ if GALERA_REV == "XXXX" and os.path.isfi
|
||||
|
||||
# export to any module that might have use of those
|
||||
Export('GALERA_VER', 'GALERA_REV')
|
||||
-print 'Signature: version: ' + GALERA_VER + ', revision: ' + GALERA_REV
|
||||
+print('Signature: version: ' + GALERA_VER + ', revision: ' + GALERA_REV)
|
||||
|
||||
LIBBOOST_PROGRAM_OPTIONS_A = ARGUMENTS.get('bpostatic', '')
|
||||
-LIBBOOST_SYSTEM_A = string.replace(LIBBOOST_PROGRAM_OPTIONS_A, 'boost_program_options', 'boost_system')
|
||||
+LIBBOOST_SYSTEM_A = LIBBOOST_PROGRAM_OPTIONS_A.replace('boost_program_options', 'boost_system')
|
||||
|
||||
#
|
||||
# Set up and export default build environment
|
||||
@@ -185,7 +185,7 @@ if link != 'default':
|
||||
try:
|
||||
cc_version = subprocess.check_output(
|
||||
env['CC'].split() + ['--version'],
|
||||
- stderr=subprocess.STDOUT).splitlines()[0]
|
||||
+ stderr=subprocess.STDOUT).splitlines()[0].decode("utf-8")
|
||||
except:
|
||||
# in case "$CC --version" returns an error, e.g. "unknown option"
|
||||
cc_version = 'unknown'
|
||||
@@ -193,15 +193,15 @@ except:
|
||||
try:
|
||||
cxx_version = subprocess.check_output(
|
||||
env['CXX'].split() + ['--version'],
|
||||
- stderr=subprocess.STDOUT).splitlines()[0]
|
||||
+ stderr=subprocess.STDOUT).splitlines()[0].decode("utf-8")
|
||||
except:
|
||||
# in case "$CXX --version" returns an error, e.g. "unknown option"
|
||||
cxx_version = 'unknown'
|
||||
|
||||
-print 'Using C compiler executable: ' + env['CC']
|
||||
-print 'C compiler version is: ' + cc_version
|
||||
-print 'Using C++ compiler executable: ' + env['CXX']
|
||||
-print 'C++ compiler version is: ' + cxx_version
|
||||
+print('Using C compiler executable: ' + env['CC'])
|
||||
+print('C compiler version is: ' + cc_version)
|
||||
+print('Using C++ compiler executable: ' + env['CXX'])
|
||||
+print('C++ compiler version is: ' + cxx_version)
|
||||
|
||||
# Initialize CPPFLAGS and LIBPATH from environment to get user preferences
|
||||
env.Replace(CPPFLAGS = os.getenv('CPPFLAGS', ''))
|
||||
@@ -303,7 +303,7 @@ conf = Configure(env, custom_tests = {'C
|
||||
# System headers and libraries
|
||||
|
||||
if not conf.CheckLib('pthread'):
|
||||
- print 'Error: pthread library not found'
|
||||
+ print('Error: pthread library not found')
|
||||
Exit(1)
|
||||
|
||||
# libatomic may be needed on some 32bit platforms (and 32bit userland PPC64)
|
||||
@@ -313,23 +313,23 @@ if not x86:
|
||||
|
||||
if sysname != 'darwin':
|
||||
if not conf.CheckLib('rt'):
|
||||
- print 'Error: rt library not found'
|
||||
+ print('Error: rt library not found')
|
||||
Exit(1)
|
||||
|
||||
if sysname == 'freebsd':
|
||||
if not conf.CheckLib('execinfo'):
|
||||
- print 'Error: execinfo library not found'
|
||||
+ print('Error: execinfo library not found')
|
||||
Exit(1)
|
||||
|
||||
if sysname == 'sunos':
|
||||
if not conf.CheckLib('socket'):
|
||||
- print 'Error: socket library not found'
|
||||
+ print('Error: socket library not found')
|
||||
Exit(1)
|
||||
if not conf.CheckLib('crypto'):
|
||||
- print 'Error: crypto library not found'
|
||||
+ print('Error: crypto library not found')
|
||||
Exit(1)
|
||||
if not conf.CheckLib('nsl'):
|
||||
- print 'Error: nsl library not found'
|
||||
+ print('Error: nsl library not found')
|
||||
Exit(1)
|
||||
|
||||
if conf.CheckHeader('sys/epoll.h'):
|
||||
@@ -345,7 +345,7 @@ elif conf.CheckHeader('sys/endian.h'):
|
||||
elif conf.CheckHeader('sys/byteorder.h'):
|
||||
conf.env.Append(CPPFLAGS = ' -DHAVE_SYS_BYTEORDER_H')
|
||||
elif sysname != 'darwin':
|
||||
- print 'can\'t find byte order information'
|
||||
+ print('can\'t find byte order information')
|
||||
Exit(1)
|
||||
|
||||
if conf.CheckHeader('execinfo.h'):
|
||||
@@ -356,7 +356,7 @@ if conf.CheckHeader('execinfo.h'):
|
||||
# boost headers
|
||||
|
||||
if not conf.CheckCXXHeader('boost/shared_ptr.hpp'):
|
||||
- print 'boost/shared_ptr.hpp not found or not usable'
|
||||
+ print('boost/shared_ptr.hpp not found or not usable')
|
||||
Exit(1)
|
||||
conf.env.Append(CPPFLAGS = ' -DHAVE_BOOST_SHARED_PTR_HPP')
|
||||
|
||||
@@ -368,7 +368,7 @@ else:
|
||||
if conf.CheckCXXHeader('boost/unordered_map.hpp'):
|
||||
conf.env.Append(CPPFLAGS = ' -DHAVE_BOOST_UNORDERED_MAP_HPP')
|
||||
else:
|
||||
- print 'no unordered map header available'
|
||||
+ print('no unordered map header available')
|
||||
Exit(1)
|
||||
|
||||
# pool allocator
|
||||
@@ -390,7 +390,7 @@ if boost == 1:
|
||||
def check_boost_library(libBaseName, header, configuredLibPath, autoadd = 1):
|
||||
libName = libBaseName + boost_library_suffix
|
||||
if configuredLibPath != '' and not os.path.isfile(configuredLibPath):
|
||||
- print "Error: file '%s' does not exist" % configuredLibPath
|
||||
+ print("Error: file '%s' does not exist" % configuredLibPath)
|
||||
Exit(1)
|
||||
if configuredLibPath == '':
|
||||
for libpath in boost_libpaths:
|
||||
@@ -400,7 +400,7 @@ if boost == 1:
|
||||
break
|
||||
if configuredLibPath != '':
|
||||
if not conf.CheckCXXHeader(header):
|
||||
- print "Error: header '%s' does not exist" % header
|
||||
+ print("Error: header '%s' does not exist" % header)
|
||||
Exit (1)
|
||||
if autoadd:
|
||||
conf.env.Append(LIBS=File(configuredLibPath))
|
||||
@@ -411,7 +411,7 @@ if boost == 1:
|
||||
header=header,
|
||||
language='CXX',
|
||||
autoadd=autoadd):
|
||||
- print 'Error: library %s does not exist' % libName
|
||||
+ print('Error: library %s does not exist' % libName)
|
||||
Exit (1)
|
||||
return [libName]
|
||||
|
||||
@@ -419,7 +419,7 @@ if boost == 1:
|
||||
#
|
||||
if boost_pool == 1:
|
||||
if conf.CheckCXXHeader('boost/pool/pool_alloc.hpp'):
|
||||
- print 'Using boost pool alloc'
|
||||
+ print('Using boost pool alloc')
|
||||
conf.env.Append(CPPFLAGS = ' -DGALERA_USE_BOOST_POOL_ALLOC=1')
|
||||
# due to a bug in boost >= 1.50 we need to link with boost_system
|
||||
# - should be a noop with no boost_pool.
|
||||
@@ -430,7 +430,7 @@ if boost == 1:
|
||||
'boost/system/error_code.hpp',
|
||||
LIBBOOST_SYSTEM_A)
|
||||
else:
|
||||
- print 'Error: boost/pool/pool_alloc.hpp not found or not usable'
|
||||
+ print('Error: boost/pool/pool_alloc.hpp not found or not usable')
|
||||
Exit(1)
|
||||
|
||||
libboost_program_options = check_boost_library('boost_program_options',
|
||||
@@ -438,14 +438,14 @@ if boost == 1:
|
||||
LIBBOOST_PROGRAM_OPTIONS_A,
|
||||
autoadd = 0)
|
||||
else:
|
||||
- print 'Not using boost'
|
||||
+ print('Not using boost')
|
||||
|
||||
# asio
|
||||
if system_asio == 1 and conf.CheckCXXHeader('asio.hpp') and conf.CheckSystemASIOVersion():
|
||||
conf.env.Append(CPPFLAGS = ' -DHAVE_ASIO_HPP')
|
||||
else:
|
||||
system_asio = False
|
||||
- print "Falling back to bundled asio"
|
||||
+ print("Falling back to bundled asio")
|
||||
|
||||
if not system_asio:
|
||||
# Make sure that -Iasio goes before other paths (e.g. -I/usr/local/include)
|
||||
@@ -455,7 +455,7 @@ if not system_asio:
|
||||
if conf.CheckCXXHeader('asio.hpp'):
|
||||
conf.env.Append(CPPFLAGS = ' -DHAVE_ASIO_HPP')
|
||||
else:
|
||||
- print 'asio headers not found or not usable'
|
||||
+ print('asio headers not found or not usable')
|
||||
Exit(1)
|
||||
|
||||
# asio/ssl
|
||||
@@ -463,14 +463,14 @@ if ssl == 1:
|
||||
if conf.CheckCXXHeader('asio/ssl.hpp'):
|
||||
conf.env.Append(CPPFLAGS = ' -DHAVE_ASIO_SSL_HPP')
|
||||
else:
|
||||
- print 'ssl support required but asio/ssl.hpp not found or not usable'
|
||||
- print 'compile with ssl=0 or check that openssl devel headers are usable'
|
||||
+ print('ssl support required but asio/ssl.hpp not found or not usable')
|
||||
+ print('compile with ssl=0 or check that openssl devel headers are usable')
|
||||
Exit(1)
|
||||
if conf.CheckLib('ssl'):
|
||||
conf.CheckLib('crypto')
|
||||
else:
|
||||
- print 'ssl support required but openssl library not found'
|
||||
- print 'compile with ssl=0 or check that openssl library is usable'
|
||||
+ print('ssl support required but openssl library not found')
|
||||
+ print('compile with ssl=0 or check that openssl library is usable')
|
||||
Exit(1)
|
||||
|
||||
|
||||
@@ -490,9 +490,9 @@ if not 'clang' in cxx_version:
|
||||
|
||||
env = conf.Finish()
|
||||
|
||||
-print 'Global flags:'
|
||||
+print('Global flags:')
|
||||
for f in ['CFLAGS', 'CXXFLAGS', 'CCFLAGS', 'CPPFLAGS']:
|
||||
- print f + ': ' + env[f].strip()
|
||||
+ print(f + ': ' + env[f].strip())
|
||||
|
||||
Export('x86', 'bits', 'env', 'sysname', 'machine', 'libboost_program_options')
|
||||
|
||||
@@ -516,15 +516,15 @@ conf = Configure(check_env)
|
||||
# Check header and library
|
||||
|
||||
if not conf.CheckHeader('check.h'):
|
||||
- print 'Error: check header file not found or not usable'
|
||||
+ print('Error: check header file not found or not usable')
|
||||
Exit(1)
|
||||
|
||||
if not conf.CheckLib('check'):
|
||||
- print 'Error: check library not found or not usable'
|
||||
+ print('Error: check library not found or not usable')
|
||||
Exit(1)
|
||||
|
||||
if not conf.CheckLib('m'):
|
||||
- print 'Error: math library not found or not usable'
|
||||
+ print('Error: math library not found or not usable')
|
||||
Exit(1)
|
||||
|
||||
# potential check dependency, link if present
|
||||
@@ -532,7 +532,7 @@ conf.CheckLib('subunit')
|
||||
|
||||
if sysname != 'darwin':
|
||||
if not conf.CheckLib('rt'):
|
||||
- print 'Error: realtime library not found or not usable'
|
||||
+ print('Error: realtime library not found or not usable')
|
||||
Exit(1)
|
||||
|
||||
conf.Finish()
|
17
galera.spec
17
galera.spec
@ -1,17 +1,20 @@
|
||||
Name: galera
|
||||
Version: 25.3.22
|
||||
Release: 2%{?dist}
|
||||
Version: 25.3.23
|
||||
Release: 1%{?dist}
|
||||
Summary: Synchronous multi-master wsrep provider (replication engine)
|
||||
|
||||
License: GPLv2
|
||||
URL: http://galeracluster.com/
|
||||
|
||||
# Actually, the truth is, we do use galera source tarball provided by MariaDB on
|
||||
# following URL (without macros):
|
||||
# https://mirror.vpsfree.cz/mariadb/mariadb-10.2.13/galera-25.3.23/src/galera-25.3.23.tar.gz
|
||||
|
||||
Source0: http://releases.galeracluster.com/source/%{name}-%{version}.tar.gz
|
||||
|
||||
Source1: garbd.service
|
||||
Source2: garbd-wrapper
|
||||
|
||||
Patch1: galera-python3.patch
|
||||
|
||||
BuildRequires: boost-devel check-devel openssl-devel scons systemd asio-devel
|
||||
Requires: nmap-ncat
|
||||
|
||||
@ -30,7 +33,6 @@ replication engine see http://www.codership.com.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .python3
|
||||
|
||||
%build
|
||||
export CPPFLAGS="%{optflags}"
|
||||
@ -55,11 +57,9 @@ install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/RE
|
||||
/sbin/ldconfig
|
||||
%systemd_post garbd.service
|
||||
|
||||
|
||||
%preun
|
||||
%systemd_preun garbd.service
|
||||
|
||||
|
||||
%postun
|
||||
/sbin/ldconfig
|
||||
%systemd_postun_with_restart garbd.service
|
||||
@ -83,6 +83,9 @@ install -D -m 644 scripts/packages/README-MySQL %{buildroot}%{_docdir}/galera/RE
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Feb 16 2018 Michal Schorm <mschorm@redhat.com> - 25.3.23-1
|
||||
- Update to 25.3.23
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 25.3.22-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (galera-25.3.22.tar.gz) = 24ae47bd6070b09372eaf633e84cb9fc653923f5416c5615446c8f30d4971c5f0602399d858b80d04d37fe4f2f1a956177d042b846d750df08fa96fade699729
|
||||
SHA512 (galera-25.3.23.tar.gz) = f51d5d14e256f1ef385caf0f763cec2af7536c87995a725aff93dec82772f1af24f7739819a9a8fc199e362d7b9674909eaaea7639e4a5f92814baefae29b11d
|
||||
|
Loading…
Reference in New Issue
Block a user