Apply a workaround for building without "openssl/engine.h"
This commit is contained in:
parent
01c3a18773
commit
09732b28cb
@ -18,6 +18,7 @@ Source0: http://releases.galeracluster.com/source/%{name}-%{version}.tar.
|
||||
Patch0: cmake_paths.patch
|
||||
Patch1: docs.patch
|
||||
Patch2: network.patch
|
||||
Patch3: openssl_engine.patch
|
||||
|
||||
BuildRequires: boost-devel check-devel openssl-devel cmake systemd gcc-c++ asio-devel
|
||||
Requires(pre): /usr/sbin/useradd
|
||||
@ -39,6 +40,7 @@ description of Galera replication engine see https://www.galeracluster.com web.
|
||||
%patch -P0 -p1
|
||||
%patch -P1 -p1
|
||||
%patch -P2 -p1
|
||||
%patch -P3 -p1
|
||||
|
||||
%build
|
||||
%{set_build_flags}
|
||||
|
27
openssl_engine.patch
Normal file
27
openssl_engine.patch
Normal file
@ -0,0 +1,27 @@
|
||||
The galera package itself does not need "openssl/engine.h" to compile.
|
||||
|
||||
There are only two instanced of that include:
|
||||
|
||||
1) File: "asio/asio/ssl/detail/openssl_types.hpp", necessary for galera itself to build
|
||||
Which contains coorectly conditioned:
|
||||
| #if !defined(OPENSSL_NO_ENGINE)
|
||||
| # include <openssl/engine.h>
|
||||
| #endif // !defined(OPENSSL_NO_ENGINE)
|
||||
|
||||
2) File: "galera-26.4.19/galerautils/tests/gu_asio_test.cpp", necessary for galera 'galerautils' tests to build
|
||||
|
||||
which does not have the include inside a condition, as the code requires it in any case.
|
||||
|
||||
==
|
||||
|
||||
As a workaround, disable build of the 'galerautils' tests, until
|
||||
the openssl engine functionality is correctly removed from it.
|
||||
|
||||
--- galera-26.4.19/galerautils/CMakeLists.txt 2024-08-20 15:56:58.821943102 +0200
|
||||
+++ galera-26.4.19/galerautils/CMakeLists.txt_patched 2024-08-20 15:57:07.027849238 +0200
|
||||
@@ -3,4 +3,4 @@
|
||||
#
|
||||
|
||||
add_subdirectory(src)
|
||||
-add_subdirectory(tests)
|
||||
+#add_subdirectory(tests)
|
Loading…
Reference in New Issue
Block a user