Import fxload-2002_04_11-6.fc8.src.rpm
This commit is contained in:
parent
dbddc211b7
commit
f679343c40
@ -0,0 +1 @@
|
||||
fxload-2002_04_11-noa3load.tar.gz
|
8
fxload-generate-tarball.sh
Normal file
8
fxload-generate-tarball.sh
Normal file
@ -0,0 +1,8 @@
|
||||
#!/bin/sh
|
||||
|
||||
VERSION=$1
|
||||
|
||||
tar -xzvf fxload-${VERSION}.tar.gz
|
||||
rm fxload-${VERSION}/a3load.hex
|
||||
tar -czvf fxload-${VERSION}-noa3load.tar.gz fxload-${VERSION}
|
||||
|
11
fxload-header.patch
Normal file
11
fxload-header.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ezusb.c 2002-04-12 06:08:01.000000000 +0200
|
||||
+++ ezusb.c.new 2006-12-07 23:57:04.000000000 +0100
|
||||
@@ -29,7 +29,7 @@
|
||||
# include <sys/ioctl.h>
|
||||
|
||||
# include <linux/version.h>
|
||||
-# include <linux/usb.h>
|
||||
+# include <linux/usb/ch9.h>
|
||||
# include <linux/usbdevice_fs.h>
|
||||
|
||||
# include "ezusb.h"
|
34
fxload-noa3load.patch
Normal file
34
fxload-noa3load.patch
Normal file
@ -0,0 +1,34 @@
|
||||
diff -urN fxload-2002_04_11/fxload.8 fxload-2002_04_11-noa3load/fxload.8
|
||||
--- fxload-2002_04_11/fxload.8 2002-04-11 22:08:01.000000000 -0600
|
||||
+++ fxload-2002_04_11-noa3load/fxload.8 2007-11-16 23:13:40.000000000 -0700
|
||||
@@ -217,15 +217,6 @@
|
||||
.B DEVICE
|
||||
normally names a "usbfs" file that will be used to talk to the device.
|
||||
This is provided by the Linux kernel as part of USB hotplugging.
|
||||
-.SH "FILES"
|
||||
-.TP
|
||||
-.I /usr/share/usb/a3load.hex
|
||||
-Second stage loader that works with AnchorChips EZ-USB,
|
||||
-Cypress EZ-USB FX, and Cypress EZ-USB FX2.
|
||||
-Note that this only supports the 0xA3 vendor command, to
|
||||
-write external memory.
|
||||
-A loader that also supports the 0xA2 command, to write boot EEPROMs,
|
||||
-is included with Cypress developer kits.
|
||||
.SH "SEE ALSO"
|
||||
.BR hotplug "(8) "
|
||||
.SH "AUTHORS"
|
||||
diff -urN fxload-2002_04_11/README.txt fxload-2002_04_11-noa3load/README.txt
|
||||
--- fxload-2002_04_11/README.txt 2002-04-11 22:08:01.000000000 -0600
|
||||
+++ fxload-2002_04_11-noa3load/README.txt 2007-11-16 23:13:29.000000000 -0700
|
||||
@@ -11,11 +11,6 @@
|
||||
use, as well as downloading firmware to all other off-chip memory,
|
||||
a second stage loader must first be downloaded.
|
||||
|
||||
-The distribution includes "a3load.hex", which is a simple second stage
|
||||
-loader that works with all the EZ-USB products listed above. If you
|
||||
-want to write to an EEPROM, you can use the appropriate version of the
|
||||
-"Vend_Ax" code provided with the Cypress developer kit.
|
||||
-
|
||||
|
||||
UPDATES
|
||||
|
88
fxload.spec
Normal file
88
fxload.spec
Normal file
@ -0,0 +1,88 @@
|
||||
Name: fxload
|
||||
Version: 2002_04_11
|
||||
Release: 6%{?dist}
|
||||
Summary: A helper program to download firmware into FX and FX2 EZ-USB devices
|
||||
|
||||
Group: System Environment/Kernel
|
||||
License: GPLv2+
|
||||
URL: http://linux-hotplug.sourceforge.net/
|
||||
Source0: fxload-2002_04_11-noa3load.tar.gz
|
||||
# The above file is derived from:
|
||||
# http://downloads.sourceforge.net/linux-hotplug/fxload-2002_04_11.tar.gz
|
||||
# This file contains code that is copyright Cypress Semiconductor Inc,
|
||||
# and cannot be distributed. Therefore we use this script to remove the
|
||||
# copyright code before shipping it. Download the upstream tarball and
|
||||
# invoke this script while in the tarball's directory:
|
||||
# ./fxload-generate-tarball.sh 2002_04_11
|
||||
Source1: fxload-generate-tarball.sh
|
||||
Patch0: fxload-header.patch
|
||||
Patch1: fxload-noa3load.patch
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
BuildRequires: kernel-headers
|
||||
Requires: udev
|
||||
Conflicts: hotplug-gtk hotplug
|
||||
|
||||
%description
|
||||
This program is conveniently able to download firmware into FX and FX2
|
||||
EZ-USB devices, as well as the original AnchorChips EZ-USB. It is
|
||||
intended to be invoked by udev scripts when the unprogrammed device
|
||||
appears on the bus.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p0 -b .fxload-header
|
||||
%patch1 -p1 -b .fxload-noa3load
|
||||
|
||||
%build
|
||||
make
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
mkdir -p -m 755 %{buildroot}/sbin
|
||||
install -m 755 fxload %{buildroot}/sbin
|
||||
mkdir -p -m 755 %{buildroot}/%{_mandir}/man8/
|
||||
install -m 644 fxload.8 %{buildroot}/%{_mandir}/man8/
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(0644,root,root,0755)
|
||||
%doc COPYING
|
||||
%doc README.txt
|
||||
%attr(0755, root, root) /sbin/fxload
|
||||
%{_mandir}/*/*
|
||||
|
||||
%changelog
|
||||
* Sat Nov 16 2007 Stephen Warren <s-t-rhbugzilla@wwwdotorg.org> - 2002_04_11-6
|
||||
- Rework the spec file formatting to match templates from rpmdev
|
||||
- Be explicit about file attributes, just in case
|
||||
|
||||
* Sat Nov 16 2007 Stephen Warren <s-t-rhbugzilla@wwwdotorg.org> - 2002_04_11-5
|
||||
- Updates after reading packaging guide-lines more thoroughly:
|
||||
- Make license version more explicit
|
||||
- Add generate-tarball.sh, and associated comments
|
||||
- Added BuildRequires on kernel-headers
|
||||
- Added COPYING as a doc
|
||||
- Use dollar v.s. percent macros more consitently
|
||||
|
||||
* Fri Nov 15 2007 Stephen Warren <s-t-rhbugzilla@wwwdotorg.org> - 2002_04_11-4
|
||||
- Repackage the source tarball to remove a3load.hex
|
||||
- Added instructions to spec file on how to do the above
|
||||
- Remove reference to a3load.hex from the man page too
|
||||
|
||||
* Thu Nov 15 2007 Stephen Warren <s-t-rhbugzilla@wwwdotorg.org> - 2002_04_11-3
|
||||
- Update BuildRoot per Fedora wiki
|
||||
- Fixed rpmlint complaint about not cleaning buildroot
|
||||
- Updated source patch file to match latest kernel file layout
|
||||
- Add patch to remove reference to non-shipped non-free a3load.hex firmware
|
||||
|
||||
* Fri Dec 8 2006 Bart Vanbrabant <bart.vanbrabant@zoeloelip.be> - 2002_04_11-2
|
||||
- Fixed some rpmlint complaints
|
||||
- Added patch to fix an include header
|
||||
- Added dist tag
|
||||
|
||||
* Wed Apr 12 2006 Bart Vanbrabant <bart.vanbrabant@zoeloelip.be> - 2002_04_11-1
|
||||
- First version of fxload spec based on hotplug spec
|
||||
|
Loading…
Reference in New Issue
Block a user