Remove cflags-ldflags patch
This patch added the CFLAGS to linking as well, which breaks and annocheck complains: Hardened: fxload: FAIL: Compiled without using either the -Wall or -Wformat-security options. Run with -v to see where. A later patch will add the LDFLAGS back at the same place
This commit is contained in:
parent
f2e9845851
commit
ec0ec05211
@ -1,12 +0,0 @@
|
||||
diff -up fxload-2008_10_13/Makefile.cflags fxload-2008_10_13/Makefile
|
||||
--- fxload-2008_10_13/Makefile.cflags 2008-10-13 17:44:04.000000000 -0400
|
||||
+++ fxload-2008_10_13/Makefile 2018-02-25 23:11:02.416103160 -0500
|
||||
@@ -39,7 +39,7 @@ release: rpms
|
||||
|
||||
# object files
|
||||
$(PROG): $(FILES_OBJ)
|
||||
- $(CC) -o $(PROG) $(FILES_OBJ)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $(PROG) $(FILES_OBJ)
|
||||
|
||||
%.o: %.c
|
||||
$(CC) -c $(CFLAGS) $< -o $@
|
@ -15,7 +15,6 @@ Source0: fxload-%{version}-noa3load.tar.gz
|
||||
# ./fxload-generate-tarball.sh 2008_10_13
|
||||
Source1: fxload-generate-tarball.sh
|
||||
Patch0: fxload-noa3load.patch
|
||||
Patch1: fxload-cflags-ldflags.patch
|
||||
|
||||
BuildRequires: gcc kernel-headers
|
||||
Requires: udev
|
||||
@ -30,7 +29,6 @@ appears on the bus.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .fxload-noa3load
|
||||
%patch1 -p1 -b .cflags
|
||||
|
||||
%build
|
||||
make CC=%{__cc} CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS"
|
||||
|
Loading…
Reference in New Issue
Block a user