New upstream release
This commit is contained in:
parent
0b44dc4e29
commit
fcdc366dc8
1
.gitignore
vendored
1
.gitignore
vendored
@ -101,3 +101,4 @@
|
||||
/fwupd-1.8.7.tar.xz
|
||||
/fwupd-1.8.8.tar.xz
|
||||
/fwupd-1.8.9.tar.xz
|
||||
/fwupd-1.8.10.tar.xz
|
||||
|
@ -1,57 +0,0 @@
|
||||
From 26e42c59eb529d24ca80c6e9f08e2e6edd7185bf Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Tue, 3 Jan 2023 17:59:44 +0000
|
||||
Subject: [PATCH] mtd: Use dummy SMBIOS data to fix self test on s390x
|
||||
|
||||
---
|
||||
plugins/mtd/fu-self-test.c | 1 +
|
||||
plugins/mtd/meson.build | 5 ++++-
|
||||
plugins/mtd/tests/dmi | 1 +
|
||||
3 files changed, 6 insertions(+), 1 deletion(-)
|
||||
create mode 120000 plugins/mtd/tests/dmi
|
||||
|
||||
diff --git a/plugins/mtd/fu-self-test.c b/plugins/mtd/fu-self-test.c
|
||||
index 73b8ed6df..c06f4f087 100644
|
||||
--- a/plugins/mtd/fu-self-test.c
|
||||
+++ b/plugins/mtd/fu-self-test.c
|
||||
@@ -103,6 +103,7 @@ main(int argc, char **argv)
|
||||
g_test_init(&argc, &argv, NULL);
|
||||
(void)g_setenv("FWUPD_MTD_VERBOSE", "1", TRUE);
|
||||
testdatadir = g_test_build_filename(G_TEST_DIST, "tests", NULL);
|
||||
+ (void)g_setenv("FWUPD_SYSFSFWDIR", testdatadir, TRUE);
|
||||
(void)g_setenv("FWUPD_SYSFSFWATTRIBDIR", testdatadir, TRUE);
|
||||
|
||||
g_log_set_fatal_mask(NULL, G_LOG_LEVEL_ERROR | G_LOG_LEVEL_CRITICAL);
|
||||
diff --git a/plugins/mtd/meson.build b/plugins/mtd/meson.build
|
||||
index 316948e85..442f5f3da 100644
|
||||
--- a/plugins/mtd/meson.build
|
||||
+++ b/plugins/mtd/meson.build
|
||||
@@ -15,6 +15,9 @@ plugin_builtin_mtd = static_library('fu_plugin_mtd',
|
||||
plugin_builtins += plugin_builtin_mtd
|
||||
|
||||
if get_option('tests')
|
||||
+ env = environment()
|
||||
+ env.set('G_TEST_SRCDIR', meson.current_source_dir())
|
||||
+ env.set('G_TEST_BUILDDIR', meson.current_build_dir())
|
||||
e = executable(
|
||||
'mtd-self-test',
|
||||
sources: [
|
||||
@@ -31,6 +34,6 @@ if get_option('tests')
|
||||
install_rpath: libdir_pkg,
|
||||
install_dir: installed_test_bindir,
|
||||
)
|
||||
- test('mtd-self-test', e) # added to installed-tests
|
||||
+ test('mtd-self-test', e, env: env) # added to installed-tests
|
||||
endif
|
||||
endif
|
||||
diff --git a/plugins/mtd/tests/dmi b/plugins/mtd/tests/dmi
|
||||
new file mode 120000
|
||||
index 000000000..545fadeaf
|
||||
--- /dev/null
|
||||
+++ b/plugins/mtd/tests/dmi
|
||||
@@ -0,0 +1 @@
|
||||
+../../../libfwupdplugin/tests/dmi/
|
||||
\ No newline at end of file
|
||||
--
|
||||
2.38.1
|
||||
|
@ -48,14 +48,12 @@
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 1.8.9
|
||||
Version: 1.8.10
|
||||
Release: %autorelease
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/fwupd/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch1: 0001-mtd-Use-dummy-SMBIOS-data-to-fix-self-test-on-s390x.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
||||
@ -404,6 +402,8 @@ done
|
||||
%if 0%{?have_uefi}
|
||||
%{_datadir}/installed-tests/fwupd/efi
|
||||
%endif
|
||||
%{_datadir}/installed-tests/fwupd/chassis_type
|
||||
%{_datadir}/installed-tests/fwupd/sys_vendor
|
||||
%{_datadir}/fwupd/device-tests/*.json
|
||||
%{_libexecdir}/installed-tests/fwupd/*
|
||||
%dir %{_sysconfdir}/fwupd/remotes.d
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fwupd-1.8.9.tar.xz) = 91dc477ac83c5c691bd9c88d69c3289292e6cbde2708ffc64d1823abbde75300a15d2b4bd1e6b2cac693082ba5e565c6749bbe09207aebd1f13aec361647e4d7
|
||||
SHA512 (fwupd-1.8.10.tar.xz) = 8437cdc93d553e42d33a037d14fcb09bb65b4c4d7d60add6a90c84dce0845097fe96005a1f6a9da7daf89df5b7dcd1b43a9fbba666cd18129b67ebe1c3ce7c97
|
||||
|
Loading…
Reference in New Issue
Block a user