Import from AlmaLinux stable repository
This commit is contained in:
parent
837ef2387d
commit
eef873ad71
@ -8,8 +8,9 @@ cd2bbe591438fe893b4042dc03d30659c1e31756 SOURCES/DBXUpdate-20210429-x64.cab
|
|||||||
d3ae610f5b6e602feded54eae8d67ddb7c60e64f SOURCES/DBXUpdate-20220812-aa64.cab
|
d3ae610f5b6e602feded54eae8d67ddb7c60e64f SOURCES/DBXUpdate-20220812-aa64.cab
|
||||||
0ac8508ef7a86959e6ab03deec256b19df29677f SOURCES/DBXUpdate-20220812-ia32.cab
|
0ac8508ef7a86959e6ab03deec256b19df29677f SOURCES/DBXUpdate-20220812-ia32.cab
|
||||||
60f9aa664cb7588e33ce56d621dafa9b5a71e072 SOURCES/DBXUpdate-20220812-x64.cab
|
60f9aa664cb7588e33ce56d621dafa9b5a71e072 SOURCES/DBXUpdate-20220812-x64.cab
|
||||||
1f06b0f236377e5100815d1367954c6bf263f4e4 SOURCES/DBXUpdate-20230509-aa64.cab
|
46a42362cd34c0d103cf534ca431508d24715e51 SOURCES/DBXUpdate-20230509-aa64.cab
|
||||||
6fc53ba85dc791f16235e851f4693c6c49fbf38d SOURCES/DBXUpdate-20230509-ia32.cab
|
23d9544ef0f9b39a76d258f6d4a4a54d8f7592b2 SOURCES/DBXUpdate-20230509-ia32.cab
|
||||||
93470ea2546e4c794b5fd74ee4dd8e536420144e SOURCES/DBXUpdate-20230509-x64.cab
|
bc6a604b29918d67d5fef745ad4375ca3d43d05e SOURCES/DBXUpdate-20230509-x64.cab
|
||||||
0abed3cf70b97366f77616b908af66f7b4ac6f1f SOURCES/fwupd-1.8.16.tar.xz
|
077f737b9a26b59d2517ee390879f02ab464a284 SOURCES/almalinuxsecurebootca0.cer
|
||||||
|
a8c8f0cc046ecff12e425484bc5ec1eb7fe49e90 SOURCES/fwupd-1.9.13.tar.xz
|
||||||
147b36f75fca288fd01d9ed4150866344d57df27 SOURCES/fwupd-efi-1.4.tar.xz
|
147b36f75fca288fd01d9ed4150866344d57df27 SOURCES/fwupd-efi-1.4.tar.xz
|
||||||
|
3
.gitignore
vendored
3
.gitignore
vendored
@ -11,5 +11,6 @@ SOURCES/DBXUpdate-20220812-x64.cab
|
|||||||
SOURCES/DBXUpdate-20230509-aa64.cab
|
SOURCES/DBXUpdate-20230509-aa64.cab
|
||||||
SOURCES/DBXUpdate-20230509-ia32.cab
|
SOURCES/DBXUpdate-20230509-ia32.cab
|
||||||
SOURCES/DBXUpdate-20230509-x64.cab
|
SOURCES/DBXUpdate-20230509-x64.cab
|
||||||
SOURCES/fwupd-1.8.16.tar.xz
|
SOURCES/almalinuxsecurebootca0.cer
|
||||||
|
SOURCES/fwupd-1.9.13.tar.xz
|
||||||
SOURCES/fwupd-efi-1.4.tar.xz
|
SOURCES/fwupd-efi-1.4.tar.xz
|
||||||
|
@ -0,0 +1,47 @@
|
|||||||
|
From 6fc21ec8364babc2edc57d6a39ee44c1e72cc6b2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Richard Hughes <richard@hughsie.com>
|
||||||
|
Date: Sun, 18 Feb 2024 10:23:03 +0000
|
||||||
|
Subject: [PATCH] Correctly migrate from v2 to database schema v10
|
||||||
|
|
||||||
|
Artificially bump the schema version to v11 to ensure the migration is done.
|
||||||
|
|
||||||
|
diff --git a/src/fu-history.c b/src/fu-history.c
|
||||||
|
index 21a4fd3e8..3be03c3a7 100644
|
||||||
|
--- a/src/fu-history.c
|
||||||
|
+++ b/src/fu-history.c
|
||||||
|
@@ -21,7 +21,20 @@
|
||||||
|
#include "fu-history.h"
|
||||||
|
#include "fu-security-attr-common.h"
|
||||||
|
|
||||||
|
-#define FU_HISTORY_CURRENT_SCHEMA_VERSION 10
|
||||||
|
+/*
|
||||||
|
+ * v1 legacy schema
|
||||||
|
+ * v2 initial schema
|
||||||
|
+ * v3 add checksum_device to history
|
||||||
|
+ * v4 add protocol to history
|
||||||
|
+ * v5 create table approved_firmware
|
||||||
|
+ * v6 create table blocked_firmware
|
||||||
|
+ * v7 create table hsi_history
|
||||||
|
+ * v8 add release_id to history
|
||||||
|
+ * v9 add appstream_id to history
|
||||||
|
+ * v10 add version_format to history
|
||||||
|
+ * v11 no changes, bumped due to bungled migration to v10
|
||||||
|
+ */
|
||||||
|
+#define FU_HISTORY_CURRENT_SCHEMA_VERSION 11
|
||||||
|
|
||||||
|
static void
|
||||||
|
fu_history_finalize(GObject *object);
|
||||||
|
@@ -466,11 +479,12 @@ fu_history_create_or_migrate(FuHistory *self, guint schema_ver, GError **error)
|
||||||
|
case 8:
|
||||||
|
if (!fu_history_migrate_database_v8(self, error))
|
||||||
|
return FALSE;
|
||||||
|
- break;
|
||||||
|
/* fall through */
|
||||||
|
case 9:
|
||||||
|
+ case 10:
|
||||||
|
if (!fu_history_migrate_database_v9(self, error))
|
||||||
|
return FALSE;
|
||||||
|
+ /* no longer fall through */
|
||||||
|
break;
|
||||||
|
default:
|
||||||
|
/* this is probably okay, but return an error if we ever delete
|
Binary file not shown.
102
SPECS/fwupd.spec
102
SPECS/fwupd.spec
@ -40,11 +40,6 @@
|
|||||||
%global have_msr 1
|
%global have_msr 1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# libsmbios is only available on x86
|
|
||||||
%ifarch x86_64
|
|
||||||
%global have_dell 1
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# Until we actually have seen it outside x86
|
# Until we actually have seen it outside x86
|
||||||
%ifarch i686 x86_64
|
%ifarch i686 x86_64
|
||||||
%global have_thunderbolt 1
|
%global have_thunderbolt 1
|
||||||
@ -57,14 +52,15 @@
|
|||||||
|
|
||||||
Summary: Firmware update daemon
|
Summary: Firmware update daemon
|
||||||
Name: fwupd
|
Name: fwupd
|
||||||
Version: 1.8.16
|
Version: 1.9.13
|
||||||
Release: 1%{?dist}.alma.2
|
Release: 2%{?dist}.alma.1
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/fwupd/fwupd
|
URL: https://github.com/fwupd/fwupd
|
||||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||||
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.4.tar.xz
|
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.4.tar.xz
|
||||||
|
|
||||||
Patch101: 0001-generate_binary-Add-NX-COMPAT-flag-manually-when-gen.patch
|
Patch101: 0001-generate_binary-Add-NX-COMPAT-flag-manually-when-gen.patch
|
||||||
|
Patch102: 0001-Correctly-migrate-from-v2-to-database-schema-v10.patch
|
||||||
|
|
||||||
Source10: http://people.redhat.com/rhughes/dbx/DBXUpdate-20100307-x64.cab
|
Source10: http://people.redhat.com/rhughes/dbx/DBXUpdate-20100307-x64.cab
|
||||||
Source11: http://people.redhat.com/rhughes/dbx/DBXUpdate-20140413-x64.cab
|
Source11: http://people.redhat.com/rhughes/dbx/DBXUpdate-20140413-x64.cab
|
||||||
@ -90,7 +86,6 @@ Source503: almalinuxsecurebootca0.cer
|
|||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
||||||
BuildRequires: libgcab1-devel
|
|
||||||
BuildRequires: libgudev1-devel
|
BuildRequires: libgudev1-devel
|
||||||
BuildRequires: libgusb-devel >= %{libgusb_version}
|
BuildRequires: libgusb-devel >= %{libgusb_version}
|
||||||
BuildRequires: libcurl-devel >= %{libcurl_version}
|
BuildRequires: libcurl-devel >= %{libcurl_version}
|
||||||
@ -101,7 +96,6 @@ BuildRequires: systemd >= %{systemd_version}
|
|||||||
BuildRequires: systemd-devel
|
BuildRequires: systemd-devel
|
||||||
BuildRequires: libarchive-devel
|
BuildRequires: libarchive-devel
|
||||||
BuildRequires: gobject-introspection-devel
|
BuildRequires: gobject-introspection-devel
|
||||||
BuildRequires: gcab
|
|
||||||
%ifarch %{valgrind_arches}
|
%ifarch %{valgrind_arches}
|
||||||
BuildRequires: valgrind
|
BuildRequires: valgrind
|
||||||
BuildRequires: valgrind-devel
|
BuildRequires: valgrind-devel
|
||||||
@ -116,6 +110,8 @@ BuildRequires: git-core
|
|||||||
%if 0%{?have_flashrom}
|
%if 0%{?have_flashrom}
|
||||||
BuildRequires: flashrom-devel >= 1.2-2
|
BuildRequires: flashrom-devel >= 1.2-2
|
||||||
%endif
|
%endif
|
||||||
|
BuildRequires: libdrm-devel
|
||||||
|
BuildRequires: python3-jinja2
|
||||||
|
|
||||||
%if 0%{?have_modem_manager}
|
%if 0%{?have_modem_manager}
|
||||||
BuildRequires: ModemManager-glib-devel >= 1.10.0
|
BuildRequires: ModemManager-glib-devel >= 1.10.0
|
||||||
@ -136,11 +132,6 @@ BuildRequires: tpm2-tss-devel >= 2.2.3
|
|||||||
BuildRequires: pesign >= 113-20
|
BuildRequires: pesign >= 113-20
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if 0%{?have_dell}
|
|
||||||
BuildRequires: efivar-devel >= 33
|
|
||||||
BuildRequires: libsmbios-devel >= 2.3.0
|
|
||||||
%endif
|
|
||||||
|
|
||||||
Requires(post): systemd
|
Requires(post): systemd
|
||||||
Requires(preun): systemd
|
Requires(preun): systemd
|
||||||
Requires(postun): systemd
|
Requires(postun): systemd
|
||||||
@ -209,6 +200,7 @@ can be flashed using flashrom. It is probably not required on servers.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch102 -p1
|
||||||
|
|
||||||
mkdir -p subprojects/fwupd-efi
|
mkdir -p subprojects/fwupd-efi
|
||||||
tar xfvs %{SOURCE2} -C subprojects/fwupd-efi --strip-components=1
|
tar xfvs %{SOURCE2} -C subprojects/fwupd-efi --strip-components=1
|
||||||
@ -221,16 +213,13 @@ cd -
|
|||||||
%meson \
|
%meson \
|
||||||
-Ddocs=disabled \
|
-Ddocs=disabled \
|
||||||
-Dlvfs=disabled \
|
-Dlvfs=disabled \
|
||||||
|
-Dlaunchd=disabled \
|
||||||
|
-Dpassim=disabled \
|
||||||
%if 0%{?enable_tests}
|
%if 0%{?enable_tests}
|
||||||
-Dtests=true \
|
-Dtests=true \
|
||||||
%else
|
%else
|
||||||
-Dtests=false \
|
-Dtests=false \
|
||||||
%endif
|
%endif
|
||||||
%if 0%{?enable_dummy}
|
|
||||||
-Dplugin_dummy=true \
|
|
||||||
%else
|
|
||||||
-Dplugin_dummy=false \
|
|
||||||
%endif
|
|
||||||
%if 0%{?have_flashrom}
|
%if 0%{?have_flashrom}
|
||||||
-Dplugin_flashrom=enabled \
|
-Dplugin_flashrom=enabled \
|
||||||
%else
|
%else
|
||||||
@ -256,7 +245,7 @@ cd -
|
|||||||
-Dfwupd-efi:efi_sbat_distro_summary="AlmaLinux" \
|
-Dfwupd-efi:efi_sbat_distro_summary="AlmaLinux" \
|
||||||
-Dfwupd-efi:efi_sbat_distro_pkgname="%{name}" \
|
-Dfwupd-efi:efi_sbat_distro_pkgname="%{name}" \
|
||||||
-Dfwupd-efi:efi_sbat_distro_version="%{version}" \
|
-Dfwupd-efi:efi_sbat_distro_version="%{version}" \
|
||||||
-Dfwupd-efi:efi_sbat_distro_url="maito:security@almalinux.org" \
|
-Dfwupd-efi:efi_sbat_distro_url="mailto:security@almalinux.org" \
|
||||||
-Dfwupd-efi:efi-libdir="/usr/lib64" \
|
-Dfwupd-efi:efi-libdir="/usr/lib64" \
|
||||||
%endif
|
%endif
|
||||||
%else
|
%else
|
||||||
@ -264,17 +253,13 @@ cd -
|
|||||||
-Dplugin_uefi_pk=disabled \
|
-Dplugin_uefi_pk=disabled \
|
||||||
-Dplugin_tpm=disabled \
|
-Dplugin_tpm=disabled \
|
||||||
%endif
|
%endif
|
||||||
%if 0%{?have_dell}
|
|
||||||
-Dplugin_dell=enabled \
|
|
||||||
%else
|
|
||||||
-Dplugin_dell=disabled \
|
|
||||||
%endif
|
|
||||||
%if 0%{?have_modem_manager}
|
%if 0%{?have_modem_manager}
|
||||||
-Dplugin_modem_manager=enabled \
|
-Dplugin_modem_manager=enabled \
|
||||||
%else
|
%else
|
||||||
-Dplugin_modem_manager=disabled \
|
-Dplugin_modem_manager=disabled \
|
||||||
%endif
|
%endif
|
||||||
-Dman=true \
|
-Dman=true \
|
||||||
|
-Dsystemd_unit_user="" \
|
||||||
-Dcompat_cli=true \
|
-Dcompat_cli=true \
|
||||||
-Dbluez=disabled \
|
-Dbluez=disabled \
|
||||||
-Dcbor=disabled \
|
-Dcbor=disabled \
|
||||||
@ -323,7 +308,7 @@ mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/fwupd
|
|||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
%post
|
%post
|
||||||
%systemd_post fwupd.service
|
%systemd_post fwupd.service fwupd-refresh.timer
|
||||||
|
|
||||||
# change vendor-installed remotes to use the default keyring type
|
# change vendor-installed remotes to use the default keyring type
|
||||||
for fn in /etc/fwupd/remotes.d/*.conf; do
|
for fn in /etc/fwupd/remotes.d/*.conf; do
|
||||||
@ -333,23 +318,16 @@ for fn in /etc/fwupd/remotes.d/*.conf; do
|
|||||||
done
|
done
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
%systemd_preun fwupd.service
|
%systemd_preun fwupd.service fwupd-refresh.timer
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
%systemd_postun_with_restart fwupd.service
|
%systemd_postun_with_restart fwupd.service fwupd-refresh.timer
|
||||||
%systemd_postun_with_restart pesign.service
|
%systemd_postun_with_restart pesign.service
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%doc README.md
|
%doc README.md
|
||||||
%license COPYING
|
%license COPYING
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/daemon.conf
|
%config(noreplace)%{_sysconfdir}/fwupd/fwupd.conf
|
||||||
%if 0%{?have_uefi}
|
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/uefi_capsule.conf
|
|
||||||
%endif
|
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/redfish.conf
|
|
||||||
%if 0%{?have_thunderbolt}
|
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/thunderbolt.conf
|
|
||||||
%endif
|
|
||||||
%dir %{_libexecdir}/fwupd
|
%dir %{_libexecdir}/fwupd
|
||||||
%{_libexecdir}/fwupd/fwupd
|
%{_libexecdir}/fwupd/fwupd
|
||||||
%ifarch i686 x86_64
|
%ifarch i686 x86_64
|
||||||
@ -364,9 +342,7 @@ done
|
|||||||
%{_bindir}/fwupdate
|
%{_bindir}/fwupdate
|
||||||
%endif
|
%endif
|
||||||
%{_bindir}/dfu-tool
|
%{_bindir}/dfu-tool
|
||||||
%if 0%{?have_uefi}
|
|
||||||
%{_bindir}/dbxtool
|
%{_bindir}/dbxtool
|
||||||
%endif
|
|
||||||
%{_bindir}/fwupdmgr
|
%{_bindir}/fwupdmgr
|
||||||
%{_bindir}/fwupdtool
|
%{_bindir}/fwupdtool
|
||||||
%{_bindir}/fwupdagent
|
%{_bindir}/fwupdagent
|
||||||
@ -374,27 +350,19 @@ done
|
|||||||
%dir %{_sysconfdir}/fwupd/bios-settings.d
|
%dir %{_sysconfdir}/fwupd/bios-settings.d
|
||||||
%{_sysconfdir}/fwupd/bios-settings.d/README.md
|
%{_sysconfdir}/fwupd/bios-settings.d/README.md
|
||||||
%dir %{_sysconfdir}/fwupd/remotes.d
|
%dir %{_sysconfdir}/fwupd/remotes.d
|
||||||
%if 0%{?have_dell}
|
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/dell-esrt.conf
|
|
||||||
%endif
|
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs.conf
|
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs.conf
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs-testing.conf
|
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs-testing.conf
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/vendor.conf
|
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/vendor-directory.conf
|
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/vendor-directory.conf
|
||||||
%config(noreplace)%{_sysconfdir}/pki/fwupd
|
%config(noreplace)%{_sysconfdir}/pki/fwupd
|
||||||
%{_sysconfdir}/pki/fwupd-metadata
|
%{_sysconfdir}/pki/fwupd-metadata
|
||||||
%if 0%{?have_msr}
|
%if 0%{?have_msr}
|
||||||
/usr/lib/modules-load.d/fwupd-msr.conf
|
/usr/lib/modules-load.d/fwupd-msr.conf
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/msr.conf
|
|
||||||
%endif
|
%endif
|
||||||
%{_datadir}/dbus-1/system.d/org.freedesktop.fwupd.conf
|
%{_datadir}/dbus-1/system.d/org.freedesktop.fwupd.conf
|
||||||
%{_datadir}/bash-completion/completions/fwupdmgr
|
%{_datadir}/bash-completion/completions/fwupdmgr
|
||||||
%{_datadir}/bash-completion/completions/fwupdtool
|
%{_datadir}/bash-completion/completions/fwupdtool
|
||||||
%{_datadir}/fish/vendor_completions.d/fwupdmgr.fish
|
%{_datadir}/fish/vendor_completions.d/fwupdmgr.fish
|
||||||
%{_datadir}/fwupd/metainfo/org.freedesktop.fwupd*.metainfo.xml
|
%{_datadir}/fwupd/metainfo/org.freedesktop.fwupd*.metainfo.xml
|
||||||
%if 0%{?have_dell}
|
|
||||||
%{_datadir}/fwupd/remotes.d/dell-esrt/metadata.xml
|
|
||||||
%endif
|
|
||||||
%{_datadir}/fwupd/remotes.d/vendor/firmware/README.md
|
%{_datadir}/fwupd/remotes.d/vendor/firmware/README.md
|
||||||
%{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
|
%{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
|
||||||
%{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
|
%{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
|
||||||
@ -414,16 +382,9 @@ done
|
|||||||
%{_datadir}/dbxtool/DBXUpdate-20230509-aa64.cab
|
%{_datadir}/dbxtool/DBXUpdate-20230509-aa64.cab
|
||||||
%{_datadir}/dbxtool/DBXUpdate-20230509-ia32.cab
|
%{_datadir}/dbxtool/DBXUpdate-20230509-ia32.cab
|
||||||
%{_datadir}/dbxtool/DBXUpdate-20230509-x64.cab
|
%{_datadir}/dbxtool/DBXUpdate-20230509-x64.cab
|
||||||
%{_mandir}/man1/fwupdtool.1*
|
%{_mandir}/man1/*
|
||||||
%{_mandir}/man1/fwupdagent.1*
|
%{_mandir}/man5/*
|
||||||
%{_mandir}/man1/dfu-tool.1*
|
%{_mandir}/man8/*
|
||||||
%if 0%{?have_uefi}
|
|
||||||
%{_mandir}/man1/dbxtool.*
|
|
||||||
%endif
|
|
||||||
%{_mandir}/man1/fwupdmgr.1*
|
|
||||||
%if 0%{?have_uefi}
|
|
||||||
%{_mandir}/man1/fwupdate.1*
|
|
||||||
%endif
|
|
||||||
%{_datadir}/metainfo/org.freedesktop.fwupd.metainfo.xml
|
%{_datadir}/metainfo/org.freedesktop.fwupd.metainfo.xml
|
||||||
%{_datadir}/icons/hicolor/scalable/apps/org.freedesktop.fwupd.svg
|
%{_datadir}/icons/hicolor/scalable/apps/org.freedesktop.fwupd.svg
|
||||||
%{_datadir}/fwupd/firmware_packager.py
|
%{_datadir}/fwupd/firmware_packager.py
|
||||||
@ -434,7 +395,6 @@ done
|
|||||||
%{_unitdir}/fwupd.service
|
%{_unitdir}/fwupd.service
|
||||||
%{_unitdir}/fwupd-refresh.service
|
%{_unitdir}/fwupd-refresh.service
|
||||||
%{_unitdir}/fwupd-refresh.timer
|
%{_unitdir}/fwupd-refresh.timer
|
||||||
%{_presetdir}/fwupd-refresh.preset
|
|
||||||
%{_unitdir}/system-update.target.wants/
|
%{_unitdir}/system-update.target.wants/
|
||||||
%dir %{_localstatedir}/lib/fwupd
|
%dir %{_localstatedir}/lib/fwupd
|
||||||
%dir %{_localstatedir}/cache/fwupd
|
%dir %{_localstatedir}/cache/fwupd
|
||||||
@ -481,6 +441,9 @@ done
|
|||||||
%{_datadir}/installed-tests/fwupd/fwupd-tests.xml
|
%{_datadir}/installed-tests/fwupd/fwupd-tests.xml
|
||||||
%{_datadir}/installed-tests/fwupd/*.test
|
%{_datadir}/installed-tests/fwupd/*.test
|
||||||
%{_datadir}/installed-tests/fwupd/*.cab
|
%{_datadir}/installed-tests/fwupd/*.cab
|
||||||
|
%{_datadir}/installed-tests/fwupd/fakedevice124.jcat
|
||||||
|
%{_datadir}/installed-tests/fwupd/fakedevice124.bin
|
||||||
|
%{_datadir}/installed-tests/fwupd/fakedevice124.metainfo.xml
|
||||||
%{_datadir}/installed-tests/fwupd/*.sh
|
%{_datadir}/installed-tests/fwupd/*.sh
|
||||||
%{_datadir}/installed-tests/fwupd/*.zip
|
%{_datadir}/installed-tests/fwupd/*.zip
|
||||||
%if 0%{?have_uefi}
|
%if 0%{?have_uefi}
|
||||||
@ -490,13 +453,33 @@ done
|
|||||||
%{_datadir}/installed-tests/fwupd/sys_vendor
|
%{_datadir}/installed-tests/fwupd/sys_vendor
|
||||||
%{_libexecdir}/installed-tests/fwupd/*
|
%{_libexecdir}/installed-tests/fwupd/*
|
||||||
%dir %{_sysconfdir}/fwupd/remotes.d
|
%dir %{_sysconfdir}/fwupd/remotes.d
|
||||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/fwupd-tests.conf
|
%{_datadir}/fwupd/remotes.d/fwupd-tests.conf
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Oct 09 2023 Eduard Abdullin <eabdullin@almalinux.org> - 1.8.16-1.alma.1
|
* Thu Mar 28 2024 Eduard Abdullin <eabdullin@almalinux.org> - 1.9.13-2.alma.1
|
||||||
- Use AlmaLinux cert
|
- Use AlmaLinux cert
|
||||||
|
|
||||||
|
* Mon Feb 19 2024 Richard Hughes <richard@hughsie.com> 1.9.13-2
|
||||||
|
- Fix upgrade from fwupd < v1.9.5
|
||||||
|
- Resolves: #RHEL-15328
|
||||||
|
|
||||||
|
* Thu Feb 15 2024 Richard Hughes <richard@hughsie.com> 1.9.13-1
|
||||||
|
- Update to latest stable upstream version.
|
||||||
|
- Resolves: #RHEL-15328
|
||||||
|
|
||||||
|
* Wed Jan 24 2024 Richard Hughes <richard@hughsie.com> 1.9.12-1
|
||||||
|
- Update to latest stable upstream version.
|
||||||
|
- Resolves: #RHEL-15328
|
||||||
|
|
||||||
|
* Wed Jan 03 2024 Richard Hughes <richard@hughsie.com> 1.9.11-1
|
||||||
|
- Update to latest stable upstream version.
|
||||||
|
- Resolves: #RHEL-15328
|
||||||
|
|
||||||
|
* Mon Dec 04 2023 Richard Hughes <richard@hughsie.com> 1.9.10-1
|
||||||
|
- Update to latest stable upstream version.
|
||||||
|
- Resolves: #RHEL-15328
|
||||||
|
|
||||||
* Fri Jun 09 2023 Richard Hughes <richard@hughsie.com> 1.8.16-1
|
* Fri Jun 09 2023 Richard Hughes <richard@hughsie.com> 1.8.16-1
|
||||||
- Update to latest stable upstream version.
|
- Update to latest stable upstream version.
|
||||||
- Resolves: rhbz#2209944
|
- Resolves: rhbz#2209944
|
||||||
@ -504,6 +487,7 @@ done
|
|||||||
* Thu Feb 02 2023 Richard Hughes <richard@hughsie.com> 1.8.10-2
|
* Thu Feb 02 2023 Richard Hughes <richard@hughsie.com> 1.8.10-2
|
||||||
- Rebuild because distrobaker did entirely the wrong thing.
|
- Rebuild because distrobaker did entirely the wrong thing.
|
||||||
- Resolves: rhbz#2128384, needed for rhbz#2119436 and rhbz#2128384
|
- Resolves: rhbz#2128384, needed for rhbz#2119436 and rhbz#2128384
|
||||||
|
|
||||||
* Fri Jan 27 2023 Richard Hughes <richard@hughsie.com> 1.8.10-1
|
* Fri Jan 27 2023 Richard Hughes <richard@hughsie.com> 1.8.10-1
|
||||||
- Rebase to latest upstream release to fix multiple ESP detection problems
|
- Rebase to latest upstream release to fix multiple ESP detection problems
|
||||||
- Resolves: rhbz#2128384, needed for rhbz#2119436 and rhbz#2128384
|
- Resolves: rhbz#2128384, needed for rhbz#2119436 and rhbz#2128384
|
||||||
|
Loading…
Reference in New Issue
Block a user