New upstream release
This commit is contained in:
parent
493fc741d6
commit
db0be44b00
1
.gitignore
vendored
1
.gitignore
vendored
@ -96,3 +96,4 @@
|
||||
/fwupd-1.8.2.tar.xz
|
||||
/fwupd-1.8.3.tar.xz
|
||||
/fwupd-1.8.4.tar.xz
|
||||
/fwupd-1.8.5.tar.xz
|
||||
|
36
0001-Install-the-docs-in-the-correct-place.patch
Normal file
36
0001-Install-the-docs-in-the-correct-place.patch
Normal file
@ -0,0 +1,36 @@
|
||||
From 9293b8e32261ed23a0e5cde32f2f690cd6650a25 Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Thu, 22 Sep 2022 15:48:03 +0100
|
||||
Subject: [PATCH] Install the docs in the correct place
|
||||
|
||||
We want /usr/share/docs/fwupd/libfwupd for the docs that can be referenced from
|
||||
index.html, and a symlink of /usr/share/docs/libfwupd for devhelp.
|
||||
|
||||
This also fixes the rpmbuild warning:
|
||||
|
||||
# absolute symlink: /usr/share/doc/fwupd/libfwupd -> /usr/share/doc/libfwupd
|
||||
# absolute symlink: /usr/share/doc/fwupd/libfwupdplugin -> /usr/share/doc/libfwupdplugin
|
||||
---
|
||||
docs/meson.build | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/docs/meson.build b/docs/meson.build
|
||||
index 92b9e6fc7..75dd9a3d7 100644
|
||||
--- a/docs/meson.build
|
||||
+++ b/docs/meson.build
|
||||
@@ -82,10 +82,10 @@ if gidocgen_dep.found() and docs_python_deps.allowed() and gidocgen_app.found()
|
||||
#make devhelp work
|
||||
install_symlink('libfwupd',
|
||||
install_dir: join_paths(datadir, 'doc', 'fwupd'),
|
||||
- pointing_to: join_paths(datadir, 'doc', 'libfwupd'),
|
||||
+ pointing_to: join_paths('..', 'libfwupd'),
|
||||
)
|
||||
install_symlink('libfwupdplugin',
|
||||
install_dir: join_paths(datadir, 'doc', 'fwupd'),
|
||||
- pointing_to: join_paths(datadir, 'doc', 'libfwupdplugin'),
|
||||
+ pointing_to: join_paths('..', 'libfwupdplugin'),
|
||||
)
|
||||
endif
|
||||
--
|
||||
2.37.3
|
||||
|
51
fwupd.spec
51
fwupd.spec
@ -42,6 +42,11 @@
|
||||
%global have_dell 1
|
||||
%endif
|
||||
|
||||
# Until we actually have seen it outside x86
|
||||
%ifarch i686 x86_64
|
||||
%global have_thunderbolt 1
|
||||
%endif
|
||||
|
||||
# only available recently
|
||||
%if 0%{?fedora} >= 30
|
||||
%global have_modem_manager 1
|
||||
@ -49,12 +54,14 @@
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 1.8.4
|
||||
Release: 2%{?dist}
|
||||
Version: 1.8.5
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/fwupd/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch0: 0001-Install-the-docs-in-the-correct-place.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
||||
@ -263,12 +270,6 @@ or server machines.
|
||||
%install
|
||||
%meson_install
|
||||
|
||||
# move the symlink out of the way
|
||||
rm -f $RPM_BUILD_ROOT%{_datadir}/doc/libfwupdplugin
|
||||
rm -f $RPM_BUILD_ROOT%{_datadir}/doc/libfwupd
|
||||
mv $RPM_BUILD_ROOT%{_datadir}/doc/fwupd/libfwupdplugin $RPM_BUILD_ROOT%{_datadir}/doc/
|
||||
mv $RPM_BUILD_ROOT%{_datadir}/doc/fwupd/libfwupd $RPM_BUILD_ROOT%{_datadir}/doc/
|
||||
|
||||
mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
|
||||
# workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1757948
|
||||
@ -300,7 +301,9 @@ done
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/uefi_capsule.conf
|
||||
%endif
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/redfish.conf
|
||||
%if 0%{?have_thunderbolt}
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/thunderbolt.conf
|
||||
%endif
|
||||
%dir %{_libexecdir}/fwupd
|
||||
%{_libexecdir}/fwupd/fwupd
|
||||
%ifarch i686 x86_64
|
||||
@ -391,6 +394,7 @@ done
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_acpi_phat.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_amt.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_analogix.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_android_boot.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_ata.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_bcm57xx.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_cfu.so
|
||||
@ -419,6 +423,7 @@ done
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_gpio.so
|
||||
%endif
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_hailuck.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_intel_usb4.so
|
||||
%ifarch i686 x86_64
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_iommu.so
|
||||
%endif
|
||||
@ -438,6 +443,7 @@ done
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_msr.so
|
||||
%endif
|
||||
%ifarch i686 x86_64
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_amd_pmc.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_pci_psp.so
|
||||
%endif
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_mtd.so
|
||||
@ -468,7 +474,9 @@ done
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_invalid.so
|
||||
%endif
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_thelio_io.so
|
||||
%if 0%{?have_thunderbolt}
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_thunderbolt.so
|
||||
%endif
|
||||
%if 0%{?have_uefi}
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_tpm.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_bios.so
|
||||
@ -506,6 +514,8 @@ done
|
||||
%files devel
|
||||
%{_datadir}/gir-1.0/Fwupd-2.0.gir
|
||||
%{_datadir}/gir-1.0/FwupdPlugin-1.0.gir
|
||||
%{_datadir}/doc/fwupd/libfwupdplugin
|
||||
%{_datadir}/doc/fwupd/libfwupd
|
||||
%{_datadir}/doc/libfwupdplugin
|
||||
%{_datadir}/doc/libfwupd
|
||||
%{_datadir}/vala/vapi
|
||||
@ -516,6 +526,7 @@ done
|
||||
|
||||
%files tests
|
||||
%if 0%{?enable_tests}
|
||||
%{_datadir}/fwupd/host-emulate.d/*.json.gz
|
||||
%dir %{_datadir}/installed-tests/fwupd
|
||||
%{_datadir}/installed-tests/fwupd/tests/*
|
||||
%{_datadir}/installed-tests/fwupd/fwupd-tests.xml
|
||||
@ -526,13 +537,35 @@ done
|
||||
%{_datadir}/installed-tests/fwupd/efi
|
||||
%endif
|
||||
%{_datadir}/fwupd/device-tests/*.json
|
||||
%{_datadir}/fwupd/host-emulate.d/*.json.gz
|
||||
%{_libexecdir}/installed-tests/fwupd/*
|
||||
%dir %{_sysconfdir}/fwupd/remotes.d
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/fwupd-tests.conf
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Sep 22 2022 Richard Hughes <richard@hughsie.com> 1.8.5-1
|
||||
- New upstream release
|
||||
- Add new plugin to display SMU firmware version on AMD APU/CPU
|
||||
- Add support for platform capability descriptors so devices can set quirks
|
||||
- Always check the BDP partitions when getting all the possible ESPs
|
||||
- Correctly update Wacom AES devices
|
||||
- Disable changing sleep mode on Ryzen 6000 systems
|
||||
- Do not show the 'may not be usable while updating' message for DBX updates
|
||||
- Fix a critical warning when issuing Secure Boot modem AT commands
|
||||
- Fix a fuzzing crash when parsing malicious FDT data
|
||||
- Fix a possible crash when dumping VBE firmware
|
||||
- Fix a possible critical warning when parsing cabinet archives
|
||||
- Fix a regression when parsing pixart-rf firmware
|
||||
- Fix a small memory leak when parsing UF2 files
|
||||
- Fix checking for invalid depth requirements
|
||||
- Fix parsing the coSWID firmware ID when encoded as a UUID
|
||||
- Fix parsing uSWID uncompressed metadata
|
||||
- Fix uploading to DFU-CSR devices
|
||||
- Load coSWID metadata from a uSWID MTD block device
|
||||
- Never save the Redfish auto-generated password to a user-readable file
|
||||
- Only create users using IPMI when we know it's going to work
|
||||
- Write all the CCGX metadata block as intended
|
||||
|
||||
* Tue Aug 30 2022 Richard Hughes <richard@hughsie.com> 1.8.4-2
|
||||
- Fix fwupd-devel upgrade issue.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fwupd-1.8.4.tar.xz) = 569d0cb81f9a29259d0a7ae7100ca1063d20557b56903f80c1466667baf40a74d677f48159e5bd53ab6b33de8ce7185bf279b6dbcf6edfee744c1d4965c5db8f
|
||||
SHA512 (fwupd-1.8.5.tar.xz) = 96856a56cb10b789bbbb82a33b702473cf1bdc32a9fddca6e48313ba3fefbe2f63a12a7290e3b4bd11939844f6989a0e15e96a4c2911cb900cd9e8d9c6c13f15
|
||||
|
Loading…
Reference in New Issue
Block a user