New upstream release
This commit is contained in:
parent
525affae4d
commit
d6b618abc1
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@
|
||||
/fwupd-0.7.5.tar.xz
|
||||
/fwupd-0.8.0.tar.xz
|
||||
/fwupd-0.8.1.tar.xz
|
||||
/fwupd-0.8.2.tar.xz
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 5b6f6d209e0b23e12ab67f4908ab2cbf5b9e4982 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Thu, 23 Mar 2017 12:20:02 +0100
|
||||
Subject: [PATCH] unifying: Release device in error path
|
||||
|
||||
When starting up fwupd, and the unifying receiver doesn't reply as
|
||||
we expect, fwupd keeps the device claimed, making it unavailable for use
|
||||
as an input device.
|
||||
|
||||
https://github.com/hughsie/fwupd/issues/101
|
||||
---
|
||||
plugins/unifying/fu-plugin-unifying.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/plugins/unifying/fu-plugin-unifying.c b/plugins/unifying/fu-plugin-unifying.c
|
||||
index 8fdf7db..d33a8b3 100644
|
||||
--- a/plugins/unifying/fu-plugin-unifying.c
|
||||
+++ b/plugins/unifying/fu-plugin-unifying.c
|
||||
@@ -61,8 +61,10 @@ fu_plugin_unifying_device_added (FuPlugin *plugin,
|
||||
fu_device_set_id (FU_DEVICE (dev), platform_id);
|
||||
|
||||
/* open the device */
|
||||
- if (!fu_device_unifying_open (dev, error))
|
||||
+ if (!fu_device_unifying_open (dev, error)) {
|
||||
+ fu_device_unifying_close (dev, NULL);
|
||||
return FALSE;
|
||||
+ }
|
||||
|
||||
/* close the device */
|
||||
if (!fu_device_unifying_close (dev, error))
|
||||
--
|
||||
2.12.0
|
||||
|
24
fwupd.spec
24
fwupd.spec
@ -14,8 +14,8 @@
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 0.8.1
|
||||
Release: 2%{?dist}
|
||||
Version: 0.8.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://github.com/hughsie/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
@ -42,8 +42,6 @@ BuildRequires: valgrind-devel
|
||||
BuildRequires: elfutils-libelf-devel
|
||||
BuildRequires: gtk-doc
|
||||
|
||||
Patch0: 0001-unifying-Release-device-in-error-path.patch
|
||||
|
||||
%if 0%{?have_smbios}
|
||||
BuildRequires: libsmbios-devel >= 2.3.0
|
||||
%endif
|
||||
@ -91,7 +89,6 @@ Files for development with libdfu.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .release-unifying
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -122,6 +119,9 @@ make install DESTDIR=$RPM_BUILD_ROOT
|
||||
find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
||||
mkdir --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
|
||||
# not ready for primetime yet
|
||||
rm -f %{buildroot}/usr/lib64/fwupd-plugins-2/libfu_plugin_unifying.so
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%check
|
||||
@ -163,9 +163,6 @@ mkdir --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
%dir %{_localstatedir}/lib/fwupd
|
||||
%{_libdir}/libfwupd*.so.*
|
||||
%{_libdir}/girepository-1.0/Fwupd-1.0.typelib
|
||||
%dir %{_localstatedir}/cache/app-info
|
||||
%dir %{_localstatedir}/cache/app-info/icons
|
||||
%dir %{_localstatedir}/cache/app-info/xmls
|
||||
/usr/lib/udev/rules.d/*.rules
|
||||
%dir %{_libdir}/fwupd-plugins-2
|
||||
%{_libdir}/fwupd-plugins-2/libfu_plugin_altos.so
|
||||
@ -185,7 +182,7 @@ mkdir --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
%if 0%{?have_uefi}
|
||||
%{_libdir}/fwupd-plugins-2/libfu_plugin_uefi.so
|
||||
%endif
|
||||
%{_libdir}/fwupd-plugins-2/libfu_plugin_unifying.so
|
||||
#%{_libdir}/fwupd-plugins-2/libfu_plugin_unifying.so
|
||||
%{_libdir}/fwupd-plugins-2/libfu_plugin_upower.so
|
||||
%{_libdir}/fwupd-plugins-2/libfu_plugin_usb.so
|
||||
%ghost %{_localstatedir}/lib/fwupd/gnupg
|
||||
@ -213,6 +210,15 @@ mkdir --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
%{_libdir}/pkgconfig/dfu.pc
|
||||
|
||||
%changelog
|
||||
* Thu Apr 20 2017 Richard Hughes <richard@hughsie.com> 0.8.2-1
|
||||
- New upstream release
|
||||
- Add a config option to allow runtime disabling plugins by name
|
||||
- Add DFU quirk for OpenPICC and SIMtrace
|
||||
- Create directories in /var/cache as required
|
||||
- Fix the Requires lines in the dfu pkg-config file
|
||||
- Only try to mkdir the localstatedir if we have the right permissions
|
||||
- Support proxy servers in fwupdmgr
|
||||
|
||||
* Thu Mar 23 2017 Bastien Nocera <bnocera@redhat.com> - 0.8.1-2
|
||||
+ fwupd-0.8.1-2
|
||||
- Release claimed devices on error, fixes unusable input devices
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fwupd-0.8.1.tar.xz) = 421505296e06806eb95f74a6d55a4a1f13a9b0f62549b706a3c93e014be3949b0e370f7a4a757e994ed7e8cd6e1b0a5f1da33567190ac74182affa828cf6a30b
|
||||
SHA512 (fwupd-0.8.2.tar.xz) = a0c19f7c3fb00a1f946cf2b2712b6c00a705146316efd5b4d6e33e36920312114d34a5850b0f152bfa50905b96768f30163c389baf0cd28bcee2aaa7d672c3ca
|
||||
|
Loading…
Reference in New Issue
Block a user