Rebase to get new hardware support
Resolves: #RHEL-82423
This commit is contained in:
parent
dddf88b0d6
commit
c6625141ad
2
.gitignore
vendored
2
.gitignore
vendored
@ -103,3 +103,5 @@
|
||||
/fwupd-1.9.12.tar.xz
|
||||
/fwupd-1.9.13.tar.xz
|
||||
/fwupd-1.9.26.tar.xz
|
||||
/fwupd-1.9.29.tar.xz
|
||||
/DBXUpdate-20241101-x64.cab
|
||||
|
@ -1,38 +0,0 @@
|
||||
From 11a6f914ae27953c9070f6e4cd562a326e1cb60c Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Tue, 15 Oct 2024 14:27:08 +0100
|
||||
Subject: [PATCH] Revert "trivial: bump libjcat and passim deps"
|
||||
|
||||
This reverts commit 774b87fed0c6addd49cdc65a3ecc24923f7c76ae.
|
||||
|
||||
We can update the subproject, but we can't raise the deps in a stable branch
|
||||
otherwise we make it really hard to build for RHEL and Ubuntu LTS.
|
||||
---
|
||||
meson.build | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 167e529d1..5047cab72 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -241,7 +241,7 @@ sqlite = dependency('sqlite3', required: get_option('sqlite'))
|
||||
if sqlite.found()
|
||||
conf.set('HAVE_SQLITE', '1')
|
||||
endif
|
||||
-passim = dependency('passim', version: '>= 0.1.5', required: get_option('passim'), fallback: ['passim', 'passim_dep'])
|
||||
+passim = dependency('passim', version: '>= 0.1.2', required: get_option('passim'), fallback: ['passim', 'passim_dep'])
|
||||
if passim.found()
|
||||
conf.set('HAVE_PASSIM', '1')
|
||||
endif
|
||||
@@ -253,7 +253,7 @@ if libarchive.found()
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
-libjcat = dependency('jcat', version: '>= 0.2.0', fallback: ['libjcat', 'libjcat_dep'])
|
||||
+libjcat = dependency('jcat', version: '>= 0.1.4', fallback: ['libjcat', 'libjcat_dep'])
|
||||
libjsonglib = dependency('json-glib-1.0', version: '>= 1.6.0')
|
||||
valgrind = dependency('valgrind', required: false)
|
||||
libcurl = dependency('libcurl', version: '>= 7.62.0', required: get_option('curl'))
|
||||
--
|
||||
2.47.0
|
||||
|
13
fwupd.spec
13
fwupd.spec
@ -48,7 +48,7 @@
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 1.9.26
|
||||
Version: 1.9.29
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/fwupd/fwupd
|
||||
@ -56,7 +56,6 @@ Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.
|
||||
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.4.tar.xz
|
||||
|
||||
Patch101: 0001-generate_binary-Add-NX-COMPAT-flag-manually-when-gen.patch
|
||||
Patch201: 0001-Revert-trivial-bump-libjcat-and-passim-deps.patch
|
||||
|
||||
Source10: http://people.redhat.com/rhughes/dbx/DBXUpdate-20100307-x64.cab
|
||||
Source11: http://people.redhat.com/rhughes/dbx/DBXUpdate-20140413-x64.cab
|
||||
@ -71,6 +70,7 @@ Source19: http://people.redhat.com/rhughes/dbx/DBXUpdate-20220812-x64.cab
|
||||
Source20: http://people.redhat.com/rhughes/dbx/DBXUpdate-20230509-aa64.cab
|
||||
Source21: http://people.redhat.com/rhughes/dbx/DBXUpdate-20230509-ia32.cab
|
||||
Source22: http://people.redhat.com/rhughes/dbx/DBXUpdate-20230509-x64.cab
|
||||
Source23: http://people.redhat.com/rhughes/dbx/DBXUpdate-20241101-x64.cab
|
||||
|
||||
# these are numbered high just to keep them wildly away from colliding with
|
||||
# the real package sources, in order to reduce churn.
|
||||
@ -196,7 +196,6 @@ can be flashed using flashrom. It is probably not required on servers.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch201 -p1
|
||||
|
||||
mkdir -p subprojects/fwupd-efi
|
||||
tar xfvs %{SOURCE2} -C subprojects/fwupd-efi --strip-components=1
|
||||
@ -284,7 +283,8 @@ cd -
|
||||
mkdir -p %{buildroot}/%{_datadir}/dbxtool
|
||||
install \
|
||||
%{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} \
|
||||
%{SOURCE16} %{SOURCE17} %{SOURCE18} %{SOURCE19} %{SOURCE20} %{SOURCE21} %{SOURCE22} \
|
||||
%{SOURCE16} %{SOURCE17} %{SOURCE18} %{SOURCE19} %{SOURCE20} %{SOURCE21} \
|
||||
%{SOURCE22} %{SOURCE23} \
|
||||
%{buildroot}/%{_datadir}/dbxtool
|
||||
|
||||
# sign fwupd.efi loader
|
||||
@ -382,6 +382,7 @@ done
|
||||
%{_datadir}/dbxtool/DBXUpdate-20230509-aa64.cab
|
||||
%{_datadir}/dbxtool/DBXUpdate-20230509-ia32.cab
|
||||
%{_datadir}/dbxtool/DBXUpdate-20230509-x64.cab
|
||||
%{_datadir}/dbxtool/DBXUpdate-20241101-x64.cab
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man5/*
|
||||
%{_mandir}/man8/*
|
||||
@ -457,6 +458,10 @@ done
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Mar 18 2025 Richard Hughes <richard@hughsie.com> 1.9.29-1
|
||||
- Rebase to get new hardware support
|
||||
- Resolves: #RHEL-82423
|
||||
|
||||
* Tue Oct 15 2024 Richard Hughes <richard@hughsie.com> 1.9.26-1
|
||||
- Rebase to get hardware support for CERTPX-13842
|
||||
- Resolves: #RHEL-16637
|
||||
|
3
sources
3
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (fwupd-1.9.26.tar.xz) = 04684f0be26c1daec9966e62c7db103cce923bb361657c66111e085e9a388e812250ac18774ef83eac672852489acc2ab21b9d7c94a28a8e5564e8bb7d67c0ba
|
||||
SHA512 (fwupd-1.9.29.tar.xz) = 27a6b687f4956b9b137cb29a23ab735f2e0b8c2260e2db08c5ba08660d1819a8cd2f8f67772c559a95ba6f7e8aeecd080b7666ee26fa740afa76ce93ec2d8eef
|
||||
SHA512 (fwupd-efi-1.4.tar.xz) = c330409861a8c1e332a0d4fd49c54ef2c5bf7cdaca99d14de39b50fb35f0c490e9f7f7a4c9dd48181bd509cd358c43eb23659536aea93408c1fefb47629e4991
|
||||
SHA512 (DBXUpdate-20100307-x64.cab) = f8ad56cf015f4cdc5c305856ff1f7a8589c25a2a671708c61883f427f38eb9b6a7abd3f2c8d79ef9d5076222255e42585917f8705a2a4b13f860bad4e02ec409
|
||||
SHA512 (DBXUpdate-20140413-x64.cab) = 75771876a2309fa8ca083c2e76520173d434229b7cacf1e7636bd9b1bc4f871d745c348b9792bfb65fd9f40ef54c25bb427b1431151e817e7050b7829456731a
|
||||
@ -13,3 +13,4 @@ SHA512 (DBXUpdate-20220812-x64.cab) = 03dde66a31241ccaa562c57bd9b6b824f2a6b5a1d1
|
||||
SHA512 (DBXUpdate-20230509-aa64.cab) = 259f2373d6ab4cd031fe8b993825ba4cf922306afb3da1617d7b4e9d4ac918018b463135f58ace884a2ceec01789f3b2b31aaf63e63501503e4efbcf46ce567b
|
||||
SHA512 (DBXUpdate-20230509-ia32.cab) = e9983039fa5283bf8357c75874842d06ac76a36e90c76406ab864a2b76f557f9649e84be3eb20ab473486cd60a08847ece0ef4015145357969067561338a7977
|
||||
SHA512 (DBXUpdate-20230509-x64.cab) = b2893b431adc3b155335a07e035979a2bf08b7c06975bde7c5561f5e5c1d8ed55f337e7a4782e6ad5c4c50c286cf474a1be356991784c88c23315c467fca30bb
|
||||
SHA512 (DBXUpdate-20241101-x64.cab) = 0a2883908e15c405c2b8b3adf84b3c322f3ddcb9cae8658bbe4ef99a2b575865654339a3b901db7bb2088b7a669a335be04c50134e7e2168871fc397e1a096b6
|
||||
|
Loading…
Reference in New Issue
Block a user