New upstream release
This commit is contained in:
parent
786ec76332
commit
b72cbff275
1
.gitignore
vendored
1
.gitignore
vendored
@ -84,3 +84,4 @@
|
||||
/fwupd-1.6.3.tar.xz
|
||||
/fwupd-1.6.4.tar.xz
|
||||
/fwupd-1.7.0.tar.xz
|
||||
/fwupd-1.7.1.tar.xz
|
||||
|
@ -1,69 +0,0 @@
|
||||
From 478099cf46e577c91c9a932d07e4fd6eb83f14d2 Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Wed, 6 Oct 2021 16:50:24 +0100
|
||||
Subject: [PATCH] Fix build error when sys/io.h is ot available
|
||||
|
||||
---
|
||||
meson.build | 3 +++
|
||||
plugins/flashrom/fu-flashrom-cmos.c | 10 +++++++++-
|
||||
2 files changed, 12 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 547eb64a..7557cd4a 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -314,6 +314,9 @@ endif
|
||||
if cc.has_header('sys/socket.h')
|
||||
conf.set('HAVE_SOCKET_H', '1')
|
||||
endif
|
||||
+if cc.has_header('sys/io.h')
|
||||
+ conf.set('HAVE_IO_H', '1')
|
||||
+endif
|
||||
if cc.has_header('linux/ethtool.h')
|
||||
conf.set('HAVE_ETHTOOL_H', '1')
|
||||
endif
|
||||
diff --git a/plugins/flashrom/fu-flashrom-cmos.c b/plugins/flashrom/fu-flashrom-cmos.c
|
||||
index 490f0240..77f2cc65 100644
|
||||
--- a/plugins/flashrom/fu-flashrom-cmos.c
|
||||
+++ b/plugins/flashrom/fu-flashrom-cmos.c
|
||||
@@ -5,10 +5,13 @@
|
||||
*/
|
||||
#include "config.h"
|
||||
|
||||
+#ifdef HAVE_IO_H
|
||||
#include <sys/io.h>
|
||||
+#endif
|
||||
|
||||
#include "fu-flashrom-cmos.h"
|
||||
|
||||
+#ifdef HAVE_IO_H
|
||||
static gboolean
|
||||
fu_flashrom_cmos_write(guint8 addr, guint8 val)
|
||||
{
|
||||
@@ -29,10 +32,12 @@ fu_flashrom_cmos_write(guint8 addr, guint8 val)
|
||||
/* Check the read value against the written */
|
||||
return (tmp == val);
|
||||
}
|
||||
+#endif
|
||||
|
||||
gboolean
|
||||
fu_flashrom_cmos_reset(GError **error)
|
||||
{
|
||||
+#ifdef HAVE_IO_H
|
||||
/* Call ioperm() to grant us access to ports 0x70 and 0x71 */
|
||||
if (ioperm(RTC_BASE_PORT, 2, TRUE) < 0) {
|
||||
g_set_error_literal(error,
|
||||
@@ -50,6 +55,9 @@ fu_flashrom_cmos_reset(GError **error)
|
||||
}
|
||||
|
||||
/* success */
|
||||
-
|
||||
return TRUE;
|
||||
+#else
|
||||
+ g_set_error_literal(error, G_IO_ERROR, G_IO_ERROR_NOT_SUPPORTED, "no <sys/io.h> support");
|
||||
+ return FALSE;
|
||||
+#endif
|
||||
}
|
||||
--
|
||||
2.32.0
|
||||
|
27
fwupd.spec
27
fwupd.spec
@ -44,15 +44,12 @@
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 1.7.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.7.1
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/fwupd/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
|
||||
# backported from upstream
|
||||
Patch0: 0001-Fix-build-error-when-sys-io.h-is-ot-available.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
||||
@ -377,6 +374,7 @@ done
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_ata.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_bcm57xx.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_ccgx.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_cfu.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_colorhug.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_cros_ec.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_cpu.so
|
||||
@ -482,6 +480,7 @@ done
|
||||
%files tests
|
||||
%if 0%{?enable_tests}
|
||||
%dir %{_datadir}/installed-tests/fwupd
|
||||
%{_datadir}/installed-tests/fwupd/tests/*
|
||||
%{_datadir}/installed-tests/fwupd/fwupd-tests.xml
|
||||
%{_datadir}/installed-tests/fwupd/*.test
|
||||
%{_datadir}/installed-tests/fwupd/*.cab
|
||||
@ -493,6 +492,24 @@ done
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Nov 01 2021 Richard Hughes <richard@hughsie.com> 1.7.1-1
|
||||
- New upstream release
|
||||
- Allow specifying 'fwupdmgr device-test foo --json' for unattended testing
|
||||
- Show changes in HSI attributes when using 'fwupdmgr security'
|
||||
- Show the user a warning if updating may affect full-disk-encryption
|
||||
- Show translated firmware release notes when provided
|
||||
- Support loading remotes from /var/lib/fwupd/remotes.d
|
||||
- Fix a CCGX regression when loading firmware
|
||||
- Fix a potential crash when dumping Parade devices
|
||||
- Fix the CSME CVE detection for new generations
|
||||
- Handle EPERM when running the self tests on systems with IPMI
|
||||
- Mark as SUPPORTED even if on battery power
|
||||
- Only save the HSI attributes to the database if different
|
||||
- Raise the client timeout value from 25 seconds to fix Redfish startup
|
||||
- Redirect the old HSI links to the correct place
|
||||
- Set device time and timezone for logitech bulkcontroller devices
|
||||
- Set the verfmt of the returned device when the daemon device is unset
|
||||
|
||||
* Mon Oct 25 2021 Adrian Reber <adrian@lisas.de> - 1.7.0-2
|
||||
- Rebuilt for protobuf 3.18.1
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fwupd-1.7.0.tar.xz) = 48a52c109a636cee8ddda5cd9e3c9ccece794cf1e24ccc47a4a8ed8fe7c747622bf4aa59d6c54ebcb938ee166f05f9b3fe8b8918fdf9ac90fec400b1c9856ac1
|
||||
SHA512 (fwupd-1.7.1.tar.xz) = c5d2406065c73909d3cdf9815e31de386ef3f3cbeb7c2845eeee8655754bfe4b464d2660780a80835349394aeedb1891fcd0b1eee8db33a318095c81faf84297
|
||||
|
Loading…
Reference in New Issue
Block a user