New upstream release
This commit is contained in:
parent
a962d79a37
commit
b6787c2033
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@
|
||||
/fwupd-0.8.1.tar.xz
|
||||
/fwupd-0.8.2.tar.xz
|
||||
/fwupd-0.9.2.tar.xz
|
||||
/fwupd-0.9.3.tar.xz
|
||||
|
34
fwupd.spec
34
fwupd.spec
@ -1,7 +1,8 @@
|
||||
%global glib2_version 2.45.8
|
||||
%global libappstream_version 0.5.10
|
||||
%global libappstream_version 0.6.13
|
||||
%global libgusb_version 0.2.9
|
||||
%global libsoup_version 2.51.92
|
||||
%global systemd_version 231
|
||||
|
||||
%ifarch x86_64 %{ix86}
|
||||
%global have_smbios 1
|
||||
@ -14,15 +15,12 @@
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 0.9.2
|
||||
Release: 2%{?dist}
|
||||
Version: 0.9.3
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://github.com/hughsie/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
|
||||
# backported from master
|
||||
Patch0: master.patch
|
||||
|
||||
BuildRequires: docbook-utils
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
@ -32,10 +30,9 @@ BuildRequires: libgusb-devel >= %{libgusb_version}
|
||||
BuildRequires: libsoup-devel >= %{libsoup_version}
|
||||
BuildRequires: colord-devel >= 1.0.0
|
||||
BuildRequires: polkit-devel >= 0.103
|
||||
BuildRequires: libgcab1-devel
|
||||
BuildRequires: sqlite-devel
|
||||
BuildRequires: gpgme-devel
|
||||
BuildRequires: systemd
|
||||
BuildRequires: systemd >= %{systemd_version}
|
||||
BuildRequires: libarchive-devel
|
||||
BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: gcab
|
||||
@ -93,11 +90,11 @@ Files for development with libdfu.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .master
|
||||
|
||||
%build
|
||||
|
||||
%meson \
|
||||
-Denable-doc=true \
|
||||
-Denable-man=true \
|
||||
-Denable-tests=false \
|
||||
-Denable-thunderbolt=false \
|
||||
%if 0%{?have_uefi}
|
||||
@ -144,6 +141,10 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
%dir %{_libexecdir}/fwupd
|
||||
%{_libexecdir}/fwupd/fwupd
|
||||
%{_bindir}/fwupdmgr
|
||||
%dir %{_sysconfdir}/fwupd
|
||||
%dir %{_sysconfdir}/fwupd/remotes.d
|
||||
%{_sysconfdir}/fwupd/remotes.d/lvfs.conf
|
||||
%{_sysconfdir}/fwupd/remotes.d/lvfs-testing.conf
|
||||
%{_sysconfdir}/pki/fwupd
|
||||
%{_sysconfdir}/pki/fwupd-metadata
|
||||
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.fwupd.conf
|
||||
@ -206,6 +207,19 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
%{_libdir}/pkgconfig/dfu.pc
|
||||
|
||||
%changelog
|
||||
* Wed Jun 07 2017 Richard Hughes <richard@hughsie.com> 0.9.3-1
|
||||
- New upstream release
|
||||
- Add a 'downgrade' command to fwupdmgr
|
||||
- Add a 'get-releases' command to fwupdmgr
|
||||
- Add support for Microsoft HardwareIDs
|
||||
- Allow downloading metadata from more than just the LVFS
|
||||
- Allow multiple checksums on devices and releases
|
||||
- Correctly open Unifying devices with original factory firmware
|
||||
- Do not expect a Unifying reply when issuing a REBOOT command
|
||||
- Do not re-download firmware that exists in the cache
|
||||
- Fix a problem when testing for a Dell system
|
||||
- Fix flashing new firmware to 8bitdo controllers
|
||||
|
||||
* Tue May 23 2017 Richard Hughes <richard@hughsie.com> 0.9.2-2
|
||||
- Backport several fixes for updating Unifying devices
|
||||
|
||||
|
74
master.patch
74
master.patch
@ -1,74 +0,0 @@
|
||||
diff --git a/plugins/unifying/lu-device-runtime.c b/plugins/unifying/lu-device-runtime.c
|
||||
index 32d0c56..0e1a562 100644
|
||||
--- a/plugins/unifying/lu-device-runtime.c
|
||||
+++ b/plugins/unifying/lu-device-runtime.c
|
||||
@@ -111,6 +111,12 @@ lu_device_runtime_open (LuDevice *device, GError **error)
|
||||
memset (config, 0x00, sizeof (config));
|
||||
for (guint i = 0x01; i < 0x05; i++) {
|
||||
g_autoptr(LuDeviceHidppMsg) msg = lu_device_hidpp_new ();
|
||||
+
|
||||
+ /* workaround a bug in the 12.01 firmware, which fails with
|
||||
+ * INVALID_VALUE when reading MCU1_HW_VERSION */
|
||||
+ if (version_bl_major == 0x01 && i == 0x03)
|
||||
+ continue;
|
||||
+
|
||||
msg->report_id = HIDPP_REPORT_ID_SHORT;
|
||||
msg->device_id = lu_device_get_hidpp_id (device);
|
||||
msg->sub_id = HIDPP_SUBID_GET_REGISTER;
|
||||
@@ -156,7 +162,7 @@ lu_device_runtime_open (LuDevice *device, GError **error)
|
||||
lu_device_add_flag (device, LU_DEVICE_FLAG_CAN_FLASH);
|
||||
|
||||
/* only the bootloader can do the update */
|
||||
- lu_device_set_product (device, "Unifying Reciever");
|
||||
+ lu_device_set_product (device, "Unifying Receiver");
|
||||
|
||||
return TRUE;
|
||||
}
|
||||
diff --git a/plugins/unifying/lu-device.c b/plugins/unifying/lu-device.c
|
||||
index 4fd67a4..4e53633 100644
|
||||
--- a/plugins/unifying/lu-device.c
|
||||
+++ b/plugins/unifying/lu-device.c
|
||||
@@ -288,13 +288,13 @@ lu_device_hidpp_receive (LuDevice *device,
|
||||
}
|
||||
}
|
||||
|
||||
- /* check length */
|
||||
+ /* check long enough, but allow returning oversize packets */
|
||||
lu_device_hidpp_dump (device, "device->host", (guint8 *) msg, read_size);
|
||||
- if (lu_device_hidpp_msg_length (msg) != read_size) {
|
||||
+ if (read_size < lu_device_hidpp_msg_length (msg)) {
|
||||
g_set_error (error,
|
||||
G_IO_ERROR,
|
||||
G_IO_ERROR_FAILED,
|
||||
- "not expected message length, "
|
||||
+ "message length too small, "
|
||||
"got %" G_GSIZE_FORMAT " expected %" G_GSIZE_FORMAT,
|
||||
read_size, lu_device_hidpp_msg_length (msg));
|
||||
return FALSE;
|
||||
@@ -746,7 +746,7 @@ lu_device_open (LuDevice *device, GError **error)
|
||||
/* subclassed */
|
||||
if (klass->open != NULL) {
|
||||
if (!klass->open (device, error)) {
|
||||
- g_usb_device_close (priv->usb_device, NULL);
|
||||
+ lu_device_close (device, NULL);
|
||||
return FALSE;
|
||||
}
|
||||
}
|
||||
@@ -754,7 +754,7 @@ lu_device_open (LuDevice *device, GError **error)
|
||||
|
||||
/* subclassed */
|
||||
if (!lu_device_probe (device, error)) {
|
||||
- g_usb_device_close (priv->usb_device, NULL);
|
||||
+ lu_device_close (device, NULL);
|
||||
return FALSE;
|
||||
}
|
||||
|
||||
@@ -788,7 +788,7 @@ lu_device_poll (LuDevice *device, GError **error)
|
||||
return FALSE;
|
||||
}
|
||||
|
||||
- /* unifying reciever notification */
|
||||
+ /* unifying receiver notification */
|
||||
if (msg->report_id == HIDPP_REPORT_ID_SHORT) {
|
||||
switch (msg->sub_id) {
|
||||
case HIDPP_SUBID_DEVICE_CONNECTION:
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fwupd-0.9.2.tar.xz) = 9cca2e152536e13c0d702e44582d5e7bfdd1d3b0a363dc18769f95477975b785424c3774b960aa3e50e9e1fdcf5330e6ddc5c3e27738460328d49c83145229b9
|
||||
SHA512 (fwupd-0.9.3.tar.xz) = d6b8002f2048c55f0b9ec13a9cc8c8a4158d98c46a6f4a27dd99daf85ffab492128370e4a3f5f9195a9f9495b0e32c0e151bdc84850f6c0117b9c9bb3945a916
|
||||
|
Loading…
Reference in New Issue
Block a user