New upstream release
This commit is contained in:
parent
e79aa43a91
commit
b1d8c97c3a
1
.gitignore
vendored
1
.gitignore
vendored
@ -64,3 +64,4 @@
|
||||
/fwupd-1.4.0.tar.xz
|
||||
/fwupd-1.4.1.tar.xz
|
||||
/fwupd-1.4.2.tar.xz
|
||||
/fwupd-1.4.3.tar.xz
|
||||
|
@ -1,32 +0,0 @@
|
||||
From d7a1eb17bef650f13e7f96430f99294c36a40806 Mon Sep 17 00:00:00 2001
|
||||
From: Vincent Huang <vincent.huang@tw.synaptics.com>
|
||||
Date: Tue, 19 May 2020 13:09:28 +0800
|
||||
Subject: [PATCH] synaptics-prometheus: Force the minor version from 0x02 to
|
||||
0x01 to make sure the devices can be updated back to 0x01.
|
||||
|
||||
---
|
||||
plugins/synaptics-prometheus/fu-synaprom-device.c | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git plugins/synaptics-prometheus/fu-synaprom-device.c plugins/synaptics-prometheus/fu-synaprom-device.c
|
||||
index 5a19203c..299ebde2 100644
|
||||
--- a/plugins/synaptics-prometheus/fu-synaprom-device.c
|
||||
+++ b/plugins/synaptics-prometheus/fu-synaprom-device.c
|
||||
@@ -142,6 +142,14 @@ fu_synaprom_device_set_version (FuSynapromDevice *self,
|
||||
{
|
||||
g_autofree gchar *str = NULL;
|
||||
|
||||
+ /* We decide to skip 10.02.xxxxxx firmware, so we force the minor version from 0x02
|
||||
+ ** to 0x01 to make the devices with 0x02 minor version firmware allow to be updated
|
||||
+ ** back to minor version 0x01. */
|
||||
+ if (vmajor == 0x0a && vminor == 0x02) {
|
||||
+ g_debug ("quirking vminor from %02x to 01", vminor);
|
||||
+ vminor = 0x01;
|
||||
+ }
|
||||
+
|
||||
/* set display version */
|
||||
str = g_strdup_printf ("%02u.%02u.%u", vmajor, vminor, buildnum);
|
||||
fu_device_set_version (FU_DEVICE (self), str);
|
||||
--
|
||||
2.26.2
|
||||
|
14
fwupd.spec
14
fwupd.spec
@ -40,14 +40,12 @@
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 1.4.2
|
||||
Release: 2%{?dist}
|
||||
Version: 1.4.3
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/fwupd/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch1: 0001-synaptics-prometheus-Force-the-minor-version-from-0x.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
||||
@ -405,6 +403,14 @@ mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/fwupd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jun 09 2020 Richard Hughes <richard@hughsie.com> 1.4.3-1
|
||||
- New upstream release
|
||||
- Add support for HP DMC dock devices
|
||||
- Always enforce the metadata signature has a valid timestamp
|
||||
- Capture the dock SKU in metadata
|
||||
- Check the device requirements when returning from GetDetails
|
||||
- Prevent Dell dock updates to occur via synaptics-mst plugin
|
||||
|
||||
* Fri May 22 2020 Richard Hughes <richard@hughsie.com> 1.4.2-2
|
||||
- Backport a patch to fix the synaptics fingerprint reader update.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fwupd-1.4.2.tar.xz) = 9837b24bc23253333767aba07b81cc811fe95182a6699dadab41fb4375d28b0e697e087370778dc96895f1ec003f0c5959ffaa14668f90474eda01b39a10080c
|
||||
SHA512 (fwupd-1.4.3.tar.xz) = 342756c908d341133746810b69811fabe6d6922bdf9eda162ac3191fe54f7e99b82bccfef8df88e7e5e604c86345fe4a6b279ceaf4fdb9e18934beae54a143cb
|
||||
|
Loading…
Reference in New Issue
Block a user