Backport a build fix from master
This commit is contained in:
parent
d999b39a21
commit
a77f9c2881
40
fix.patch
Normal file
40
fix.patch
Normal file
@ -0,0 +1,40 @@
|
||||
diff --git a/meson.build b/meson.build
|
||||
index da72f33f..73420d18 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -77,7 +77,7 @@ warning_flags = [
|
||||
'-Wmissing-prototypes',
|
||||
'-Wnested-externs',
|
||||
'-Wno-cast-function-type',
|
||||
- '-Wno-error=cpp',
|
||||
+ '-Wno-address-of-packed-member', # incompatable with g_autoptr()
|
||||
'-Wno-unknown-pragmas',
|
||||
'-Wno-discarded-qualifiers',
|
||||
'-Wno-missing-field-initializers',
|
||||
diff --git a/plugins/uefi/efi/meson.build b/plugins/uefi/efi/meson.build
|
||||
index dbccda03..5be2ffea 100644
|
||||
--- a/plugins/uefi/efi/meson.build
|
||||
+++ b/plugins/uefi/efi/meson.build
|
||||
@@ -53,7 +53,6 @@ compile_args = ['-Og',
|
||||
'--param=ssp-buffer-size=4',
|
||||
'-fexceptions',
|
||||
'-Wall',
|
||||
- '-Werror',
|
||||
'-Wextra',
|
||||
'-Wvla',
|
||||
'-std=gnu11',
|
||||
@@ -66,10 +65,14 @@ compile_args = ['-Og',
|
||||
'-fno-merge-constants',
|
||||
'-Wsign-compare',
|
||||
'-Wno-missing-field-initializers',
|
||||
+ '-Wno-address-of-packed-member',
|
||||
'-grecord-gcc-switches',
|
||||
'-DDEBUGDIR="@0@"'.format(debugdir),
|
||||
'-isystem', efi_incdir,
|
||||
'-isystem', join_paths(efi_incdir, gnu_efi_path_arch)]
|
||||
+if get_option('werror')
|
||||
+ compile_args += '-Werror'
|
||||
+endif
|
||||
if efi_arch == 'x86_64'
|
||||
compile_args += ['-mno-red-zone',
|
||||
'-mno-sse',
|
@ -31,6 +31,9 @@ License: LGPLv2+
|
||||
URL: https://github.com/hughsie/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
|
||||
# backport from master
|
||||
Patch0: fix.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
||||
@ -120,7 +123,7 @@ BuildArch: noarch
|
||||
Data files for installed tests.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user