Rebase to get hardware support for CERTPX-13842
Resolves: #RHEL-16637 Resolves: #RHEL-61930 Resolves: #RHEL-35373
This commit is contained in:
parent
954a09be72
commit
90bc5c3551
1
.gitignore
vendored
1
.gitignore
vendored
@ -102,3 +102,4 @@
|
|||||||
/fwupd-1.9.11.tar.xz
|
/fwupd-1.9.11.tar.xz
|
||||||
/fwupd-1.9.12.tar.xz
|
/fwupd-1.9.12.tar.xz
|
||||||
/fwupd-1.9.13.tar.xz
|
/fwupd-1.9.13.tar.xz
|
||||||
|
/fwupd-1.9.26.tar.xz
|
||||||
|
38
0001-Revert-trivial-bump-libjcat-and-passim-deps.patch
Normal file
38
0001-Revert-trivial-bump-libjcat-and-passim-deps.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
From 11a6f914ae27953c9070f6e4cd562a326e1cb60c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Richard Hughes <richard@hughsie.com>
|
||||||
|
Date: Tue, 15 Oct 2024 14:27:08 +0100
|
||||||
|
Subject: [PATCH] Revert "trivial: bump libjcat and passim deps"
|
||||||
|
|
||||||
|
This reverts commit 774b87fed0c6addd49cdc65a3ecc24923f7c76ae.
|
||||||
|
|
||||||
|
We can update the subproject, but we can't raise the deps in a stable branch
|
||||||
|
otherwise we make it really hard to build for RHEL and Ubuntu LTS.
|
||||||
|
---
|
||||||
|
meson.build | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index 167e529d1..5047cab72 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -241,7 +241,7 @@ sqlite = dependency('sqlite3', required: get_option('sqlite'))
|
||||||
|
if sqlite.found()
|
||||||
|
conf.set('HAVE_SQLITE', '1')
|
||||||
|
endif
|
||||||
|
-passim = dependency('passim', version: '>= 0.1.5', required: get_option('passim'), fallback: ['passim', 'passim_dep'])
|
||||||
|
+passim = dependency('passim', version: '>= 0.1.2', required: get_option('passim'), fallback: ['passim', 'passim_dep'])
|
||||||
|
if passim.found()
|
||||||
|
conf.set('HAVE_PASSIM', '1')
|
||||||
|
endif
|
||||||
|
@@ -253,7 +253,7 @@ if libarchive.found()
|
||||||
|
endif
|
||||||
|
endif
|
||||||
|
endif
|
||||||
|
-libjcat = dependency('jcat', version: '>= 0.2.0', fallback: ['libjcat', 'libjcat_dep'])
|
||||||
|
+libjcat = dependency('jcat', version: '>= 0.1.4', fallback: ['libjcat', 'libjcat_dep'])
|
||||||
|
libjsonglib = dependency('json-glib-1.0', version: '>= 1.6.0')
|
||||||
|
valgrind = dependency('valgrind', required: false)
|
||||||
|
libcurl = dependency('libcurl', version: '>= 7.62.0', required: get_option('curl'))
|
||||||
|
--
|
||||||
|
2.47.0
|
||||||
|
|
22
fwupd.spec
22
fwupd.spec
@ -48,15 +48,15 @@
|
|||||||
|
|
||||||
Summary: Firmware update daemon
|
Summary: Firmware update daemon
|
||||||
Name: fwupd
|
Name: fwupd
|
||||||
Version: 1.9.13
|
Version: 1.9.26
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/fwupd/fwupd
|
URL: https://github.com/fwupd/fwupd
|
||||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||||
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.4.tar.xz
|
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.4.tar.xz
|
||||||
|
|
||||||
Patch101: 0001-generate_binary-Add-NX-COMPAT-flag-manually-when-gen.patch
|
Patch101: 0001-generate_binary-Add-NX-COMPAT-flag-manually-when-gen.patch
|
||||||
Patch102: 0001-Correctly-migrate-from-v2-to-database-schema-v10.patch
|
Patch201: 0001-Revert-trivial-bump-libjcat-and-passim-deps.patch
|
||||||
|
|
||||||
Source10: http://people.redhat.com/rhughes/dbx/DBXUpdate-20100307-x64.cab
|
Source10: http://people.redhat.com/rhughes/dbx/DBXUpdate-20100307-x64.cab
|
||||||
Source11: http://people.redhat.com/rhughes/dbx/DBXUpdate-20140413-x64.cab
|
Source11: http://people.redhat.com/rhughes/dbx/DBXUpdate-20140413-x64.cab
|
||||||
@ -196,7 +196,7 @@ can be flashed using flashrom. It is probably not required on servers.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch102 -p1
|
%patch201 -p1
|
||||||
|
|
||||||
mkdir -p subprojects/fwupd-efi
|
mkdir -p subprojects/fwupd-efi
|
||||||
tar xfvs %{SOURCE2} -C subprojects/fwupd-efi --strip-components=1
|
tar xfvs %{SOURCE2} -C subprojects/fwupd-efi --strip-components=1
|
||||||
@ -318,7 +318,6 @@ done
|
|||||||
|
|
||||||
%postun
|
%postun
|
||||||
%systemd_postun_with_restart fwupd.service fwupd-refresh.timer
|
%systemd_postun_with_restart fwupd.service fwupd-refresh.timer
|
||||||
%systemd_postun_with_restart pesign.service
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%doc README.md
|
%doc README.md
|
||||||
@ -326,7 +325,7 @@ done
|
|||||||
%config(noreplace)%{_sysconfdir}/fwupd/fwupd.conf
|
%config(noreplace)%{_sysconfdir}/fwupd/fwupd.conf
|
||||||
%dir %{_libexecdir}/fwupd
|
%dir %{_libexecdir}/fwupd
|
||||||
%{_libexecdir}/fwupd/fwupd
|
%{_libexecdir}/fwupd/fwupd
|
||||||
%ifarch i686 x86_64
|
%ifarch x86_64
|
||||||
%{_libexecdir}/fwupd/fwupd-detect-cet
|
%{_libexecdir}/fwupd/fwupd-detect-cet
|
||||||
%endif
|
%endif
|
||||||
%{_libexecdir}/fwupd/fwupdoffline
|
%{_libexecdir}/fwupd/fwupdoffline
|
||||||
@ -358,7 +357,12 @@ done
|
|||||||
%{_datadir}/bash-completion/completions/fwupdmgr
|
%{_datadir}/bash-completion/completions/fwupdmgr
|
||||||
%{_datadir}/bash-completion/completions/fwupdtool
|
%{_datadir}/bash-completion/completions/fwupdtool
|
||||||
%{_datadir}/fish/vendor_completions.d/fwupdmgr.fish
|
%{_datadir}/fish/vendor_completions.d/fwupdmgr.fish
|
||||||
|
%dir %{_datadir}/fwupd
|
||||||
|
%dir %{_datadir}/fwupd/metainfo
|
||||||
%{_datadir}/fwupd/metainfo/org.freedesktop.fwupd*.metainfo.xml
|
%{_datadir}/fwupd/metainfo/org.freedesktop.fwupd*.metainfo.xml
|
||||||
|
%dir %{_datadir}/fwupd/remotes.d
|
||||||
|
%dir %{_datadir}/fwupd/remotes.d/vendor
|
||||||
|
%dir %{_datadir}/fwupd/remotes.d/vendor/firmware
|
||||||
%{_datadir}/fwupd/remotes.d/vendor/firmware/README.md
|
%{_datadir}/fwupd/remotes.d/vendor/firmware/README.md
|
||||||
%{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
|
%{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
|
||||||
%{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
|
%{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
|
||||||
@ -453,6 +457,12 @@ done
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 15 2024 Richard Hughes <richard@hughsie.com> 1.9.26-1
|
||||||
|
- Rebase to get hardware support for CERTPX-13842
|
||||||
|
- Resolves: #RHEL-16637
|
||||||
|
- Resolves: #RHEL-35373
|
||||||
|
- Resolves: #RHEL-61930
|
||||||
|
|
||||||
* Mon Feb 19 2024 Richard Hughes <richard@hughsie.com> 1.9.13-2
|
* Mon Feb 19 2024 Richard Hughes <richard@hughsie.com> 1.9.13-2
|
||||||
- Fix upgrade from fwupd < v1.9.5
|
- Fix upgrade from fwupd < v1.9.5
|
||||||
- Resolves: #RHEL-15328
|
- Resolves: #RHEL-15328
|
||||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
|||||||
SHA512 (fwupd-1.9.13.tar.xz) = 240e057e33e861a84638866a43a7cae33bc3f12d48d5cf2ad3f8bdfb92824057472d1981ac2145d2024f31727f8413c555ce907dea28f4f7232e4604e24703ab
|
SHA512 (fwupd-1.9.26.tar.xz) = 04684f0be26c1daec9966e62c7db103cce923bb361657c66111e085e9a388e812250ac18774ef83eac672852489acc2ab21b9d7c94a28a8e5564e8bb7d67c0ba
|
||||||
SHA512 (fwupd-efi-1.4.tar.xz) = c330409861a8c1e332a0d4fd49c54ef2c5bf7cdaca99d14de39b50fb35f0c490e9f7f7a4c9dd48181bd509cd358c43eb23659536aea93408c1fefb47629e4991
|
SHA512 (fwupd-efi-1.4.tar.xz) = c330409861a8c1e332a0d4fd49c54ef2c5bf7cdaca99d14de39b50fb35f0c490e9f7f7a4c9dd48181bd509cd358c43eb23659536aea93408c1fefb47629e4991
|
||||||
SHA512 (DBXUpdate-20100307-x64.cab) = f8ad56cf015f4cdc5c305856ff1f7a8589c25a2a671708c61883f427f38eb9b6a7abd3f2c8d79ef9d5076222255e42585917f8705a2a4b13f860bad4e02ec409
|
SHA512 (DBXUpdate-20100307-x64.cab) = f8ad56cf015f4cdc5c305856ff1f7a8589c25a2a671708c61883f427f38eb9b6a7abd3f2c8d79ef9d5076222255e42585917f8705a2a4b13f860bad4e02ec409
|
||||||
SHA512 (DBXUpdate-20140413-x64.cab) = 75771876a2309fa8ca083c2e76520173d434229b7cacf1e7636bd9b1bc4f871d745c348b9792bfb65fd9f40ef54c25bb427b1431151e817e7050b7829456731a
|
SHA512 (DBXUpdate-20140413-x64.cab) = 75771876a2309fa8ca083c2e76520173d434229b7cacf1e7636bd9b1bc4f871d745c348b9792bfb65fd9f40ef54c25bb427b1431151e817e7050b7829456731a
|
||||||
|
Loading…
Reference in New Issue
Block a user