New upstream release

This commit is contained in:
Richard Hughes 2022-12-07 18:49:03 +00:00
parent de12c4dc1d
commit 85024a8d14
3 changed files with 15 additions and 86 deletions

View File

@ -1,40 +0,0 @@
From 73a63b89a051dda3c149b16ffc0f4759e1611715 Mon Sep 17 00:00:00 2001
From: Richard Hughes <richard@hughsie.com>
Date: Wed, 9 Nov 2022 15:51:27 +0000
Subject: [PATCH] trivial: Fix lvfs-testing remote file
---
data/remotes.d/meson.build | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)
diff --git a/data/remotes.d/meson.build b/data/remotes.d/meson.build
index 4ef0266f0..c20a1a05e 100644
--- a/data/remotes.d/meson.build
+++ b/data/remotes.d/meson.build
@@ -1,9 +1,4 @@
if build_standalone and get_option('lvfs') != 'false'
- install_data([
- 'lvfs-testing.conf',
- ],
- install_dir: join_paths(sysconfdir, 'fwupd', 'remotes.d')
- )
con3 = configuration_data()
if get_option('lvfs') == 'disabled'
con3.set('enabled', 'false')
@@ -22,6 +17,13 @@ if build_standalone and get_option('lvfs') != 'false'
install: true,
install_dir: join_paths(sysconfdir, 'fwupd', 'remotes.d'),
)
+ configure_file(
+ input: 'lvfs-testing.conf',
+ output: 'lvfs-testing.conf',
+ configuration: con3,
+ install: true,
+ install_dir: join_paths(sysconfdir, 'fwupd', 'remotes.d'),
+ )
i18n.merge_file(
input: 'lvfs.metainfo.xml',
output: 'org.freedesktop.fwupd.remotes.lvfs.metainfo.xml',
--
2.37.3

View File

@ -1,40 +0,0 @@
From 1a31c35732db748af7af8d7d123d148582376251 Mon Sep 17 00:00:00 2001
From: Richard Hughes <richard@hughsie.com>
Date: Wed, 9 Nov 2022 15:28:06 +0000
Subject: [PATCH] trivial: Fix the tests on s390x
---
plugins/synaptics-mst/fu-self-test.c | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/plugins/synaptics-mst/fu-self-test.c b/plugins/synaptics-mst/fu-self-test.c
index ffdaa7a5b..29a05e9c5 100644
--- a/plugins/synaptics-mst/fu-self-test.c
+++ b/plugins/synaptics-mst/fu-self-test.c
@@ -81,6 +81,11 @@ fu_plugin_synaptics_mst_none_func(void)
g_ptr_array_new_with_free_func((GDestroyNotify)g_object_unref);
g_autofree gchar *filename = NULL;
+#if defined(__s390x__)
+ g_test_skip("Skipping HWID test on s390x due missing HwIDs");
+ return;
+#endif
+
ret = fu_context_load_quirks(ctx, FU_QUIRKS_LOAD_FLAG_NO_CACHE, &error);
g_assert_no_error(error);
g_assert_true(ret);
@@ -124,6 +129,11 @@ fu_plugin_synaptics_mst_tb16_func(void)
g_ptr_array_new_with_free_func((GDestroyNotify)g_object_unref);
g_autofree gchar *filename = NULL;
+#if defined(__s390x__)
+ g_test_skip("Skipping HWID test on s390x due missing HwIDs");
+ return;
+#endif
+
ret = fu_context_load_quirks(ctx, FU_QUIRKS_LOAD_FLAG_NO_CACHE, &error);
g_assert_no_error(error);
g_assert_true(ret);
--
2.37.3

View File

@ -48,15 +48,12 @@
Summary: Firmware update daemon Summary: Firmware update daemon
Name: fwupd Name: fwupd
Version: 1.8.7 Version: 1.8.8
Release: 3%{?dist} Release: 1%{?dist}
License: LGPLv2+ License: LGPLv2+
URL: https://github.com/fwupd/fwupd URL: https://github.com/fwupd/fwupd
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
Patch1: 0001-trivial-Fix-the-tests-on-s390x.patch
Patch2: 0001-trivial-Fix-lvfs-testing-remote-file.patch
BuildRequires: gettext BuildRequires: gettext
BuildRequires: glib2-devel >= %{glib2_version} BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: libxmlb-devel >= %{libxmlb_version} BuildRequires: libxmlb-devel >= %{libxmlb_version}
@ -307,7 +304,7 @@ done
%{_bindir}/fwupdagent %{_bindir}/fwupdagent
%dir %{_sysconfdir}/fwupd %dir %{_sysconfdir}/fwupd
%dir %{_sysconfdir}/fwupd/bios-settings.d %dir %{_sysconfdir}/fwupd/bios-settings.d
%config%(noreplace)%{_sysconfdir}/fwupd/bios-settings.d/README.md %{_sysconfdir}/fwupd/bios-settings.d/README.md
%dir %{_sysconfdir}/fwupd/remotes.d %dir %{_sysconfdir}/fwupd/remotes.d
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs.conf %config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs.conf
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs-testing.conf %config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs-testing.conf
@ -411,6 +408,18 @@ done
%endif %endif
%changelog %changelog
* Wed Dec 07 2022 Richard Hughes <richard@hughsie.com> 1.8.8-1
- New upstream release
- Add BIOS rollback protection support for Dell and Lenovo systems
- Ensure the device name is set for Intel USB4 devices
- Fix a critical DFU CSR warning when deploying firmware
- Fix a Synaptics RMI issue when updating non-secure devices
- Generate OVAL rules for openSCAP evaluation
- Match more device properties when using GetDetails
- Show the signed reports from QA teams in client tools
- Use the correct AppStream ID for the Key Manifest failure
- Wait for the Intel GPU to come back after updating
* Tue Nov 29 2022 Richard Hughes <richard@hughsie.com> 1.8.7-3 * Tue Nov 29 2022 Richard Hughes <richard@hughsie.com> 1.8.7-3
- Disable the libsmbios requirement as it is now unmaintained in Fedora. - Disable the libsmbios requirement as it is now unmaintained in Fedora.