New upstream release
This commit is contained in:
parent
e62a509b17
commit
81ced04732
1
.gitignore
vendored
1
.gitignore
vendored
@ -35,3 +35,4 @@
|
||||
/fwupd-1.0.3.tar.xz
|
||||
/fwupd-1.0.4.tar.xz
|
||||
/fwupd-1.0.5.tar.xz
|
||||
/fwupd-1.0.6.tar.xz
|
||||
|
@ -1,43 +0,0 @@
|
||||
From 4ee0836ff3f3c5ee14965da250bc549abcbcc95c Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Wed, 21 Feb 2018 19:01:57 +0000
|
||||
Subject: [PATCH] Use a CNAME to redirect to the correct CDN for metadata
|
||||
|
||||
The current CDN (~$100/month) is kindly sponsored by Amazon, but that won't
|
||||
last forever. In the future we can switch to a 'dumb' provider like BunnyCDN
|
||||
for 1/10th of the cost.
|
||||
|
||||
Use a CNAME we control to make switching CDN providers easy in the future.
|
||||
---
|
||||
data/remotes.d/lvfs-testing.conf | 2 +-
|
||||
data/remotes.d/lvfs.conf | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/data/remotes.d/lvfs-testing.conf b/data/remotes.d/lvfs-testing.conf
|
||||
index 75da08f1..41d9ffff 100644
|
||||
--- a/data/remotes.d/lvfs-testing.conf
|
||||
+++ b/data/remotes.d/lvfs-testing.conf
|
||||
@@ -4,7 +4,7 @@
|
||||
Enabled=false
|
||||
Title=Linux Vendor Firmware Service (testing)
|
||||
Keyring=gpg
|
||||
-MetadataURI=https://s3.amazonaws.com/lvfsbucket/downloads/firmware-testing.xml.gz
|
||||
+MetadataURI=https://cdn.fwupd.org/downloads/firmware-testing.xml.gz
|
||||
ReportURI=https://fwupd.org/lvfs/firmware/report
|
||||
Username=
|
||||
Password=
|
||||
diff --git a/data/remotes.d/lvfs.conf b/data/remotes.d/lvfs.conf
|
||||
index 51d0f55e..4e971be6 100644
|
||||
--- a/data/remotes.d/lvfs.conf
|
||||
+++ b/data/remotes.d/lvfs.conf
|
||||
@@ -4,6 +4,6 @@
|
||||
Enabled=true
|
||||
Title=Linux Vendor Firmware Service
|
||||
Keyring=gpg
|
||||
-MetadataURI=https://s3.amazonaws.com/lvfsbucket/downloads/firmware.xml.gz
|
||||
+MetadataURI=https://cdn.fwupd.org/downloads/firmware.xml.gz
|
||||
ReportURI=https://fwupd.org/lvfs/firmware/report
|
||||
OrderBefore=fwupd
|
||||
--
|
||||
2.14.3
|
||||
|
29
fwupd.spec
29
fwupd.spec
@ -19,20 +19,14 @@
|
||||
%global have_dell 1
|
||||
%endif
|
||||
|
||||
# -Wl,-z,defs is broken
|
||||
%undefine _strict_symbol_defs_build
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 1.0.5
|
||||
Release: 2%{?dist}
|
||||
Version: 1.0.6
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
URL: https://github.com/hughsie/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
|
||||
# backport from master
|
||||
Patch0: 0001-Use-a-CNAME-to-redirect-to-the-correct-CDN-for-metad.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: libappstream-glib-devel >= %{libappstream_version}
|
||||
@ -57,6 +51,7 @@ BuildRequires: gnutls-utils
|
||||
BuildRequires: meson
|
||||
BuildRequires: help2man
|
||||
BuildRequires: json-glib-devel >= %{json_glib_version}
|
||||
BuildRequires: vala
|
||||
|
||||
%if 0%{?have_uefi}
|
||||
BuildRequires: python3 python3-cairo python3-gobject python3-pillow
|
||||
@ -124,7 +119,6 @@ Data files for installed tests.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .no-cdn
|
||||
|
||||
%build
|
||||
|
||||
@ -187,6 +181,7 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
%doc README.md AUTHORS NEWS
|
||||
%license COPYING
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/daemon.conf
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/uefi.conf
|
||||
%dir %{_libexecdir}/fwupd
|
||||
%{_libexecdir}/fwupd/fwupd
|
||||
%{_bindir}/dfu-tool
|
||||
@ -200,6 +195,7 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
%config(noreplace)%{_sysconfdir}/pki/fwupd
|
||||
%{_sysconfdir}/pki/fwupd-metadata
|
||||
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.fwupd.conf
|
||||
%{_datadir}/bash-completion/completions/fwupdmgr
|
||||
%{_datadir}/fwupd/remotes.d/fwupd/metadata.xml
|
||||
%{_datadir}/fwupd/remotes.d/vendor/firmware/README.md
|
||||
%{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
|
||||
@ -231,7 +227,6 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_dfu.so
|
||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_ebitdo.so
|
||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_nitrokey.so
|
||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_raspberrypi.so
|
||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_steelseries.so
|
||||
%if 0%{?have_dell}
|
||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_synapticsmst.so
|
||||
@ -252,6 +247,7 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
%files devel
|
||||
%{_datadir}/gir-1.0/Fwupd-2.0.gir
|
||||
%{_datadir}/gtk-doc/html/libfwupd
|
||||
%{_datadir}/vala/vapi
|
||||
%{_includedir}/fwupd-1
|
||||
%{_libdir}/libfwupd*.so
|
||||
%{_libdir}/pkgconfig/fwupd.pc
|
||||
@ -271,6 +267,19 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||
%{_datadir}/installed-tests/fwupd/*.py*
|
||||
|
||||
%changelog
|
||||
* Mon Mar 12 2018 Richard Hughes <richard@hughsie.com> 1.0.6-1
|
||||
- New upstream release
|
||||
- Add bash completion for fwupdmgr
|
||||
- Add support for newest Thunderbolt chips
|
||||
- Allow devices to use the runtime version when in bootloader mode
|
||||
- Allow overriding ESP mount point via conf file
|
||||
- Correct handling of unknown Thunderbolt devices
|
||||
- Correctly detect new remotes that are manually copied
|
||||
- Delete any old fwupdate capsules and efivars when launching fwupd
|
||||
- Fix a crash related to when passing device to downgrade in CLI
|
||||
- Fix Unifying signature writing and parsing for Texas bootloader
|
||||
- Generate Vala bindings
|
||||
|
||||
* Fri Feb 23 2018 Richard Hughes <richard@hughsie.com> 1.0.5-2
|
||||
- Use the new CDN for metadata.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fwupd-1.0.5.tar.xz) = 38cd5fe28096ec10f132f29a52ded8268d175aad752ee2706f9dcfdfa57d3714f728119ad06ff5b1f4b11aeed44cfc21b74d8dd736632a75252056214be5eba8
|
||||
SHA512 (fwupd-1.0.6.tar.xz) = 5188f09ab0edcc9f1e2b6087db86148ac59e950a0ec70c327930890e3dc2ea05474f75de82b707f650412332d25104fe28f85ba144dc51688b7e99e1d12e08b4
|
||||
|
Loading…
Reference in New Issue
Block a user