Merge branch 'c9-beta' into a9-beta
This commit is contained in:
commit
75e2dbe50c
@ -8,5 +8,12 @@ cd2bbe591438fe893b4042dc03d30659c1e31756 SOURCES/DBXUpdate-20210429-x64.cab
|
||||
d3ae610f5b6e602feded54eae8d67ddb7c60e64f SOURCES/DBXUpdate-20220812-aa64.cab
|
||||
0ac8508ef7a86959e6ab03deec256b19df29677f SOURCES/DBXUpdate-20220812-ia32.cab
|
||||
60f9aa664cb7588e33ce56d621dafa9b5a71e072 SOURCES/DBXUpdate-20220812-x64.cab
|
||||
5e77389b263dd463de85db965d478f7182a9ea0a SOURCES/fwupd-1.8.10.tar.xz
|
||||
46a42362cd34c0d103cf534ca431508d24715e51 SOURCES/DBXUpdate-20230509-aa64.cab
|
||||
23d9544ef0f9b39a76d258f6d4a4a54d8f7592b2 SOURCES/DBXUpdate-20230509-ia32.cab
|
||||
bc6a604b29918d67d5fef745ad4375ca3d43d05e SOURCES/DBXUpdate-20230509-x64.cab
|
||||
a8c8f0cc046ecff12e425484bc5ec1eb7fe49e90 SOURCES/fwupd-1.9.13.tar.xz
|
||||
147b36f75fca288fd01d9ed4150866344d57df27 SOURCES/fwupd-efi-1.4.tar.xz
|
||||
4a07b56e28741884b86da6ac91f8f9929541a1e4 SOURCES/redhatsecureboot301.cer
|
||||
33e260486f5c12e47b72b90dfb779ca892f56c45 SOURCES/redhatsecureboot503.cer
|
||||
cf9230e69000076727e5b784ec871d22716dc5da SOURCES/redhatsecurebootca3.cer
|
||||
e6f506462069aa17d2e8610503635c20f3a995c3 SOURCES/redhatsecurebootca5.cer
|
||||
|
9
.gitignore
vendored
9
.gitignore
vendored
@ -8,5 +8,12 @@ SOURCES/DBXUpdate-20210429-x64.cab
|
||||
SOURCES/DBXUpdate-20220812-aa64.cab
|
||||
SOURCES/DBXUpdate-20220812-ia32.cab
|
||||
SOURCES/DBXUpdate-20220812-x64.cab
|
||||
SOURCES/fwupd-1.8.10.tar.xz
|
||||
SOURCES/DBXUpdate-20230509-aa64.cab
|
||||
SOURCES/DBXUpdate-20230509-ia32.cab
|
||||
SOURCES/DBXUpdate-20230509-x64.cab
|
||||
SOURCES/fwupd-1.9.13.tar.xz
|
||||
SOURCES/fwupd-efi-1.4.tar.xz
|
||||
SOURCES/redhatsecureboot301.cer
|
||||
SOURCES/redhatsecureboot503.cer
|
||||
SOURCES/redhatsecurebootca3.cer
|
||||
SOURCES/redhatsecurebootca5.cer
|
||||
|
@ -0,0 +1,47 @@
|
||||
From 6fc21ec8364babc2edc57d6a39ee44c1e72cc6b2 Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Sun, 18 Feb 2024 10:23:03 +0000
|
||||
Subject: [PATCH] Correctly migrate from v2 to database schema v10
|
||||
|
||||
Artificially bump the schema version to v11 to ensure the migration is done.
|
||||
|
||||
diff --git a/src/fu-history.c b/src/fu-history.c
|
||||
index 21a4fd3e8..3be03c3a7 100644
|
||||
--- a/src/fu-history.c
|
||||
+++ b/src/fu-history.c
|
||||
@@ -21,7 +21,20 @@
|
||||
#include "fu-history.h"
|
||||
#include "fu-security-attr-common.h"
|
||||
|
||||
-#define FU_HISTORY_CURRENT_SCHEMA_VERSION 10
|
||||
+/*
|
||||
+ * v1 legacy schema
|
||||
+ * v2 initial schema
|
||||
+ * v3 add checksum_device to history
|
||||
+ * v4 add protocol to history
|
||||
+ * v5 create table approved_firmware
|
||||
+ * v6 create table blocked_firmware
|
||||
+ * v7 create table hsi_history
|
||||
+ * v8 add release_id to history
|
||||
+ * v9 add appstream_id to history
|
||||
+ * v10 add version_format to history
|
||||
+ * v11 no changes, bumped due to bungled migration to v10
|
||||
+ */
|
||||
+#define FU_HISTORY_CURRENT_SCHEMA_VERSION 11
|
||||
|
||||
static void
|
||||
fu_history_finalize(GObject *object);
|
||||
@@ -466,11 +479,12 @@ fu_history_create_or_migrate(FuHistory *self, guint schema_ver, GError **error)
|
||||
case 8:
|
||||
if (!fu_history_migrate_database_v8(self, error))
|
||||
return FALSE;
|
||||
- break;
|
||||
/* fall through */
|
||||
case 9:
|
||||
+ case 10:
|
||||
if (!fu_history_migrate_database_v9(self, error))
|
||||
return FALSE;
|
||||
+ /* no longer fall through */
|
||||
break;
|
||||
default:
|
||||
/* this is probably okay, but return an error if we ever delete
|
@ -1,110 +0,0 @@
|
||||
From 90e5a58736645cdd37bf4c63f9a4056951dfb3f2 Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Tue, 24 Jan 2023 09:52:17 +0000
|
||||
Subject: [PATCH] Do not make any of the HWIDs setup failures fatal
|
||||
|
||||
It's perfectly okay to have no HWIDs defined.
|
||||
|
||||
Should help with https://github.com/fwupd/fwupd/issues/5402
|
||||
---
|
||||
libfwupdplugin/fu-context.c | 73 +++++++++++--------------------------
|
||||
1 file changed, 21 insertions(+), 52 deletions(-)
|
||||
|
||||
diff --git a/libfwupdplugin/fu-context.c b/libfwupdplugin/fu-context.c
|
||||
index 08618b435..11b4b1b38 100644
|
||||
--- a/libfwupdplugin/fu-context.c
|
||||
+++ b/libfwupdplugin/fu-context.c
|
||||
@@ -767,6 +767,8 @@ fu_context_security_changed(FuContext *self)
|
||||
g_signal_emit(self, signals[SIGNAL_SECURITY_CHANGED], 0);
|
||||
}
|
||||
|
||||
+typedef gboolean (*FuContextHwidsSetupFunc)(FuContext *self, FuHwids *hwids, GError **error);
|
||||
+
|
||||
/**
|
||||
* fu_context_load_hwinfo:
|
||||
* @self: a #FuContext
|
||||
@@ -786,62 +788,29 @@ fu_context_load_hwinfo(FuContext *self, FuContextHwidFlags flags, GError **error
|
||||
GPtrArray *guids;
|
||||
g_autoptr(GError) error_hwids = NULL;
|
||||
g_autoptr(GError) error_bios_settings = NULL;
|
||||
+ struct {
|
||||
+ const gchar *name;
|
||||
+ FuContextHwidFlags flag;
|
||||
+ FuContextHwidsSetupFunc func;
|
||||
+ } hwids_setup_map[] = {{"config", FU_CONTEXT_HWID_FLAG_LOAD_CONFIG, fu_hwids_config_setup},
|
||||
+ {"smbios", FU_CONTEXT_HWID_FLAG_LOAD_SMBIOS, fu_hwids_smbios_setup},
|
||||
+ {"fdt", FU_CONTEXT_HWID_FLAG_LOAD_FDT, fu_hwids_fdt_setup},
|
||||
+ {"kenv", FU_CONTEXT_HWID_FLAG_LOAD_KENV, fu_hwids_kenv_setup},
|
||||
+ {"dmi", FU_CONTEXT_HWID_FLAG_LOAD_DMI, fu_hwids_dmi_setup},
|
||||
+ {NULL, FU_CONTEXT_HWID_FLAG_NONE, NULL}};
|
||||
|
||||
g_return_val_if_fail(FU_IS_CONTEXT(self), FALSE);
|
||||
g_return_val_if_fail(error == NULL || *error == NULL, FALSE);
|
||||
|
||||
- if ((flags & FU_CONTEXT_HWID_FLAG_LOAD_CONFIG) > 0) {
|
||||
- g_autoptr(GError) error_local = NULL;
|
||||
- if (!fu_hwids_config_setup(self, priv->hwids, &error_local)) {
|
||||
- if (!g_error_matches(error_local, FWUPD_ERROR, FWUPD_ERROR_NOT_SUPPORTED)) {
|
||||
- g_propagate_prefixed_error(error,
|
||||
- g_steal_pointer(&error_local),
|
||||
- "Failed to load HWIDs config: ");
|
||||
- return FALSE;
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
- if ((flags & FU_CONTEXT_HWID_FLAG_LOAD_DMI) > 0) {
|
||||
- g_autoptr(GError) error_local = NULL;
|
||||
- if (!fu_hwids_dmi_setup(self, priv->hwids, &error_local)) {
|
||||
- if (!g_error_matches(error_local, FWUPD_ERROR, FWUPD_ERROR_NOT_SUPPORTED)) {
|
||||
- g_propagate_prefixed_error(error,
|
||||
- g_steal_pointer(&error_local),
|
||||
- "Failed to load HWIDs DMI: ");
|
||||
- return FALSE;
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
- if ((flags & FU_CONTEXT_HWID_FLAG_LOAD_FDT) > 0) {
|
||||
- g_autoptr(GError) error_local = NULL;
|
||||
- if (!fu_hwids_fdt_setup(self, priv->hwids, &error_local)) {
|
||||
- if (!g_error_matches(error_local, FWUPD_ERROR, FWUPD_ERROR_NOT_SUPPORTED)) {
|
||||
- g_propagate_prefixed_error(error,
|
||||
- g_steal_pointer(&error_local),
|
||||
- "Failed to load HWIDs FDT: ");
|
||||
- return FALSE;
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
- if ((flags & FU_CONTEXT_HWID_FLAG_LOAD_KENV) > 0) {
|
||||
- g_autoptr(GError) error_local = NULL;
|
||||
- if (!fu_hwids_kenv_setup(self, priv->hwids, &error_local)) {
|
||||
- if (!g_error_matches(error_local, FWUPD_ERROR, FWUPD_ERROR_NOT_SUPPORTED)) {
|
||||
- g_propagate_prefixed_error(error,
|
||||
- g_steal_pointer(&error_local),
|
||||
- "Failed to load HWIDs kenv: ");
|
||||
- return FALSE;
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
- if ((flags & FU_CONTEXT_HWID_FLAG_LOAD_SMBIOS) > 0) {
|
||||
- g_autoptr(GError) error_local = NULL;
|
||||
- if (!fu_hwids_smbios_setup(self, priv->hwids, &error_local)) {
|
||||
- if (!g_error_matches(error_local, FWUPD_ERROR, FWUPD_ERROR_NOT_SUPPORTED)) {
|
||||
- g_propagate_prefixed_error(error,
|
||||
- g_steal_pointer(&error_local),
|
||||
- "Failed to load SMBIOS: ");
|
||||
- return FALSE;
|
||||
+ /* run all the HWID setup funcs */
|
||||
+ for (guint i = 0; hwids_setup_map[i].name != NULL; i++) {
|
||||
+ if ((flags & hwids_setup_map[i].flag) > 0) {
|
||||
+ g_autoptr(GError) error_local = NULL;
|
||||
+ if (!hwids_setup_map[i].func(self, priv->hwids, &error_local)) {
|
||||
+ g_debug("failed to load %s: %s",
|
||||
+ hwids_setup_map[i].name,
|
||||
+ error_local->message);
|
||||
+ break;
|
||||
}
|
||||
}
|
||||
}
|
||||
--
|
||||
2.39.1
|
||||
|
@ -1,60 +0,0 @@
|
||||
From 19db23f9b8a64597564ce1b474eb6c384a57125f Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Wed, 2 Nov 2022 09:31:53 +0000
|
||||
Subject: [PATCH] Only include the 'attribute not exported' warning on debug
|
||||
builds
|
||||
|
||||
End users are not really capable of fixing the root issue, and people seem
|
||||
overly worried that something bad has gone wrong.
|
||||
|
||||
Fixes https://github.com/fwupd/fwupd/issues/5077
|
||||
---
|
||||
libfwupdplugin/fu-bios-settings.c | 2 +-
|
||||
libfwupdplugin/fu-self-test.c | 2 ++
|
||||
plugins/lenovo-thinklmi/fu-self-test.c | 2 ++
|
||||
3 files changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libfwupdplugin/fu-bios-settings.c b/libfwupdplugin/fu-bios-settings.c
|
||||
index 6151c8289..8ea1269d7 100644
|
||||
--- a/libfwupdplugin/fu-bios-settings.c
|
||||
+++ b/libfwupdplugin/fu-bios-settings.c
|
||||
@@ -276,7 +276,7 @@ fu_bios_setting_set_type(FuBiosSettings *self, FwupdBiosSetting *attr, GError **
|
||||
|
||||
/* lenovo thinklmi seems to be missing it even though it's mandatory :/ */
|
||||
if (!fu_bios_setting_get_key(attr, "type", &data, &error_key)) {
|
||||
-#if GLIB_CHECK_VERSION(2, 64, 0)
|
||||
+#if GLIB_CHECK_VERSION(2, 64, 0) && !defined(SUPPORTED_BUILD)
|
||||
g_warning_once("KERNEL BUG: 'type' attribute not exported: (%s)",
|
||||
error_key->message);
|
||||
#else
|
||||
diff --git a/libfwupdplugin/fu-self-test.c b/libfwupdplugin/fu-self-test.c
|
||||
index c105fa271..c670b3a80 100644
|
||||
--- a/libfwupdplugin/fu-self-test.c
|
||||
+++ b/libfwupdplugin/fu-self-test.c
|
||||
@@ -3117,7 +3117,9 @@ fu_bios_settings_load_func(void)
|
||||
test_dir = g_test_build_filename(G_TEST_DIST, "tests", "bios-attrs", "lenovo-p620", NULL);
|
||||
(void)g_setenv("FWUPD_SYSFSFWATTRIBDIR", test_dir, TRUE);
|
||||
|
||||
+#if GLIB_CHECK_VERSION(2, 64, 0) && !defined(SUPPORTED_BUILD)
|
||||
g_test_expect_message("FuBiosSettings", G_LOG_LEVEL_WARNING, "*BUG*");
|
||||
+#endif
|
||||
ret = fu_context_reload_bios_settings(ctx, &error);
|
||||
g_assert_no_error(error);
|
||||
g_assert_true(ret);
|
||||
diff --git a/plugins/lenovo-thinklmi/fu-self-test.c b/plugins/lenovo-thinklmi/fu-self-test.c
|
||||
index 4777a2ae1..9e20a8cf5 100644
|
||||
--- a/plugins/lenovo-thinklmi/fu-self-test.c
|
||||
+++ b/plugins/lenovo-thinklmi/fu-self-test.c
|
||||
@@ -39,7 +39,9 @@ fu_test_self_init(FuTest *self, GError **error_global)
|
||||
g_autoptr(FuProgress) progress = fu_progress_new(G_STRLOC);
|
||||
g_autoptr(GError) error = NULL;
|
||||
|
||||
+#if GLIB_CHECK_VERSION(2, 64, 0) && !defined(SUPPORTED_BUILD)
|
||||
g_test_expect_message("FuBiosSettings", G_LOG_LEVEL_WARNING, "*KERNEL*BUG*");
|
||||
+#endif
|
||||
|
||||
ret = fu_context_load_quirks(ctx,
|
||||
FU_QUIRKS_LOAD_FLAG_NO_CACHE | FU_QUIRKS_LOAD_FLAG_NO_VERIFY,
|
||||
--
|
||||
2.39.1
|
||||
|
@ -1,28 +0,0 @@
|
||||
From af5fb429c8e726d1d7455b2d0e5d4263edbd4290 Mon Sep 17 00:00:00 2001
|
||||
From: Ivan Mikhanchuk <ivanmikh@pm.me>
|
||||
Date: Tue, 24 Jan 2023 17:06:09 -0800
|
||||
Subject: [PATCH] modem-manager: remove improper use of assert
|
||||
|
||||
FuSaharaLoader being NULL is normal for devices that only
|
||||
support Firehose and don't use Sahara QDL port.
|
||||
---
|
||||
plugins/modem-manager/fu-sahara-loader.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/plugins/modem-manager/fu-sahara-loader.c b/plugins/modem-manager/fu-sahara-loader.c
|
||||
index 89c620fbe..78f24036f 100644
|
||||
--- a/plugins/modem-manager/fu-sahara-loader.c
|
||||
+++ b/plugins/modem-manager/fu-sahara-loader.c
|
||||
@@ -206,7 +206,8 @@ fu_sahara_loader_close(FuSaharaLoader *self, GError **error)
|
||||
gboolean
|
||||
fu_sahara_loader_qdl_is_open(FuSaharaLoader *self)
|
||||
{
|
||||
- g_return_val_if_fail(self != NULL, FALSE);
|
||||
+ if (self == NULL)
|
||||
+ return FALSE;
|
||||
|
||||
return fu_usb_device_is_open(self->usb_device);
|
||||
}
|
||||
--
|
||||
2.39.1
|
||||
|
@ -1,24 +0,0 @@
|
||||
From 7f427d567d497048772bad59e098528605e563ce Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Mon, 23 Jan 2023 11:22:43 +0000
|
||||
Subject: [PATCH] trivial: Fix build fix when using ppc64le system
|
||||
|
||||
---
|
||||
src/meson.build | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/meson.build b/src/meson.build
|
||||
index b9f6736f2..f3ca734ee 100644
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -197,6 +197,7 @@ plugins_hdr = custom_target('fwupd-generate-plugins-header',
|
||||
fwupdengine = library(
|
||||
'fwupdengine',
|
||||
resources_src,
|
||||
+ plugins_hdr,
|
||||
sources: fwupd_engine_src,
|
||||
install: true,
|
||||
install_rpath: libdir_pkg,
|
||||
--
|
||||
2.39.1
|
||||
|
@ -1,46 +0,0 @@
|
||||
From 8076090a000d4adde59fddeadb17a6f769993d1e Mon Sep 17 00:00:00 2001
|
||||
From: Jason Gerecke <killertofu@gmail.com>
|
||||
Date: Tue, 17 Jan 2023 14:24:14 -0800
|
||||
Subject: [PATCH] wacom-usb: Retry set_report on failure
|
||||
|
||||
Sometimes the flash process will randomly hang and time-out when sending
|
||||
data to the device. We currently do not use any retry logic, so if this
|
||||
happens the flash attempt is treated as a failure. This can be a source
|
||||
of worry or frustration, especially if subsequent manual retries fail
|
||||
in a similar way.
|
||||
|
||||
Adding FU_HID_DEVICE_FLAG_RETRY_FAILURE to the list of flags used when
|
||||
calling fu_hid_device_set_report allows fwupd to try sending a block
|
||||
multiple times if such a time-out (or other error) occurs. This makes
|
||||
the flash process less prone to failure.
|
||||
|
||||
Signed-off-by: Jason Gerecke <jason.gerecke@wacom.com>
|
||||
---
|
||||
plugins/wacom-usb/fu-wac-device.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/plugins/wacom-usb/fu-wac-device.c b/plugins/wacom-usb/fu-wac-device.c
|
||||
index 9162d19a9..714761b1e 100644
|
||||
--- a/plugins/wacom-usb/fu-wac-device.c
|
||||
+++ b/plugins/wacom-usb/fu-wac-device.c
|
||||
@@ -182,7 +182,8 @@ fu_wac_device_set_feature_report(FuWacDevice *self,
|
||||
buf,
|
||||
bufsz,
|
||||
FU_WAC_DEVICE_TIMEOUT,
|
||||
- flags | FU_HID_DEVICE_FLAG_IS_FEATURE,
|
||||
+ flags | FU_HID_DEVICE_FLAG_IS_FEATURE |
|
||||
+ FU_HID_DEVICE_FLAG_RETRY_FAILURE,
|
||||
error);
|
||||
}
|
||||
|
||||
@@ -920,6 +921,7 @@ fu_wac_device_init(FuWacDevice *self)
|
||||
fu_device_set_install_duration(FU_DEVICE(self), 10);
|
||||
fu_device_set_remove_delay(FU_DEVICE(self), FU_DEVICE_REMOVE_DELAY_RE_ENUMERATE);
|
||||
fu_device_set_firmware_gtype(FU_DEVICE(self), FU_TYPE_WAC_FIRMWARE);
|
||||
+ fu_device_retry_set_delay(FU_DEVICE(self), 30); /* ms */
|
||||
}
|
||||
|
||||
static void
|
||||
--
|
||||
2.39.1
|
||||
|
129
SPECS/fwupd.spec
129
SPECS/fwupd.spec
@ -40,11 +40,6 @@
|
||||
%global have_msr 1
|
||||
%endif
|
||||
|
||||
# libsmbios is only available on x86
|
||||
%ifarch x86_64
|
||||
%global have_dell 1
|
||||
%endif
|
||||
|
||||
# Until we actually have seen it outside x86
|
||||
%ifarch i686 x86_64
|
||||
%global have_thunderbolt 1
|
||||
@ -57,20 +52,15 @@
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 1.8.10
|
||||
Version: 1.9.13
|
||||
Release: 2%{?dist}.alma
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/fwupd/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.4.tar.xz
|
||||
|
||||
Patch1: 0001-trivial-Fix-build-fix-when-using-ppc64le-system.patch
|
||||
Patch2: 0001-Only-include-the-attribute-not-exported-warning-on-d.patch
|
||||
Patch3: 0001-Do-not-make-any-of-the-HWIDs-setup-failures-fatal.patch
|
||||
Patch4: 0001-modem-manager-remove-improper-use-of-assert.patch
|
||||
Patch5: 0001-wacom-usb-Retry-set_report-on-failure.patch
|
||||
|
||||
Patch101: 0001-generate_binary-Add-NX-COMPAT-flag-manually-when-gen.patch
|
||||
Patch102: 0001-Correctly-migrate-from-v2-to-database-schema-v10.patch
|
||||
|
||||
Source10: http://people.redhat.com/rhughes/dbx/DBXUpdate-20100307-x64.cab
|
||||
Source11: http://people.redhat.com/rhughes/dbx/DBXUpdate-20140413-x64.cab
|
||||
@ -82,6 +72,9 @@ Source16: http://people.redhat.com/rhughes/dbx/DBXUpdate-20210429-x64.cab
|
||||
Source17: http://people.redhat.com/rhughes/dbx/DBXUpdate-20220812-aa64.cab
|
||||
Source18: http://people.redhat.com/rhughes/dbx/DBXUpdate-20220812-ia32.cab
|
||||
Source19: http://people.redhat.com/rhughes/dbx/DBXUpdate-20220812-x64.cab
|
||||
Source20: http://people.redhat.com/rhughes/dbx/DBXUpdate-20230509-aa64.cab
|
||||
Source21: http://people.redhat.com/rhughes/dbx/DBXUpdate-20230509-ia32.cab
|
||||
Source22: http://people.redhat.com/rhughes/dbx/DBXUpdate-20230509-x64.cab
|
||||
|
||||
# these are numbered high just to keep them wildly away from colliding with
|
||||
# the real package sources, in order to reduce churn.
|
||||
@ -93,7 +86,6 @@ Source503: almalinuxsecurebootca0.cer
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
||||
BuildRequires: libgcab1-devel
|
||||
BuildRequires: libgudev1-devel
|
||||
BuildRequires: libgusb-devel >= %{libgusb_version}
|
||||
BuildRequires: libcurl-devel >= %{libcurl_version}
|
||||
@ -104,7 +96,6 @@ BuildRequires: systemd >= %{systemd_version}
|
||||
BuildRequires: systemd-devel
|
||||
BuildRequires: libarchive-devel
|
||||
BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: gcab
|
||||
%ifarch %{valgrind_arches}
|
||||
BuildRequires: valgrind
|
||||
BuildRequires: valgrind-devel
|
||||
@ -119,6 +110,8 @@ BuildRequires: git-core
|
||||
%if 0%{?have_flashrom}
|
||||
BuildRequires: flashrom-devel >= 1.2-2
|
||||
%endif
|
||||
BuildRequires: libdrm-devel
|
||||
BuildRequires: python3-jinja2
|
||||
|
||||
%if 0%{?have_modem_manager}
|
||||
BuildRequires: ModemManager-glib-devel >= 1.10.0
|
||||
@ -139,11 +132,6 @@ BuildRequires: tpm2-tss-devel >= 2.2.3
|
||||
BuildRequires: pesign >= 113-20
|
||||
%endif
|
||||
|
||||
%if 0%{?have_dell}
|
||||
BuildRequires: efivar-devel >= 33
|
||||
BuildRequires: libsmbios-devel >= 2.3.0
|
||||
%endif
|
||||
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
@ -212,11 +200,7 @@ can be flashed using flashrom. It is probably not required on servers.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch102 -p1
|
||||
|
||||
mkdir -p subprojects/fwupd-efi
|
||||
tar xfvs %{SOURCE2} -C subprojects/fwupd-efi --strip-components=1
|
||||
@ -229,16 +213,13 @@ cd -
|
||||
%meson \
|
||||
-Ddocs=disabled \
|
||||
-Dlvfs=disabled \
|
||||
-Dlaunchd=disabled \
|
||||
-Dpassim=disabled \
|
||||
%if 0%{?enable_tests}
|
||||
-Dtests=true \
|
||||
%else
|
||||
-Dtests=false \
|
||||
%endif
|
||||
%if 0%{?enable_dummy}
|
||||
-Dplugin_dummy=true \
|
||||
%else
|
||||
-Dplugin_dummy=false \
|
||||
%endif
|
||||
%if 0%{?have_flashrom}
|
||||
-Dplugin_flashrom=enabled \
|
||||
%else
|
||||
@ -272,17 +253,14 @@ cd -
|
||||
-Dplugin_uefi_pk=disabled \
|
||||
-Dplugin_tpm=disabled \
|
||||
%endif
|
||||
%if 0%{?have_dell}
|
||||
-Dplugin_dell=enabled \
|
||||
%else
|
||||
-Dplugin_dell=disabled \
|
||||
%endif
|
||||
%if 0%{?have_modem_manager}
|
||||
-Dplugin_modem_manager=enabled \
|
||||
%else
|
||||
-Dplugin_modem_manager=disabled \
|
||||
%endif
|
||||
-Dman=true \
|
||||
-Dsystemd_unit_user="" \
|
||||
-Dcompat_cli=true \
|
||||
-Dbluez=disabled \
|
||||
-Dcbor=disabled \
|
||||
-Dplugin_android_boot=disabled \
|
||||
@ -308,7 +286,10 @@ cd -
|
||||
|
||||
# on RHEL the LVFS is disabled by default
|
||||
mkdir -p %{buildroot}/%{_datadir}/dbxtool
|
||||
install %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16} %{SOURCE17} %{SOURCE18} %{SOURCE19} %{buildroot}/%{_datadir}/dbxtool
|
||||
install \
|
||||
%{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} \
|
||||
%{SOURCE16} %{SOURCE17} %{SOURCE18} %{SOURCE19} %{SOURCE20} %{SOURCE21} %{SOURCE22} \
|
||||
%{buildroot}/%{_datadir}/dbxtool
|
||||
|
||||
# sign fwupd.efi loader
|
||||
%ifarch x86_64
|
||||
@ -327,7 +308,7 @@ mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/fwupd
|
||||
%find_lang %{name}
|
||||
|
||||
%post
|
||||
%systemd_post fwupd.service
|
||||
%systemd_post fwupd.service fwupd-refresh.timer
|
||||
|
||||
# change vendor-installed remotes to use the default keyring type
|
||||
for fn in /etc/fwupd/remotes.d/*.conf; do
|
||||
@ -337,23 +318,16 @@ for fn in /etc/fwupd/remotes.d/*.conf; do
|
||||
done
|
||||
|
||||
%preun
|
||||
%systemd_preun fwupd.service
|
||||
%systemd_preun fwupd.service fwupd-refresh.timer
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart fwupd.service
|
||||
%systemd_postun_with_restart fwupd.service fwupd-refresh.timer
|
||||
%systemd_postun_with_restart pesign.service
|
||||
|
||||
%files -f %{name}.lang
|
||||
%doc README.md AUTHORS
|
||||
%doc README.md
|
||||
%license COPYING
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/daemon.conf
|
||||
%if 0%{?have_uefi}
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/uefi_capsule.conf
|
||||
%endif
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/redfish.conf
|
||||
%if 0%{?have_thunderbolt}
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/thunderbolt.conf
|
||||
%endif
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/fwupd.conf
|
||||
%dir %{_libexecdir}/fwupd
|
||||
%{_libexecdir}/fwupd/fwupd
|
||||
%ifarch i686 x86_64
|
||||
@ -368,9 +342,7 @@ done
|
||||
%{_bindir}/fwupdate
|
||||
%endif
|
||||
%{_bindir}/dfu-tool
|
||||
%if 0%{?have_uefi}
|
||||
%{_bindir}/dbxtool
|
||||
%endif
|
||||
%{_bindir}/fwupdmgr
|
||||
%{_bindir}/fwupdtool
|
||||
%{_bindir}/fwupdagent
|
||||
@ -378,28 +350,19 @@ done
|
||||
%dir %{_sysconfdir}/fwupd/bios-settings.d
|
||||
%{_sysconfdir}/fwupd/bios-settings.d/README.md
|
||||
%dir %{_sysconfdir}/fwupd/remotes.d
|
||||
%if 0%{?have_dell}
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/dell-esrt.conf
|
||||
%endif
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs.conf
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs-testing.conf
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/vendor.conf
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/vendor-directory.conf
|
||||
%config(noreplace)%{_sysconfdir}/pki/fwupd
|
||||
%{_sysconfdir}/pki/fwupd-metadata
|
||||
%if 0%{?have_msr}
|
||||
/usr/lib/modules-load.d/fwupd-msr.conf
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/msr.conf
|
||||
%endif
|
||||
%{_datadir}/dbus-1/system.d/org.freedesktop.fwupd.conf
|
||||
%{_datadir}/bash-completion/completions/fwupdmgr
|
||||
%{_datadir}/bash-completion/completions/fwupdtool
|
||||
%{_datadir}/bash-completion/completions/fwupdagent
|
||||
%{_datadir}/fish/vendor_completions.d/fwupdmgr.fish
|
||||
%{_datadir}/fwupd/metainfo/org.freedesktop.fwupd*.metainfo.xml
|
||||
%if 0%{?have_dell}
|
||||
%{_datadir}/fwupd/remotes.d/dell-esrt/metadata.xml
|
||||
%endif
|
||||
%{_datadir}/fwupd/remotes.d/vendor/firmware/README.md
|
||||
%{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
|
||||
%{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
|
||||
@ -416,16 +379,12 @@ done
|
||||
%{_datadir}/dbxtool/DBXUpdate-20220812-aa64.cab
|
||||
%{_datadir}/dbxtool/DBXUpdate-20220812-ia32.cab
|
||||
%{_datadir}/dbxtool/DBXUpdate-20220812-x64.cab
|
||||
%{_mandir}/man1/fwupdtool.1*
|
||||
%{_mandir}/man1/fwupdagent.1*
|
||||
%{_mandir}/man1/dfu-tool.1*
|
||||
%if 0%{?have_uefi}
|
||||
%{_mandir}/man1/dbxtool.*
|
||||
%endif
|
||||
%{_mandir}/man1/fwupdmgr.1*
|
||||
%if 0%{?have_uefi}
|
||||
%{_mandir}/man1/fwupdate.1*
|
||||
%endif
|
||||
%{_datadir}/dbxtool/DBXUpdate-20230509-aa64.cab
|
||||
%{_datadir}/dbxtool/DBXUpdate-20230509-ia32.cab
|
||||
%{_datadir}/dbxtool/DBXUpdate-20230509-x64.cab
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man5/*
|
||||
%{_mandir}/man8/*
|
||||
%{_datadir}/metainfo/org.freedesktop.fwupd.metainfo.xml
|
||||
%{_datadir}/icons/hicolor/scalable/apps/org.freedesktop.fwupd.svg
|
||||
%{_datadir}/fwupd/firmware_packager.py
|
||||
@ -436,14 +395,13 @@ done
|
||||
%{_unitdir}/fwupd.service
|
||||
%{_unitdir}/fwupd-refresh.service
|
||||
%{_unitdir}/fwupd-refresh.timer
|
||||
%{_presetdir}/fwupd-refresh.preset
|
||||
%{_unitdir}/system-update.target.wants/
|
||||
%dir %{_localstatedir}/lib/fwupd
|
||||
%dir %{_localstatedir}/cache/fwupd
|
||||
%dir %{_datadir}/fwupd/quirks.d
|
||||
%{_datadir}/fwupd/quirks.d/builtin.quirk.gz
|
||||
%if 0%{?have_uefi}
|
||||
%{_sysconfdir}/grub.d/35_fwupd
|
||||
%config(noreplace)%{_sysconfdir}/grub.d/35_fwupd
|
||||
%endif
|
||||
%{_libdir}/libfwupd.so.2*
|
||||
%{_libdir}/girepository-1.0/Fwupd-2.0.typelib
|
||||
@ -483,6 +441,9 @@ done
|
||||
%{_datadir}/installed-tests/fwupd/fwupd-tests.xml
|
||||
%{_datadir}/installed-tests/fwupd/*.test
|
||||
%{_datadir}/installed-tests/fwupd/*.cab
|
||||
%{_datadir}/installed-tests/fwupd/fakedevice124.jcat
|
||||
%{_datadir}/installed-tests/fwupd/fakedevice124.bin
|
||||
%{_datadir}/installed-tests/fwupd/fakedevice124.metainfo.xml
|
||||
%{_datadir}/installed-tests/fwupd/*.sh
|
||||
%{_datadir}/installed-tests/fwupd/*.zip
|
||||
%if 0%{?have_uefi}
|
||||
@ -490,16 +451,38 @@ done
|
||||
%endif
|
||||
%{_datadir}/installed-tests/fwupd/chassis_type
|
||||
%{_datadir}/installed-tests/fwupd/sys_vendor
|
||||
%{_datadir}/fwupd/device-tests/*.json
|
||||
%{_libexecdir}/installed-tests/fwupd/*
|
||||
%dir %{_sysconfdir}/fwupd/remotes.d
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/fwupd-tests.conf
|
||||
%{_datadir}/fwupd/remotes.d/fwupd-tests.conf
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Mar 29 2023 Eduard Abdullin <eabdullin@almalinux.org> - 1.8.10-2.alma
|
||||
* Thu Mar 28 2024 Eduard Abdullin <eabdullin@almalinux.org> - 1.9.13-2.alma
|
||||
- Use AlmaLinux cert
|
||||
|
||||
* Mon Feb 19 2024 Richard Hughes <richard@hughsie.com> 1.9.13-2
|
||||
- Fix upgrade from fwupd < v1.9.5
|
||||
- Resolves: #RHEL-15328
|
||||
* Thu Feb 15 2024 Richard Hughes <richard@hughsie.com> 1.9.13-1
|
||||
- Update to latest stable upstream version.
|
||||
- Resolves: #RHEL-15328
|
||||
|
||||
* Wed Jan 24 2024 Richard Hughes <richard@hughsie.com> 1.9.12-1
|
||||
- Update to latest stable upstream version.
|
||||
- Resolves: #RHEL-15328
|
||||
|
||||
* Wed Jan 03 2024 Richard Hughes <richard@hughsie.com> 1.9.11-1
|
||||
- Update to latest stable upstream version.
|
||||
- Resolves: #RHEL-15328
|
||||
|
||||
* Mon Dec 04 2023 Richard Hughes <richard@hughsie.com> 1.9.10-1
|
||||
- Update to latest stable upstream version.
|
||||
- Resolves: #RHEL-15328
|
||||
|
||||
* Fri Jun 09 2023 Richard Hughes <richard@hughsie.com> 1.8.16-1
|
||||
- Update to latest stable upstream version.
|
||||
- Resolves: rhbz#2209944
|
||||
|
||||
* Thu Feb 02 2023 Richard Hughes <richard@hughsie.com> 1.8.10-2
|
||||
- Rebuild because distrobaker did entirely the wrong thing.
|
||||
- Resolves: rhbz#2128384, needed for rhbz#2119436 and rhbz#2128384
|
||||
|
Loading…
Reference in New Issue
Block a user