New upstream release
This commit is contained in:
parent
72609464c7
commit
74c110c1c5
2
.gitignore
vendored
2
.gitignore
vendored
@ -84,3 +84,5 @@
|
||||
/fwupd-1.7.1.tar.xz
|
||||
/fwupd-efi-1.1.tar.xz
|
||||
/fwupd-1.7.4.tar.xz
|
||||
/fwupd-1.7.9.tar.xz
|
||||
/fwupd-efi-1.3.tar.xz
|
||||
|
@ -1,58 +0,0 @@
|
||||
From e74d38bfd3097471fe60dbe843a68c16516a78da Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Mon, 17 Jan 2022 14:50:47 +0000
|
||||
Subject: [PATCH] Fix compiling with new versions of efivar
|
||||
|
||||
Fixes https://github.com/fwupd/fwupd/issues/4181
|
||||
---
|
||||
meson.build | 5 +++++
|
||||
plugins/uefi-capsule/fu-uefi-common.h | 3 +++
|
||||
2 files changed, 8 insertions(+)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 833bdbf56..691cc8a58 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -412,6 +412,11 @@ endif
|
||||
if build_standalone and get_option('plugin_uefi_capsule')
|
||||
efiboot = dependency('efiboot')
|
||||
|
||||
+ efivar = dependency('efivar')
|
||||
+ if cc.has_header_symbol('efivar/efivar-types.h', 'efi_time_t', dependencies : efivar)
|
||||
+ conf.set('HAVE_EFI_TIME_T', '1')
|
||||
+ endif
|
||||
+
|
||||
efi_app_location = join_paths(libexecdir, 'fwupd', 'efi')
|
||||
conf.set_quoted('EFI_APP_LOCATION', efi_app_location)
|
||||
|
||||
diff --git a/plugins/uefi-capsule/fu-uefi-common.h b/plugins/uefi-capsule/fu-uefi-common.h
|
||||
index a21806d6b..1d616c9e0 100644
|
||||
--- a/plugins/uefi-capsule/fu-uefi-common.h
|
||||
+++ b/plugins/uefi-capsule/fu-uefi-common.h
|
||||
@@ -9,6 +9,7 @@
|
||||
|
||||
#include <fwupdplugin.h>
|
||||
|
||||
+#include <efivar/efivar.h>
|
||||
#include <glib.h>
|
||||
|
||||
#define EFI_CAPSULE_HEADER_FLAGS_PERSIST_ACROSS_RESET 0x00010000
|
||||
@@ -17,6 +18,7 @@
|
||||
|
||||
#define EFI_OS_INDICATIONS_FILE_CAPSULE_DELIVERY_SUPPORTED 0x0000000000000004ULL
|
||||
|
||||
+#ifndef HAVE_EFI_TIME_T
|
||||
typedef struct __attribute__((__packed__)) {
|
||||
guint16 year;
|
||||
guint8 month;
|
||||
@@ -30,6 +32,7 @@ typedef struct __attribute__((__packed__)) {
|
||||
guint8 daylight;
|
||||
guint8 pad2;
|
||||
} efi_time_t;
|
||||
+#endif
|
||||
|
||||
typedef struct __attribute__((__packed__)) {
|
||||
fwupd_guid_t guid;
|
||||
--
|
||||
2.35.1
|
||||
|
18
fwupd.spec
18
fwupd.spec
@ -44,12 +44,12 @@
|
||||
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 1.7.4
|
||||
Release: 3%{?dist}
|
||||
Version: 1.7.9
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/fwupd/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.1.tar.xz
|
||||
Source2: http://people.freedesktop.org/~hughsient/releases/fwupd-efi-1.3.tar.xz
|
||||
|
||||
Source10: http://people.redhat.com/rhughes/dbx/DBXUpdate-20100307-x64.cab
|
||||
Source11: http://people.redhat.com/rhughes/dbx/DBXUpdate-20140413-x64.cab
|
||||
@ -65,9 +65,6 @@ Source301: redhatsecureboot301.cer
|
||||
Source500: redhatsecurebootca5.cer
|
||||
Source503: redhatsecureboot503.cer
|
||||
|
||||
# Backported from upstream
|
||||
Patch1: 0001-Fix-compiling-with-new-versions-of-efivar.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
||||
@ -259,6 +256,7 @@ tar xfvs %{SOURCE2} -C subprojects/fwupd-efi --strip-components=1
|
||||
-Dplugin_mtd=false \
|
||||
-Dplugin_powerd=false \
|
||||
-Dplugin_uf2=false \
|
||||
-Dplugin_gpio=false \
|
||||
-Dsupported_build=true
|
||||
|
||||
%meson_build
|
||||
@ -350,8 +348,8 @@ done
|
||||
%{_sysconfdir}/pki/fwupd-metadata
|
||||
%if 0%{?have_msr}
|
||||
/usr/lib/modules-load.d/fwupd-msr.conf
|
||||
%config(noreplace)%{_sysconfdir}/fwupd/msr.conf
|
||||
%endif
|
||||
/usr/lib/modules-load.d/fwupd-redfish.conf
|
||||
%{_datadir}/dbus-1/system.d/org.freedesktop.fwupd.conf
|
||||
%{_datadir}/bash-completion/completions/fwupdmgr
|
||||
%{_datadir}/bash-completion/completions/fwupdtool
|
||||
@ -435,6 +433,7 @@ done
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_ep963x.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_fastboot.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_fresco_pd.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_genesys.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_hailuck.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_iommu.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_jabra.so
|
||||
@ -460,6 +459,7 @@ done
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_redfish.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_rts54hid.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_rts54hub.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_scsi.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_steelseries.so
|
||||
%{_libdir}/fwupd-plugins-%{fwupdplugin_version}/libfu_plugin_superio.so
|
||||
%if 0%{?have_dell}
|
||||
@ -537,6 +537,10 @@ done
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jul 25 2022 Richard Hughes <richard@hughsie.com> 1.7.8-1
|
||||
- New upstream release
|
||||
- Resolves: rhbz#2059075
|
||||
|
||||
* Wed Apr 06 2022 Richard Hughes <richard@hughsie.com> 1.7.4-3
|
||||
- Disable the Logitech bulkcontroller plugin to avoid adding a dep to protobuf-c
|
||||
which lives in AppStream, not BaseOS.
|
||||
|
4
sources
4
sources
@ -1,5 +1,5 @@
|
||||
SHA512 (fwupd-1.7.4.tar.xz) = af038ba0d32bf97b2a0ea53b431628a5b5c948e161219c2f679d0b481c27e7f3488ac28a27a26aa9490df23d652110e70ba98d700eeb8ff0f99acc08f87e2d8c
|
||||
SHA512 (fwupd-efi-1.1.tar.xz) = 9070672f5238b3cbbd8d67dd72f822ccae58d73a380851ba7f69e4fbd415b96db2e79a73ddd12cb959ef5f158d55846ade7d45ea1d555ac2f4c923d5c3ab85f2
|
||||
SHA512 (fwupd-1.7.9.tar.xz) = e7ded54a1773b7e2b77c6f75ddf78f06540656a9b987e4a92217384ef7070b75cea2f7ea7f6d06115e61483062b439558225e707d310326314843de3f7153848
|
||||
SHA512 (fwupd-efi-1.3.tar.xz) = 582bc0298f773b3017fab317a392b6fe95a9d1698bfe17e56370515f4563c8d45c12f28ae52d304866e4b077043bb0c9d5c1abf4b75ded5f70b6d8ccad495ea5
|
||||
SHA512 (DBXUpdate-20100307-x64.cab) = f8ad56cf015f4cdc5c305856ff1f7a8589c25a2a671708c61883f427f38eb9b6a7abd3f2c8d79ef9d5076222255e42585917f8705a2a4b13f860bad4e02ec409
|
||||
SHA512 (DBXUpdate-20140413-x64.cab) = 75771876a2309fa8ca083c2e76520173d434229b7cacf1e7636bd9b1bc4f871d745c348b9792bfb65fd9f40ef54c25bb427b1431151e817e7050b7829456731a
|
||||
SHA512 (DBXUpdate-20160809-x64.cab) = c27c564999ae84515540f1a598cd0fd9ef3a80cdfaaf439f1c4cb04eaee0e73074548b6d76c21ca3af1ba9c4c0625907e821582998eb5617e33ecd412e6c8a13
|
||||
|
Loading…
Reference in New Issue
Block a user