New upstream release
This commit is contained in:
parent
3160ec50bb
commit
51786d0662
1
.gitignore
vendored
1
.gitignore
vendored
@ -78,3 +78,4 @@
|
|||||||
/fwupd-1.5.7.tar.xz
|
/fwupd-1.5.7.tar.xz
|
||||||
/fwupd-1.5.8.tar.xz
|
/fwupd-1.5.8.tar.xz
|
||||||
/fwupd-1.5.9.tar.xz
|
/fwupd-1.5.9.tar.xz
|
||||||
|
/fwupd-1.6.0.tar.xz
|
||||||
|
66
3144.patch
66
3144.patch
@ -1,66 +0,0 @@
|
|||||||
From 393950b8b9f56bde7e759f23f362faa44053c580 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Richard Hughes <richard@hughsie.com>
|
|
||||||
Date: Wed, 14 Apr 2021 18:02:01 +0100
|
|
||||||
Subject: [PATCH] Cancel the GDBusObjectManager operation to fix a potential
|
|
||||||
crash
|
|
||||||
|
|
||||||
If blues takes longer than 1500ms to successfully start, then we will call
|
|
||||||
fu_bluez_backend_connect_cb() with a freed FuBluezBackendHelper.
|
|
||||||
|
|
||||||
Hopefully fixes https://bugzilla.redhat.com/show_bug.cgi?id=1949491
|
|
||||||
---
|
|
||||||
src/fu-bluez-backend.c | 13 ++++++-------
|
|
||||||
1 file changed, 6 insertions(+), 7 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/fu-bluez-backend.c b/src/fu-bluez-backend.c
|
|
||||||
index 3e68d8438..f00637202 100644
|
|
||||||
--- a/src/fu-bluez-backend.c
|
|
||||||
+++ b/src/fu-bluez-backend.c
|
|
||||||
@@ -117,6 +117,7 @@ typedef struct {
|
|
||||||
GDBusObjectManager *object_manager;
|
|
||||||
GMainLoop *loop;
|
|
||||||
GError **error;
|
|
||||||
+ GCancellable *cancellable;
|
|
||||||
guint timeout_id;
|
|
||||||
} FuBluezBackendHelper;
|
|
||||||
|
|
||||||
@@ -127,6 +128,7 @@ fu_bluez_backend_helper_free (FuBluezBackendHelper *helper)
|
|
||||||
g_object_unref (helper->object_manager);
|
|
||||||
if (helper->timeout_id != 0)
|
|
||||||
g_source_remove (helper->timeout_id);
|
|
||||||
+ g_cancellable_cancel (helper->cancellable);
|
|
||||||
g_main_loop_unref (helper->loop);
|
|
||||||
g_free (helper);
|
|
||||||
}
|
|
||||||
@@ -148,12 +150,7 @@ static gboolean
|
|
||||||
fu_bluez_backend_timeout_cb (gpointer user_data)
|
|
||||||
{
|
|
||||||
FuBluezBackendHelper *helper = (FuBluezBackendHelper *) user_data;
|
|
||||||
- g_set_error (helper->error,
|
|
||||||
- G_IO_ERROR,
|
|
||||||
- G_IO_ERROR_TIMED_OUT,
|
|
||||||
- "failed to connect to Bluez after %ums",
|
|
||||||
- (guint) FU_BLUEZ_BACKEND_TIMEOUT);
|
|
||||||
- g_main_loop_quit (helper->loop);
|
|
||||||
+ g_cancellable_cancel (helper->cancellable);
|
|
||||||
helper->timeout_id = 0;
|
|
||||||
return G_SOURCE_REMOVE;
|
|
||||||
}
|
|
||||||
@@ -168,6 +165,7 @@ fu_bluez_backend_setup (FuBackend *backend, GError **error)
|
|
||||||
* forever and make fwupd startup also fail */
|
|
||||||
helper->error = error;
|
|
||||||
helper->loop = g_main_loop_new (NULL, FALSE);
|
|
||||||
+ helper->cancellable = g_cancellable_new ();
|
|
||||||
helper->timeout_id = g_timeout_add (FU_BLUEZ_BACKEND_TIMEOUT,
|
|
||||||
fu_bluez_backend_timeout_cb,
|
|
||||||
helper);
|
|
||||||
@@ -176,7 +174,8 @@ fu_bluez_backend_setup (FuBackend *backend, GError **error)
|
|
||||||
G_DBUS_OBJECT_MANAGER_CLIENT_FLAGS_NONE,
|
|
||||||
"org.bluez",
|
|
||||||
"/",
|
|
||||||
- NULL, NULL, NULL, NULL,
|
|
||||||
+ NULL, NULL, NULL,
|
|
||||||
+ helper->cancellable,
|
|
||||||
fu_bluez_backend_connect_cb,
|
|
||||||
helper);
|
|
||||||
g_main_loop_run (helper->loop);
|
|
46
fwupd.spec
46
fwupd.spec
@ -43,15 +43,12 @@
|
|||||||
|
|
||||||
Summary: Firmware update daemon
|
Summary: Firmware update daemon
|
||||||
Name: fwupd
|
Name: fwupd
|
||||||
Version: 1.5.9
|
Version: 1.6.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/fwupd/fwupd
|
URL: https://github.com/fwupd/fwupd
|
||||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1949491
|
|
||||||
Patch0: 3144.patch
|
|
||||||
|
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
BuildRequires: libxmlb-devel >= %{libxmlb_version}
|
||||||
@ -76,7 +73,6 @@ BuildRequires: gtk-doc
|
|||||||
BuildRequires: gnutls-devel
|
BuildRequires: gnutls-devel
|
||||||
BuildRequires: gnutls-utils
|
BuildRequires: gnutls-utils
|
||||||
BuildRequires: meson
|
BuildRequires: meson
|
||||||
BuildRequires: help2man
|
|
||||||
BuildRequires: json-glib-devel >= %{json_glib_version}
|
BuildRequires: json-glib-devel >= %{json_glib_version}
|
||||||
BuildRequires: vala
|
BuildRequires: vala
|
||||||
BuildRequires: bash-completion
|
BuildRequires: bash-completion
|
||||||
@ -92,15 +88,13 @@ BuildRequires: libqmi-devel >= 1.22.0
|
|||||||
|
|
||||||
%if 0%{?have_uefi}
|
%if 0%{?have_uefi}
|
||||||
BuildRequires: efivar-devel >= 33
|
BuildRequires: efivar-devel >= 33
|
||||||
BuildRequires: python3 python3-cairo python3-gobject python3-pillow
|
BuildRequires: python3 python3-cairo python3-gobject
|
||||||
BuildRequires: pango-devel
|
BuildRequires: pango-devel
|
||||||
BuildRequires: cairo-devel cairo-gobject-devel
|
BuildRequires: cairo-devel cairo-gobject-devel
|
||||||
BuildRequires: freetype
|
BuildRequires: freetype
|
||||||
BuildRequires: fontconfig
|
BuildRequires: fontconfig
|
||||||
BuildRequires: google-noto-sans-cjk-ttc-fonts
|
BuildRequires: google-noto-sans-cjk-ttc-fonts
|
||||||
BuildRequires: gnu-efi-devel
|
|
||||||
BuildRequires: tpm2-tss-devel >= 2.2.3
|
BuildRequires: tpm2-tss-devel >= 2.2.3
|
||||||
BuildRequires: pesign
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if 0%{?have_dell}
|
%if 0%{?have_dell}
|
||||||
@ -137,6 +131,7 @@ Recommends: %{name}-plugin-modem-manager
|
|||||||
Recommends: %{name}-plugin-flashrom
|
Recommends: %{name}-plugin-flashrom
|
||||||
%endif
|
%endif
|
||||||
%if 0%{?have_uefi}
|
%if 0%{?have_uefi}
|
||||||
|
Recommends: %{name}-efi
|
||||||
Recommends: %{name}-plugin-uefi-capsule-data
|
Recommends: %{name}-plugin-uefi-capsule-data
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -218,12 +213,8 @@ or server machines.
|
|||||||
%if 0%{?have_uefi}
|
%if 0%{?have_uefi}
|
||||||
-Dplugin_uefi_capsule=true \
|
-Dplugin_uefi_capsule=true \
|
||||||
-Dplugin_uefi_pk=true \
|
-Dplugin_uefi_pk=true \
|
||||||
-Defi_sbat_distro_id="fedora" \
|
|
||||||
-Defi_sbat_distro_summary="The Fedora Project" \
|
|
||||||
-Defi_sbat_distro_pkgname="%{name}" \
|
|
||||||
-Defi_sbat_distro_version="%{version}" \
|
|
||||||
-Defi_sbat_distro_url="https://src.fedoraproject.org/rpms/%{name}" \
|
|
||||||
-Dplugin_tpm=true \
|
-Dplugin_tpm=true \
|
||||||
|
-Defi_binary=false \
|
||||||
%else
|
%else
|
||||||
-Dplugin_uefi_capsule=false \
|
-Dplugin_uefi_capsule=false \
|
||||||
-Dplugin_uefi_pk=false \
|
-Dplugin_uefi_pk=false \
|
||||||
@ -255,21 +246,6 @@ or server machines.
|
|||||||
%install
|
%install
|
||||||
%meson_install
|
%meson_install
|
||||||
|
|
||||||
# sign fwupd.efi loader
|
|
||||||
%if 0%{?have_uefi}
|
|
||||||
%ifarch x86_64
|
|
||||||
%global efiarch x64
|
|
||||||
%endif
|
|
||||||
%ifarch aarch64
|
|
||||||
%global efiarch aa64
|
|
||||||
%endif
|
|
||||||
%global fwup_efi_fn $RPM_BUILD_ROOT%{_libexecdir}/fwupd/efi/fwupd%{efiarch}.efi
|
|
||||||
%pesign -s -i %{fwup_efi_fn} -o %{fwup_efi_fn}.tmp
|
|
||||||
%define __pesign_client_cert fwupd-signer
|
|
||||||
%pesign -s -i %{fwup_efi_fn}.tmp -o %{fwup_efi_fn}.signed
|
|
||||||
rm -vf %{fwup_efi_fn}.tmp
|
|
||||||
%endif
|
|
||||||
|
|
||||||
mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
||||||
|
|
||||||
# workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1757948
|
# workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1757948
|
||||||
@ -278,7 +254,7 @@ mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/fwupd
|
|||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
%post
|
%post
|
||||||
%systemd_post fwupd.service pesign.service
|
%systemd_post fwupd.service
|
||||||
|
|
||||||
# change vendor-installed remotes to use the default keyring type
|
# change vendor-installed remotes to use the default keyring type
|
||||||
for fn in /etc/fwupd/remotes.d/*.conf; do
|
for fn in /etc/fwupd/remotes.d/*.conf; do
|
||||||
@ -288,10 +264,10 @@ for fn in /etc/fwupd/remotes.d/*.conf; do
|
|||||||
done
|
done
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
%systemd_preun fwupd.service pesign.service
|
%systemd_preun fwupd.service
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
%systemd_postun_with_restart fwupd.service pesign.service
|
%systemd_postun_with_restart fwupd.service
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%doc README.md AUTHORS
|
%doc README.md AUTHORS
|
||||||
@ -310,8 +286,6 @@ done
|
|||||||
%endif
|
%endif
|
||||||
%{_libexecdir}/fwupd/fwupdoffline
|
%{_libexecdir}/fwupd/fwupdoffline
|
||||||
%if 0%{?have_uefi}
|
%if 0%{?have_uefi}
|
||||||
%{_libexecdir}/fwupd/efi/*.efi
|
|
||||||
%{_libexecdir}/fwupd/efi/*.efi.signed
|
|
||||||
%{_bindir}/fwupdate
|
%{_bindir}/fwupdate
|
||||||
%{_bindir}/fwupdtpmevlog
|
%{_bindir}/fwupdtpmevlog
|
||||||
%endif
|
%endif
|
||||||
@ -388,6 +362,7 @@ done
|
|||||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_acpi_facp.so
|
%{_libdir}/fwupd-plugins-3/libfu_plugin_acpi_facp.so
|
||||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_altos.so
|
%{_libdir}/fwupd-plugins-3/libfu_plugin_altos.so
|
||||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_amt.so
|
%{_libdir}/fwupd-plugins-3/libfu_plugin_amt.so
|
||||||
|
%{_libdir}/fwupd-plugins-3/libfu_plugin_analogix.so
|
||||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_ata.so
|
%{_libdir}/fwupd-plugins-3/libfu_plugin_ata.so
|
||||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_bcm57xx.so
|
%{_libdir}/fwupd-plugins-3/libfu_plugin_bcm57xx.so
|
||||||
%{_libdir}/fwupd-plugins-3/libfu_plugin_ccgx.so
|
%{_libdir}/fwupd-plugins-3/libfu_plugin_ccgx.so
|
||||||
@ -497,6 +472,9 @@ done
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 28 2021 Richard Hughes <richard@hughsie.com> 1.6.0-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
* Wed Apr 14 2021 Andrew Thurman <ajtbecool@gmail.com> 1.5.9-2
|
* Wed Apr 14 2021 Andrew Thurman <ajtbecool@gmail.com> 1.5.9-2
|
||||||
- Backport https://github.com/fwupd/fwupd/pull/3144 to fix https://bugzilla.redhat.com/show_bug.cgi?id=1949491
|
- Backport https://github.com/fwupd/fwupd/pull/3144 to fix https://bugzilla.redhat.com/show_bug.cgi?id=1949491
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (fwupd-1.5.9.tar.xz) = 1d22bb9759bb0fa6a9030c83b3372ffd02f812c34e4d60f83cbacf5793d68dd846b353a3f127eccfb8f2cdcd329ba09320465cd2f0fe422dea13738e5b0b47ed
|
SHA512 (fwupd-1.6.0.tar.xz) = 9fbbc66c687cb66f8613967f73e8272b4485c38847e511a5ac8164abf3a2b13ff3920b93bcc4d2b7ce5a2e91e0a4e767fe51e16fb1db7b1e4fda9207f6322f88
|
||||||
|
Loading…
Reference in New Issue
Block a user