Fix the lvfs-testing remote
This commit is contained in:
parent
168522c5bc
commit
3d1acc8ad8
40
0001-trivial-Fix-lvfs-testing-remote-file.patch
Normal file
40
0001-trivial-Fix-lvfs-testing-remote-file.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 73a63b89a051dda3c149b16ffc0f4759e1611715 Mon Sep 17 00:00:00 2001
|
||||
From: Richard Hughes <richard@hughsie.com>
|
||||
Date: Wed, 9 Nov 2022 15:51:27 +0000
|
||||
Subject: [PATCH] trivial: Fix lvfs-testing remote file
|
||||
|
||||
---
|
||||
data/remotes.d/meson.build | 12 +++++++-----
|
||||
1 file changed, 7 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/data/remotes.d/meson.build b/data/remotes.d/meson.build
|
||||
index 4ef0266f0..c20a1a05e 100644
|
||||
--- a/data/remotes.d/meson.build
|
||||
+++ b/data/remotes.d/meson.build
|
||||
@@ -1,9 +1,4 @@
|
||||
if build_standalone and get_option('lvfs') != 'false'
|
||||
- install_data([
|
||||
- 'lvfs-testing.conf',
|
||||
- ],
|
||||
- install_dir: join_paths(sysconfdir, 'fwupd', 'remotes.d')
|
||||
- )
|
||||
con3 = configuration_data()
|
||||
if get_option('lvfs') == 'disabled'
|
||||
con3.set('enabled', 'false')
|
||||
@@ -22,6 +17,13 @@ if build_standalone and get_option('lvfs') != 'false'
|
||||
install: true,
|
||||
install_dir: join_paths(sysconfdir, 'fwupd', 'remotes.d'),
|
||||
)
|
||||
+ configure_file(
|
||||
+ input: 'lvfs-testing.conf',
|
||||
+ output: 'lvfs-testing.conf',
|
||||
+ configuration: con3,
|
||||
+ install: true,
|
||||
+ install_dir: join_paths(sysconfdir, 'fwupd', 'remotes.d'),
|
||||
+ )
|
||||
i18n.merge_file(
|
||||
input: 'lvfs.metainfo.xml',
|
||||
output: 'org.freedesktop.fwupd.remotes.lvfs.metainfo.xml',
|
||||
--
|
||||
2.37.3
|
||||
|
@ -54,12 +54,13 @@
|
||||
Summary: Firmware update daemon
|
||||
Name: fwupd
|
||||
Version: 1.8.7
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/fwupd/fwupd
|
||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch0: 0001-trivial-Fix-the-tests-on-s390x.patch
|
||||
Patch1: 0001-trivial-Fix-the-tests-on-s390x.patch
|
||||
Patch2: 0001-trivial-Fix-lvfs-testing-remote-file.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
@ -430,6 +431,9 @@ done
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Nov 09 2022 Richard Hughes <richard@hughsie.com> 1.8.7-2
|
||||
- Fix the lvfs-testing remote
|
||||
|
||||
* Wed Nov 09 2022 Richard Hughes <richard@hughsie.com> 1.8.7-1
|
||||
- New upstream release
|
||||
- Add a new HSI check for the leaked Lenovo 'Key Manifest' hashes
|
||||
|
Loading…
Reference in New Issue
Block a user