New upstream release
This commit is contained in:
parent
d380a45596
commit
3952061456
1
.gitignore
vendored
1
.gitignore
vendored
@ -33,3 +33,4 @@
|
|||||||
/fwupd-1.0.1.tar.xz
|
/fwupd-1.0.1.tar.xz
|
||||||
/fwupd-1.0.2.tar.xz
|
/fwupd-1.0.2.tar.xz
|
||||||
/fwupd-1.0.3.tar.xz
|
/fwupd-1.0.3.tar.xz
|
||||||
|
/fwupd-1.0.4.tar.xz
|
||||||
|
39
0001-Do-not-use-the-CDN-when-getting-metadata.patch
Normal file
39
0001-Do-not-use-the-CDN-when-getting-metadata.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
From c1832f4a74177c39f3362b255d9d7127d02813f7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Richard Hughes <richard@hughsie.com>
|
||||||
|
Date: Thu, 25 Jan 2018 13:52:02 +0000
|
||||||
|
Subject: [PATCH] Do not use the CDN when getting metadata
|
||||||
|
|
||||||
|
We have a new server that can hopefully cope with the load.
|
||||||
|
---
|
||||||
|
data/remotes.d/lvfs-testing.conf | 2 +-
|
||||||
|
data/remotes.d/lvfs.conf | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/data/remotes.d/lvfs-testing.conf b/data/remotes.d/lvfs-testing.conf
|
||||||
|
index 75da08f1..dc4133a5 100644
|
||||||
|
--- a/data/remotes.d/lvfs-testing.conf
|
||||||
|
+++ b/data/remotes.d/lvfs-testing.conf
|
||||||
|
@@ -4,7 +4,7 @@
|
||||||
|
Enabled=false
|
||||||
|
Title=Linux Vendor Firmware Service (testing)
|
||||||
|
Keyring=gpg
|
||||||
|
-MetadataURI=https://s3.amazonaws.com/lvfsbucket/downloads/firmware-testing.xml.gz
|
||||||
|
+MetadataURI=https://fwupd.org/downloads/firmware-testing.xml.gz
|
||||||
|
ReportURI=https://fwupd.org/lvfs/firmware/report
|
||||||
|
Username=
|
||||||
|
Password=
|
||||||
|
diff --git a/data/remotes.d/lvfs.conf b/data/remotes.d/lvfs.conf
|
||||||
|
index 51d0f55e..b7dea262 100644
|
||||||
|
--- a/data/remotes.d/lvfs.conf
|
||||||
|
+++ b/data/remotes.d/lvfs.conf
|
||||||
|
@@ -4,6 +4,6 @@
|
||||||
|
Enabled=true
|
||||||
|
Title=Linux Vendor Firmware Service
|
||||||
|
Keyring=gpg
|
||||||
|
-MetadataURI=https://s3.amazonaws.com/lvfsbucket/downloads/firmware.xml.gz
|
||||||
|
+MetadataURI=https://fwupd.org/downloads/firmware.xml.gz
|
||||||
|
ReportURI=https://fwupd.org/lvfs/firmware/report
|
||||||
|
OrderBefore=fwupd
|
||||||
|
--
|
||||||
|
2.14.3
|
||||||
|
|
@ -1,100 +0,0 @@
|
|||||||
From 74fa2ca635a6b7263c58375d8588d8fd3fe16e43 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Richard Hughes <richard@hughsie.com>
|
|
||||||
Date: Wed, 10 Jan 2018 21:33:39 +0000
|
|
||||||
Subject: [PATCH] Fix firmware downloading using gnome-software compiled
|
|
||||||
against fwupd 1.0.x
|
|
||||||
|
|
||||||
Always set the AppStream app properties on the FwupdRelease. In some cases we
|
|
||||||
were returning FwupdRelease objects with no name or summary which gnome-software
|
|
||||||
was ignoring.
|
|
||||||
---
|
|
||||||
src/fu-engine.c | 21 ++++++++++++---------
|
|
||||||
src/fu-util.c | 12 ++++++++++++
|
|
||||||
2 files changed, 24 insertions(+), 9 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/fu-engine.c b/src/fu-engine.c
|
|
||||||
index ed4b893..8eb2d4d 100644
|
|
||||||
--- a/src/fu-engine.c
|
|
||||||
+++ b/src/fu-engine.c
|
|
||||||
@@ -218,6 +218,7 @@ fu_engine_device_changed_cb (FuDeviceList *device_list, FuDevice *device, FuEngi
|
|
||||||
static void
|
|
||||||
fu_engine_set_release_from_appstream (FuEngine *self,
|
|
||||||
FwupdRelease *rel,
|
|
||||||
+ AsApp *app,
|
|
||||||
AsRelease *release)
|
|
||||||
{
|
|
||||||
AsChecksum *csum;
|
|
||||||
@@ -225,6 +226,15 @@ fu_engine_set_release_from_appstream (FuEngine *self,
|
|
||||||
const gchar *tmp;
|
|
||||||
GBytes *remote_blob;
|
|
||||||
|
|
||||||
+ /* set from the AsApp */
|
|
||||||
+ fwupd_release_set_appstream_id (rel, as_app_get_id (app));
|
|
||||||
+ fwupd_release_set_homepage (rel, as_app_get_url_item (app, AS_URL_KIND_HOMEPAGE));
|
|
||||||
+ fwupd_release_set_license (rel, as_app_get_project_license (app));
|
|
||||||
+ fwupd_release_set_name (rel, as_app_get_name (app, NULL));
|
|
||||||
+ fwupd_release_set_summary (rel, as_app_get_comment (app, NULL));
|
|
||||||
+ fwupd_release_set_vendor (rel, as_app_get_developer_name (app, NULL));
|
|
||||||
+ fwupd_release_set_appstream_id (rel, as_app_get_id (app));
|
|
||||||
+
|
|
||||||
/* find the remote */
|
|
||||||
remote_blob = as_release_get_blob (release, "fwupd::RemoteId");
|
|
||||||
if (remote_blob != NULL) {
|
|
||||||
@@ -2058,13 +2068,7 @@ fu_engine_get_result_from_app (FuEngine *self, AsApp *app, GError **error)
|
|
||||||
fwupd_device_set_description (dev, as_app_get_description (app, NULL));
|
|
||||||
rel = fwupd_release_new ();
|
|
||||||
fwupd_release_set_trust_flags (rel, trust_flags);
|
|
||||||
- fwupd_release_set_homepage (rel, as_app_get_url_item (app, AS_URL_KIND_HOMEPAGE));
|
|
||||||
- fwupd_release_set_license (rel, as_app_get_project_license (app));
|
|
||||||
- fwupd_release_set_name (rel, as_app_get_name (app, NULL));
|
|
||||||
- fwupd_release_set_summary (rel, as_app_get_comment (app, NULL));
|
|
||||||
- fwupd_release_set_vendor (rel, as_app_get_developer_name (app, NULL));
|
|
||||||
- fwupd_release_set_appstream_id (rel, as_app_get_id (app));
|
|
||||||
- fu_engine_set_release_from_appstream (self, rel, release);
|
|
||||||
+ fu_engine_set_release_from_appstream (self, rel, app, release);
|
|
||||||
fwupd_device_add_release (dev, rel);
|
|
||||||
return g_steal_pointer (&dev);
|
|
||||||
}
|
|
||||||
@@ -2278,8 +2282,7 @@ fu_engine_get_releases_for_device (FuEngine *self, FuDevice *device, GError **er
|
|
||||||
g_autoptr(FwupdRelease) rel = fwupd_release_new ();
|
|
||||||
|
|
||||||
/* create new FwupdRelease for the AsRelease */
|
|
||||||
- fwupd_release_set_appstream_id (rel, as_app_get_id (app));
|
|
||||||
- fu_engine_set_release_from_appstream (self, rel, release);
|
|
||||||
+ fu_engine_set_release_from_appstream (self, rel, app, release);
|
|
||||||
|
|
||||||
/* invalid */
|
|
||||||
if (fwupd_release_get_uri (rel) == NULL)
|
|
||||||
diff --git a/src/fu-util.c b/src/fu-util.c
|
|
||||||
index b563832..970a6bb 100644
|
|
||||||
--- a/src/fu-util.c
|
|
||||||
+++ b/src/fu-util.c
|
|
||||||
@@ -901,6 +901,12 @@ fu_util_get_releases (FuUtilPrivate *priv, gchar **values, GError **error)
|
|
||||||
/* TRANSLATORS: section header for release version number */
|
|
||||||
fu_util_print_data (_("Version"), fwupd_release_get_version (rel));
|
|
||||||
|
|
||||||
+ /* TRANSLATORS: section header for the release name */
|
|
||||||
+ fu_util_print_data (_("Name"), fwupd_release_get_name (rel));
|
|
||||||
+
|
|
||||||
+ /* TRANSLATORS: section header for the release one line summary */
|
|
||||||
+ fu_util_print_data (_("Summary"), fwupd_release_get_summary (rel));
|
|
||||||
+
|
|
||||||
/* TRANSLATORS: section header for the remote the file is coming from */
|
|
||||||
fu_util_print_data (_("Remote"), fwupd_release_get_remote_id (rel));
|
|
||||||
|
|
||||||
@@ -1074,6 +1080,12 @@ fu_util_get_updates (FuUtilPrivate *priv, gchar **values, GError **error)
|
|
||||||
fu_util_print_data (_("Update Version"),
|
|
||||||
fwupd_release_get_version (rel));
|
|
||||||
|
|
||||||
+ /* TRANSLATORS: section header for the release name */
|
|
||||||
+ fu_util_print_data (_("Update Name"), fwupd_release_get_name (rel));
|
|
||||||
+
|
|
||||||
+ /* TRANSLATORS: section header for the release one line summary */
|
|
||||||
+ fu_util_print_data (_("Update Summary"), fwupd_release_get_summary (rel));
|
|
||||||
+
|
|
||||||
/* TRANSLATORS: section header for remote ID, e.g. lvfs-testing */
|
|
||||||
fu_util_print_data (_("Update Remote ID"),
|
|
||||||
fwupd_release_get_remote_id (rel));
|
|
||||||
--
|
|
||||||
2.14.3
|
|
||||||
|
|
31
fwupd.spec
31
fwupd.spec
@ -20,14 +20,14 @@
|
|||||||
|
|
||||||
Summary: Firmware update daemon
|
Summary: Firmware update daemon
|
||||||
Name: fwupd
|
Name: fwupd
|
||||||
Version: 1.0.3
|
Version: 1.0.4
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://github.com/hughsie/fwupd
|
URL: https://github.com/hughsie/fwupd
|
||||||
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# already upstream
|
# lets test this with rawhide and see how the server copes
|
||||||
Patch0: 0001-Fix-firmware-downloading-using-gnome-software-compil.patch
|
Patch0: 0001-Do-not-use-the-CDN-when-getting-metadata.patch
|
||||||
|
|
||||||
BuildRequires: docbook-utils
|
BuildRequires: docbook-utils
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -53,6 +53,7 @@ BuildRequires: gnutls-devel
|
|||||||
BuildRequires: gnutls-utils
|
BuildRequires: gnutls-utils
|
||||||
BuildRequires: meson
|
BuildRequires: meson
|
||||||
BuildRequires: help2man
|
BuildRequires: help2man
|
||||||
|
BuildRequires: json-glib-devel >= %{json_glib_version}
|
||||||
|
|
||||||
%if 0%{?have_uefi}
|
%if 0%{?have_uefi}
|
||||||
BuildRequires: python3 python3-cairo python3-gobject python3-pillow
|
BuildRequires: python3 python3-cairo python3-gobject python3-pillow
|
||||||
@ -120,7 +121,7 @@ Data files for installed tests.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .fix-gnome-software
|
%patch0 -p1 -b .no-cdn
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -189,11 +190,11 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
|||||||
%{_bindir}/fwupdmgr
|
%{_bindir}/fwupdmgr
|
||||||
%dir %{_sysconfdir}/fwupd
|
%dir %{_sysconfdir}/fwupd
|
||||||
%dir %{_sysconfdir}/fwupd/remotes.d
|
%dir %{_sysconfdir}/fwupd/remotes.d
|
||||||
%{_sysconfdir}/fwupd/remotes.d/fwupd.conf
|
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/fwupd.conf
|
||||||
%{_sysconfdir}/fwupd/remotes.d/lvfs.conf
|
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs.conf
|
||||||
%{_sysconfdir}/fwupd/remotes.d/lvfs-testing.conf
|
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/lvfs-testing.conf
|
||||||
%{_sysconfdir}/fwupd/remotes.d/vendor.conf
|
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/vendor.conf
|
||||||
%{_sysconfdir}/pki/fwupd
|
%config(noreplace)%{_sysconfdir}/pki/fwupd
|
||||||
%{_sysconfdir}/pki/fwupd-metadata
|
%{_sysconfdir}/pki/fwupd-metadata
|
||||||
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.fwupd.conf
|
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.fwupd.conf
|
||||||
%{_datadir}/fwupd/remotes.d/fwupd/metadata.xml
|
%{_datadir}/fwupd/remotes.d/fwupd/metadata.xml
|
||||||
@ -267,6 +268,16 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
|
|||||||
%{_datadir}/installed-tests/fwupd/*.py*
|
%{_datadir}/installed-tests/fwupd/*.py*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 25 2018 Richard Hughes <richard@hughsie.com> 1.0.4-1
|
||||||
|
- New upstream release
|
||||||
|
- Add a device name for locked UEFI devices
|
||||||
|
- Add D-Bus methods to get and modify the history information
|
||||||
|
- Allow the user to share firmware update success or failure
|
||||||
|
- Ask the user to refresh metadata when it is very old
|
||||||
|
- Never add two devices to the daemon with the same ID
|
||||||
|
- Rescan supported flags when refreshing metadata
|
||||||
|
- Store firmware update success and failure to a local database
|
||||||
|
|
||||||
* Fri Jan 12 2018 Richard Hughes <richard@hughsie.com> 1.0.3-2
|
* Fri Jan 12 2018 Richard Hughes <richard@hughsie.com> 1.0.3-2
|
||||||
- Backport a patch that fixes applying firmware updates using gnome-software.
|
- Backport a patch that fixes applying firmware updates using gnome-software.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (fwupd-1.0.3.tar.xz) = 82ac3c82b63f1dd73ea617b9dedeed97a1d60084f8b425c66b7998596189088f54c4bace468dd92d0b75f1260d436ee46262b79dbdbf759b522fa55a07dbd205
|
SHA512 (fwupd-1.0.4.tar.xz) = fb571a472f2a8fd8b3419f48389075f35046bade7af5e39b25403ce3f4a516423937b51e70452beeb66853993c6722c2171c35c8d8112760f8a8e8e5b7407a1a
|
||||||
|
Loading…
Reference in New Issue
Block a user