New upstream release

This commit is contained in:
Richard Hughes 2019-02-25 10:03:03 +00:00
parent f0ddfe4815
commit 222f238e47
4 changed files with 15 additions and 214 deletions

1
.gitignore vendored
View File

@ -47,3 +47,4 @@
/fwupd-1.2.2.tar.xz
/fwupd-1.2.3.tar.xz
/fwupd-1.2.4.tar.xz
/fwupd-1.2.5.tar.xz

206
fix.patch
View File

@ -1,206 +0,0 @@
diff --git a/meson.build b/meson.build
index da72f33f..73420d18 100644
--- a/meson.build
+++ b/meson.build
@@ -77,7 +77,7 @@ warning_flags = [
'-Wmissing-prototypes',
'-Wnested-externs',
'-Wno-cast-function-type',
- '-Wno-error=cpp',
+ '-Wno-address-of-packed-member', # incompatable with g_autoptr()
'-Wno-unknown-pragmas',
'-Wno-discarded-qualifiers',
'-Wno-missing-field-initializers',
diff --git a/plugins/uefi/efi/meson.build b/plugins/uefi/efi/meson.build
index dbccda03..5be2ffea 100644
--- a/plugins/uefi/efi/meson.build
+++ b/plugins/uefi/efi/meson.build
@@ -53,7 +53,6 @@ compile_args = ['-Og',
'--param=ssp-buffer-size=4',
'-fexceptions',
'-Wall',
- '-Werror',
'-Wextra',
'-Wvla',
'-std=gnu11',
@@ -66,10 +65,14 @@ compile_args = ['-Og',
'-fno-merge-constants',
'-Wsign-compare',
'-Wno-missing-field-initializers',
+ '-Wno-address-of-packed-member',
'-grecord-gcc-switches',
'-DDEBUGDIR="@0@"'.format(debugdir),
'-isystem', efi_incdir,
'-isystem', join_paths(efi_incdir, gnu_efi_path_arch)]
+if get_option('werror')
+ compile_args += '-Werror'
+endif
if efi_arch == 'x86_64'
compile_args += ['-mno-red-zone',
'-mno-sse',
commit 96e67839822d87be94372e204f24d9bf8672f4fb
Author: Richard Hughes <richard@hughsie.com>
Date: Fri Feb 1 16:47:03 2019 +0000
trivial: Fix potential compile failures for high -j values
diff --git a/plugins/ata/meson.build b/plugins/ata/meson.build
index cd26e395..7171e6b4 100644
--- a/plugins/ata/meson.build
+++ b/plugins/ata/meson.build
@@ -36,6 +36,7 @@ if get_option('tests')
cargs += '-DTESTDATADIR="' + testdatadir + '"'
e = executable(
'ata-self-test',
+ fu_hash,
sources : [
'fu-self-test.c',
'fu-ata-device.c',
diff --git a/plugins/dell/meson.build b/plugins/dell/meson.build
index df96b979..2c0532f1 100644
--- a/plugins/dell/meson.build
+++ b/plugins/dell/meson.build
@@ -37,6 +37,7 @@ if get_option('tests')
cargs += '-DPLUGINBUILDDIR="' + meson.current_build_dir() + '"'
e = executable(
'dell-self-test',
+ fu_hash,
sources : [
'fu-self-test.c',
'fu-dell-smi.c',
diff --git a/plugins/dfu/meson.build b/plugins/dfu/meson.build
index f9d9632d..fc517fcc 100644
--- a/plugins/dfu/meson.build
+++ b/plugins/dfu/meson.build
@@ -6,6 +6,7 @@ install_data(['dfu.quirk'],
dfu = static_library(
'dfu',
+ fu_hash,
sources : [
'dfu-cipher-xtea.c',
'dfu-common.c',
@@ -117,6 +118,7 @@ if get_option('tests')
cargs += '-DTESTDATADIR="' + testdatadir + '"'
e = executable(
'dfu-self-test',
+ fu_hash,
sources : [
'dfu-self-test.c'
],
diff --git a/plugins/nitrokey/meson.build b/plugins/nitrokey/meson.build
index 46911498..225b49b7 100644
--- a/plugins/nitrokey/meson.build
+++ b/plugins/nitrokey/meson.build
@@ -30,6 +30,7 @@ shared_module('fu_plugin_nitrokey',
if get_option('tests')
e = executable(
'nitrokey-self-test',
+ fu_hash,
sources : [
'fu-nitrokey-common.c',
'fu-self-test.c',
diff --git a/plugins/nvme/meson.build b/plugins/nvme/meson.build
index 614ccc60..5ec0a862 100644
--- a/plugins/nvme/meson.build
+++ b/plugins/nvme/meson.build
@@ -38,6 +38,7 @@ if get_option('tests')
cargs += '-DTESTDATADIR="' + testdatadir + '"'
e = executable(
'nvme-self-test',
+ fu_hash,
sources : [
'fu-self-test.c',
'fu-nvme-common.c',
diff --git a/plugins/redfish/meson.build b/plugins/redfish/meson.build
index a4cdba55..5c88504e 100644
--- a/plugins/redfish/meson.build
+++ b/plugins/redfish/meson.build
@@ -32,6 +32,7 @@ install_data(['redfish.conf'],
if get_option('tests')
e = executable(
'redfish-self-test',
+ fu_hash,
sources : [
'fu-self-test.c',
'fu-redfish-client.c',
diff --git a/plugins/synapticsmst/meson.build b/plugins/synapticsmst/meson.build
index 0f1abdbf..046ac6e4 100644
--- a/plugins/synapticsmst/meson.build
+++ b/plugins/synapticsmst/meson.build
@@ -35,6 +35,7 @@ if get_option('tests')
cargs += '-DSOURCEDIR="' + meson.current_source_dir() + '"'
e = executable(
'synapticsmst-self-test',
+ fu_hash,
sources : [
'fu-self-test.c',
'synapticsmst-common.c',
diff --git a/plugins/thunderbolt/meson.build b/plugins/thunderbolt/meson.build
index 10991e5b..c15e4d87 100644
--- a/plugins/thunderbolt/meson.build
+++ b/plugins/thunderbolt/meson.build
@@ -26,6 +26,7 @@ testdatadir_src = join_paths(meson.source_root(), 'data', 'tests')
testdatadir_dst = join_paths(meson.build_root(), 'data', 'tests')
cargs += '-DTESTDATADIR="' + testdatadir_src + ':' + testdatadir_dst + '"'
executable('tbtfwucli',
+ fu_hash,
sources : [
'fu-thunderbolt-tool.c',
],
@@ -50,6 +51,7 @@ if get_option('tests') and umockdev.found() and gio.version().version_compare('>
cargs += '-DPLUGINBUILDDIR="' + meson.current_build_dir() + '"'
e = executable(
'thunderbolt-self-test',
+ fu_hash,
sources : [
'fu-self-test.c',
'fu-plugin-thunderbolt.c',
diff --git a/plugins/udev/meson.build b/plugins/udev/meson.build
index 334b14a8..dfc05def 100644
--- a/plugins/udev/meson.build
+++ b/plugins/udev/meson.build
@@ -50,6 +50,7 @@ if get_option('tests')
cargs += '-DTESTDATADIR="' + testdatadir + '"'
e = executable(
'udev-self-test',
+ fu_hash,
sources : [
'fu-self-test.c',
'fu-rom.c',
diff --git a/plugins/uefi/meson.build b/plugins/uefi/meson.build
index 2492e4ec..fd1b3976 100644
--- a/plugins/uefi/meson.build
+++ b/plugins/uefi/meson.build
@@ -83,6 +83,7 @@ if get_option('tests')
cargs += '-DTESTDATADIR="' + testdatadir + '"'
e = executable(
'uefi-self-test',
+ fu_hash,
sources : [
'fu-self-test.c',
'fu-uefi-bgrt.c',
diff --git a/plugins/unifying/meson.build b/plugins/unifying/meson.build
index 7e04912d..f90d1fbf 100644
--- a/plugins/unifying/meson.build
+++ b/plugins/unifying/meson.build
@@ -39,6 +39,7 @@ shared_module('fu_plugin_unifying',
if get_option('tests')
e = executable(
'unifying-self-test',
+ fu_hash,
sources : [
'fu-unifying-self-test.c',
'fu-unifying-common.c',
diff --git a/plugins/wacom-usb/meson.build b/plugins/wacom-usb/meson.build
index e2a3f37c..fd92ed4b 100644
--- a/plugins/wacom-usb/meson.build
+++ b/plugins/wacom-usb/meson.build
@@ -38,6 +38,7 @@ if get_option('tests')
cargs += '-DTESTDATADIR="' + testdatadir + '"'
e = executable(
'wacom-usb-self-test',
+ fu_hash,
sources : [
'fu-self-test.c',
'fu-wac-common.c',

View File

@ -25,17 +25,13 @@
Summary: Firmware update daemon
Name: fwupd
Version: 1.2.4
Release: 2%{?dist}
Version: 1.2.5
Release: 1%{?dist}
License: LGPLv2+
URL: https://github.com/hughsie/fwupd
Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
# backport from master
Patch0: fix.patch
BuildRequires: gettext
BuildRequires: glibc-langpack-en
BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: libxmlb-devel >= %{libxmlb_version}
BuildRequires: libgcab1-devel
@ -55,7 +51,6 @@ BuildRequires: valgrind-devel
%endif
BuildRequires: elfutils-libelf-devel
BuildRequires: gtk-doc
BuildRequires: libuuid-devel
BuildRequires: gnutls-devel
BuildRequires: gnutls-utils
BuildRequires: meson
@ -240,6 +235,7 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
%{_datadir}/man/man1/dfu-tool.1.gz
%{_datadir}/man/man1/fwupdmgr.1.gz
%{_datadir}/metainfo/org.freedesktop.fwupd.metainfo.xml
%{_datadir}/icons/hicolor/scalable/apps/org.freedesktop.fwupd.svg
%{_datadir}/fwupd/firmware-packager
%{_unitdir}/fwupd-offline-update.service
%{_unitdir}/fwupd.service
@ -317,6 +313,16 @@ mkdir -p --mode=0700 $RPM_BUILD_ROOT%{_localstatedir}/lib/fwupd/gnupg
%config(noreplace)%{_sysconfdir}/fwupd/remotes.d/fwupd-tests.conf
%changelog
* Mon Feb 25 2019 Richard Hughes <richard@hughsie.com> 1.2.5-1
- New upstream release
- Allow a device to be updated using more than one plugin
- Call composite prepare and cleanup using fwupdtool
- Detect and special case Dell ATA hardware
- Fix flashing failure with latest Intuos Pro tablet
- Fix potential segfault when applying UEFI updates
- Fix unifying regression when recovering from failed flash
- Report the DeviceInstanceIDs from fwupdmgr when run as root
* Tue Feb 12 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.2.4-2
- Remove obsolete scriptlets

View File

@ -1 +1 @@
SHA512 (fwupd-1.2.4.tar.xz) = 340eb9d501c381ef65c115bfca2478274aeb140c4fb030034ae2b288e0a907ed865e3ee91bf5120ad6dc0087d91f5bcb524e4fa9b00b2d05f7b48db2912343d1
SHA512 (fwupd-1.2.5.tar.xz) = 7d34cc374effd0ba6dc20bd90cb5fa47586fe258d369b73afee531c2ffc56109661f1500a99cd2a0b7c4adf343e12fdb1eb31094fdea57074730e9c4132f52f3