Update to 3.6.2
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
parent
df7502bde9
commit
8dd17d138c
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/fuse-3.4.2.tar.gz
|
||||
/fuse-3.5.0.tar.gz
|
||||
/fuse-3.6.1.tar.gz
|
||||
/fuse-3.6.2.tar.gz
|
||||
|
@ -1,159 +0,0 @@
|
||||
From 1c8caf9fd542da587aa91a0dd7cc79f20925ab12 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Dykstra <2129743+DrDaveD@users.noreply.github.com>
|
||||
Date: Fri, 24 May 2019 10:38:24 -0500
|
||||
Subject: [PATCH 1/3] skip install parts that require root when non-root
|
||||
|
||||
---
|
||||
util/install_helper.sh | 13 +++++++------
|
||||
1 file changed, 7 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/util/install_helper.sh b/util/install_helper.sh
|
||||
index 688b2450..061b16b0 100755
|
||||
--- a/util/install_helper.sh
|
||||
+++ b/util/install_helper.sh
|
||||
@@ -22,16 +22,17 @@ else
|
||||
DESTDIR="${DESTDIR%/}"
|
||||
fi
|
||||
|
||||
-chown root:root "${DESTDIR}${bindir}/fusermount3"
|
||||
-chmod u+s "${DESTDIR}${bindir}/fusermount3"
|
||||
-
|
||||
install -D -m 644 "${MESON_SOURCE_ROOT}/util/fuse.conf" \
|
||||
"${DESTDIR}${sysconfdir}/fuse.conf"
|
||||
|
||||
+if [ `id -u` = 0 ]; then
|
||||
+ chown root:root "${DESTDIR}${bindir}/fusermount3"
|
||||
+ chmod u+s "${DESTDIR}${bindir}/fusermount3"
|
||||
|
||||
-if test ! -e "${DESTDIR}/dev/fuse"; then
|
||||
- mkdir -p "${DESTDIR}/dev"
|
||||
- mknod "${DESTDIR}/dev/fuse" -m 0666 c 10 229
|
||||
+ if test ! -e "${DESTDIR}/dev/fuse"; then
|
||||
+ mkdir -p "${DESTDIR}/dev"
|
||||
+ mknod "${DESTDIR}/dev/fuse" -m 0666 c 10 229
|
||||
+ fi
|
||||
fi
|
||||
|
||||
install -D -m 644 "${MESON_SOURCE_ROOT}/util/udev.rules" \
|
||||
|
||||
From 67ec3873e0eaddb5ebafed0f9f81f29e944e91ee Mon Sep 17 00:00:00 2001
|
||||
From: Dave Dykstra <2129743+DrDaveD@users.noreply.github.com>
|
||||
Date: Wed, 3 Jul 2019 13:32:12 -0500
|
||||
Subject: [PATCH 2/3] add no-root configure option
|
||||
|
||||
---
|
||||
meson_options.txt | 8 ++++++--
|
||||
util/install_helper.sh | 3 ++-
|
||||
util/meson.build | 10 +++++++++-
|
||||
3 files changed, 17 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index c08e38e4..c88b32d8 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -5,7 +5,11 @@ option('udevrulesdir', type : 'string', value : '',
|
||||
description: 'Where to install udev rules (if empty, query pkg-config(1))')
|
||||
|
||||
option('utils', type : 'boolean', value : true,
|
||||
- description: 'Wheter or not to build and install helper programs')
|
||||
+ description: 'Whether or not to build and install helper programs')
|
||||
|
||||
option('examples', type : 'boolean', value : true,
|
||||
- description: 'Wheter or not to build example programs')
|
||||
\ No newline at end of file
|
||||
+ description: 'Whether or not to build example programs')
|
||||
+
|
||||
+option('no-root', type : 'boolean', value : false,
|
||||
+ description: 'Install files without root permissions')
|
||||
+
|
||||
diff --git a/util/install_helper.sh b/util/install_helper.sh
|
||||
index 061b16b0..30f6227b 100755
|
||||
--- a/util/install_helper.sh
|
||||
+++ b/util/install_helper.sh
|
||||
@@ -9,6 +9,7 @@ set -e
|
||||
sysconfdir="$1"
|
||||
bindir="$2"
|
||||
udevrulesdir="$3"
|
||||
+useroot="$4"
|
||||
|
||||
# Both sysconfdir and bindir are absolute paths (since they are joined
|
||||
# with --prefix in meson.build), but need to be interpreted relative
|
||||
@@ -25,7 +26,7 @@ fi
|
||||
install -D -m 644 "${MESON_SOURCE_ROOT}/util/fuse.conf" \
|
||||
"${DESTDIR}${sysconfdir}/fuse.conf"
|
||||
|
||||
-if [ `id -u` = 0 ]; then
|
||||
+if $useroot; then
|
||||
chown root:root "${DESTDIR}${bindir}/fusermount3"
|
||||
chmod u+s "${DESTDIR}${bindir}/fusermount3"
|
||||
|
||||
diff --git a/util/meson.build b/util/meson.build
|
||||
index aa0e734a..d273ca8e 100644
|
||||
--- a/util/meson.build
|
||||
+++ b/util/meson.build
|
||||
@@ -20,9 +20,17 @@ if udevrulesdir == ''
|
||||
udevrulesdir = join_paths(udev.get_pkgconfig_variable('udevdir'), 'rules.d')
|
||||
endif
|
||||
|
||||
+noroot = get_option('no-root')
|
||||
+if noroot
|
||||
+ useroot = 'false'
|
||||
+else
|
||||
+ useroot = 'true'
|
||||
+endif
|
||||
+
|
||||
meson.add_install_script('install_helper.sh',
|
||||
join_paths(get_option('prefix'), get_option('sysconfdir')),
|
||||
join_paths(get_option('prefix'), get_option('bindir')),
|
||||
- udevrulesdir)
|
||||
+ udevrulesdir,
|
||||
+ useroot)
|
||||
|
||||
|
||||
|
||||
From 12cf86c8a512a50766e088c3fcca532883ad1e5f Mon Sep 17 00:00:00 2001
|
||||
From: Dave Dykstra <2129743+DrDaveD@users.noreply.github.com>
|
||||
Date: Wed, 3 Jul 2019 17:25:50 -0500
|
||||
Subject: [PATCH 3/3] make the option useroot instead of no-root
|
||||
|
||||
---
|
||||
meson_options.txt | 4 ++--
|
||||
util/meson.build | 9 +--------
|
||||
2 files changed, 3 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index c88b32d8..e778254c 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -10,6 +10,6 @@ option('utils', type : 'boolean', value : true,
|
||||
option('examples', type : 'boolean', value : true,
|
||||
description: 'Whether or not to build example programs')
|
||||
|
||||
-option('no-root', type : 'boolean', value : false,
|
||||
- description: 'Install files without root permissions')
|
||||
+option('useroot', type : 'boolean', value : true,
|
||||
+ description: 'Set owner and setuid bits on installed file')
|
||||
|
||||
diff --git a/util/meson.build b/util/meson.build
|
||||
index d273ca8e..5c8f1b58 100644
|
||||
--- a/util/meson.build
|
||||
+++ b/util/meson.build
|
||||
@@ -20,17 +20,10 @@ if udevrulesdir == ''
|
||||
udevrulesdir = join_paths(udev.get_pkgconfig_variable('udevdir'), 'rules.d')
|
||||
endif
|
||||
|
||||
-noroot = get_option('no-root')
|
||||
-if noroot
|
||||
- useroot = 'false'
|
||||
-else
|
||||
- useroot = 'true'
|
||||
-endif
|
||||
-
|
||||
meson.add_install_script('install_helper.sh',
|
||||
join_paths(get_option('prefix'), get_option('sysconfdir')),
|
||||
join_paths(get_option('prefix'), get_option('bindir')),
|
||||
udevrulesdir,
|
||||
- useroot)
|
||||
+ '@0@'.format(get_option('useroot')))
|
||||
|
||||
|
16
fuse3.spec
16
fuse3.spec
@ -1,15 +1,12 @@
|
||||
Name: fuse3
|
||||
Version: 3.6.1
|
||||
Release: 4%{?dist}
|
||||
Version: 3.6.2
|
||||
Release: 1%{?dist}
|
||||
Summary: File System in Userspace (FUSE) v3 utilities
|
||||
License: GPL+
|
||||
URL: http://fuse.sf.net
|
||||
Source0: https://github.com/libfuse/libfuse/archive/fuse-%{version}.tar.gz
|
||||
Source1: fuse.conf
|
||||
|
||||
# https://github.com/libfuse/libfuse/pull/421.patch
|
||||
Patch1: fuse3-0001-no-chown-root.patch
|
||||
|
||||
BuildRequires: which
|
||||
%if ! 0%{?el6}
|
||||
Conflicts: filesystem < 3
|
||||
@ -69,10 +66,8 @@ Common files for FUSE v2 and FUSE v3.
|
||||
%prep
|
||||
%setup -n libfuse-fuse-%{version}
|
||||
|
||||
%patch1 -p1 -b .no_chown_root
|
||||
|
||||
%build
|
||||
export LC_ALL=en_US.UTF-8
|
||||
export LC_ALL=en_US.UTF-8
|
||||
%if ! 0%{?_vpath_srcdir:1}
|
||||
%global _vpath_srcdir .
|
||||
%endif
|
||||
@ -85,7 +80,7 @@ export LC_ALL=en_US.UTF-8
|
||||
%endif
|
||||
%meson -D udevrulesdir=/etc/udev/rules.d
|
||||
%else
|
||||
%meson
|
||||
%meson
|
||||
%endif
|
||||
|
||||
(cd %{_vpath_builddir}
|
||||
@ -159,6 +154,9 @@ rm -f %{buildroot}/usr/lib/udev/rules.d/99-fuse3.rules
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Sep 1 2019 Peter Lemenkov <lemenkov@gmail.com> - 3.6.2-1
|
||||
- Update to 3.6.2
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.6.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fuse-3.6.1.tar.gz) = ed075777956efd67f67d33d893c5e7f8fdc879a614c49437ad27845bc20b01f1de0bd88c1916167e48f6d98905086457e02ab3404e713408fdd670976491dae3
|
||||
SHA512 (fuse-3.6.2.tar.gz) = 924d5c95bc7352fd5796a0ce8ccb2f2d9582dea3dfa3941603022d4f4914da8b5b80bf0b5915e7ac0e37a65068b4f7b7de862df1dc8663fe4d3cdf884ac84a65
|
||||
|
Loading…
Reference in New Issue
Block a user