update to 3.6.1-2, newer version of pr #421

This commit is contained in:
Dave Dykstra 2019-07-03 14:53:16 -05:00
parent 4190db0dac
commit 59477e2e27
2 changed files with 95 additions and 8 deletions

View File

@ -1,7 +1,7 @@
From 3b2c90d3d1c5cd0ba09d1379d791f6ec7ac07c3d Mon Sep 17 00:00:00 2001
From 1c8caf9fd542da587aa91a0dd7cc79f20925ab12 Mon Sep 17 00:00:00 2001
From: Dave Dykstra <2129743+DrDaveD@users.noreply.github.com>
Date: Fri, 24 May 2019 10:38:24 -0500
Subject: [PATCH] skip install parts that require root when non-root
Subject: [PATCH 1/2] skip install parts that require root when non-root
---
util/install_helper.sh | 13 +++++++------
@ -35,3 +35,78 @@ index 688b2450..061b16b0 100755
fi
install -D -m 644 "${MESON_SOURCE_ROOT}/util/udev.rules" \
From 67ec3873e0eaddb5ebafed0f9f81f29e944e91ee Mon Sep 17 00:00:00 2001
From: Dave Dykstra <2129743+DrDaveD@users.noreply.github.com>
Date: Wed, 3 Jul 2019 13:32:12 -0500
Subject: [PATCH 2/2] add no-root configure option
---
meson_options.txt | 8 ++++++--
util/install_helper.sh | 3 ++-
util/meson.build | 10 +++++++++-
3 files changed, 17 insertions(+), 4 deletions(-)
diff --git a/meson_options.txt b/meson_options.txt
index c08e38e4..c88b32d8 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -5,7 +5,11 @@ option('udevrulesdir', type : 'string', value : '',
description: 'Where to install udev rules (if empty, query pkg-config(1))')
option('utils', type : 'boolean', value : true,
- description: 'Wheter or not to build and install helper programs')
+ description: 'Whether or not to build and install helper programs')
option('examples', type : 'boolean', value : true,
- description: 'Wheter or not to build example programs')
\ No newline at end of file
+ description: 'Whether or not to build example programs')
+
+option('no-root', type : 'boolean', value : false,
+ description: 'Install files without root permissions')
+
diff --git a/util/install_helper.sh b/util/install_helper.sh
index 061b16b0..30f6227b 100755
--- a/util/install_helper.sh
+++ b/util/install_helper.sh
@@ -9,6 +9,7 @@ set -e
sysconfdir="$1"
bindir="$2"
udevrulesdir="$3"
+useroot="$4"
# Both sysconfdir and bindir are absolute paths (since they are joined
# with --prefix in meson.build), but need to be interpreted relative
@@ -25,7 +26,7 @@ fi
install -D -m 644 "${MESON_SOURCE_ROOT}/util/fuse.conf" \
"${DESTDIR}${sysconfdir}/fuse.conf"
-if [ `id -u` = 0 ]; then
+if $useroot; then
chown root:root "${DESTDIR}${bindir}/fusermount3"
chmod u+s "${DESTDIR}${bindir}/fusermount3"
diff --git a/util/meson.build b/util/meson.build
index aa0e734a..d273ca8e 100644
--- a/util/meson.build
+++ b/util/meson.build
@@ -20,9 +20,17 @@ if udevrulesdir == ''
udevrulesdir = join_paths(udev.get_pkgconfig_variable('udevdir'), 'rules.d')
endif
+noroot = get_option('no-root')
+if noroot
+ useroot = 'false'
+else
+ useroot = 'true'
+endif
+
meson.add_install_script('install_helper.sh',
join_paths(get_option('prefix'), get_option('sysconfdir')),
join_paths(get_option('prefix'), get_option('bindir')),
- udevrulesdir)
+ udevrulesdir,
+ useroot)

View File

@ -1,6 +1,6 @@
Name: fuse3
Version: 3.6.1
Release: 1%{?dist}
Release: 2%{?dist}
Summary: File System in Userspace (FUSE) v3 utilities
License: GPL+
URL: http://fuse.sf.net
@ -83,14 +83,22 @@ export LC_ALL=en_US.UTF-8
%if ! 0%{?__global_ldflags:1}
%global __global_ldflags ""
%endif
%meson -D udevrulesdir=/etc/udev/rules.d -D examples=false
(cd %{_vpath_builddir}
meson configure -D c_args=-I"`ls -d /usr/src/kernels/*/include|head -1`"
ninja-build reconfigure
)
%meson -D udevrulesdir=/etc/udev/rules.d
%else
%meson
%endif
(cd %{_vpath_builddir}
%if 0%{?el6}
meson configure -D c_args=-I"`ls -d /usr/src/kernels/*/include|head -1`"
%endif
%if 0%{?el6} || 0%{?el7}
meson configure -D examples=false
%endif
# don't have root for installation
meson configure -D no-root=true
ninja-build reconfigure
)
%meson_build
%install
@ -151,6 +159,10 @@ rm -f %{buildroot}/usr/lib/udev/rules.d/99-fuse3.rules
%endif
%changelog
* Wed Jul 03 2019 Dave Dykstra <dwd@fedoraproject.org> - 3.6.1-2
- Update to newer version of pr #421
- Disable building examples on el7
* Thu Jun 13 2019 Tom Callaway <spot@fedoraproject.org> - 3.6.1-1
- Update to 3.6.1