update to 3.6.1-3, final version of pr #421
This commit is contained in:
parent
59477e2e27
commit
0b21ff46e2
@ -1,7 +1,7 @@
|
||||
From 1c8caf9fd542da587aa91a0dd7cc79f20925ab12 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Dykstra <2129743+DrDaveD@users.noreply.github.com>
|
||||
Date: Fri, 24 May 2019 10:38:24 -0500
|
||||
Subject: [PATCH 1/2] skip install parts that require root when non-root
|
||||
Subject: [PATCH 1/3] skip install parts that require root when non-root
|
||||
|
||||
---
|
||||
util/install_helper.sh | 13 +++++++------
|
||||
@ -39,7 +39,7 @@ index 688b2450..061b16b0 100755
|
||||
From 67ec3873e0eaddb5ebafed0f9f81f29e944e91ee Mon Sep 17 00:00:00 2001
|
||||
From: Dave Dykstra <2129743+DrDaveD@users.noreply.github.com>
|
||||
Date: Wed, 3 Jul 2019 13:32:12 -0500
|
||||
Subject: [PATCH 2/2] add no-root configure option
|
||||
Subject: [PATCH 2/3] add no-root configure option
|
||||
|
||||
---
|
||||
meson_options.txt | 8 ++++++--
|
||||
@ -110,3 +110,50 @@ index aa0e734a..d273ca8e 100644
|
||||
+ useroot)
|
||||
|
||||
|
||||
|
||||
From 12cf86c8a512a50766e088c3fcca532883ad1e5f Mon Sep 17 00:00:00 2001
|
||||
From: Dave Dykstra <2129743+DrDaveD@users.noreply.github.com>
|
||||
Date: Wed, 3 Jul 2019 17:25:50 -0500
|
||||
Subject: [PATCH 3/3] make the option useroot instead of no-root
|
||||
|
||||
---
|
||||
meson_options.txt | 4 ++--
|
||||
util/meson.build | 9 +--------
|
||||
2 files changed, 3 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index c88b32d8..e778254c 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -10,6 +10,6 @@ option('utils', type : 'boolean', value : true,
|
||||
option('examples', type : 'boolean', value : true,
|
||||
description: 'Whether or not to build example programs')
|
||||
|
||||
-option('no-root', type : 'boolean', value : false,
|
||||
- description: 'Install files without root permissions')
|
||||
+option('useroot', type : 'boolean', value : true,
|
||||
+ description: 'Set owner and setuid bits on installed file')
|
||||
|
||||
diff --git a/util/meson.build b/util/meson.build
|
||||
index d273ca8e..5c8f1b58 100644
|
||||
--- a/util/meson.build
|
||||
+++ b/util/meson.build
|
||||
@@ -20,17 +20,10 @@ if udevrulesdir == ''
|
||||
udevrulesdir = join_paths(udev.get_pkgconfig_variable('udevdir'), 'rules.d')
|
||||
endif
|
||||
|
||||
-noroot = get_option('no-root')
|
||||
-if noroot
|
||||
- useroot = 'false'
|
||||
-else
|
||||
- useroot = 'true'
|
||||
-endif
|
||||
-
|
||||
meson.add_install_script('install_helper.sh',
|
||||
join_paths(get_option('prefix'), get_option('sysconfdir')),
|
||||
join_paths(get_option('prefix'), get_option('bindir')),
|
||||
udevrulesdir,
|
||||
- useroot)
|
||||
+ '@0@'.format(get_option('useroot')))
|
||||
|
||||
|
||||
|
@ -1,13 +1,13 @@
|
||||
Name: fuse3
|
||||
Version: 3.6.1
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: File System in Userspace (FUSE) v3 utilities
|
||||
License: GPL+
|
||||
URL: http://fuse.sf.net
|
||||
Source0: https://github.com/libfuse/libfuse/archive/fuse-%{version}.tar.gz
|
||||
Source1: fuse.conf
|
||||
|
||||
# https://github.com/libfuse/libfuse/pull/421
|
||||
# https://github.com/libfuse/libfuse/pull/421.patch
|
||||
Patch1: fuse3-0001-no-chown-root.patch
|
||||
|
||||
BuildRequires: which
|
||||
@ -96,7 +96,7 @@ meson configure -D c_args=-I"`ls -d /usr/src/kernels/*/include|head -1`"
|
||||
meson configure -D examples=false
|
||||
%endif
|
||||
# don't have root for installation
|
||||
meson configure -D no-root=true
|
||||
meson configure -D useroot=false
|
||||
ninja-build reconfigure
|
||||
)
|
||||
%meson_build
|
||||
@ -159,6 +159,9 @@ rm -f %{buildroot}/usr/lib/udev/rules.d/99-fuse3.rules
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jul 03 2019 Dave Dykstra <dwd@fedoraproject.org> - 3.6.1-3
|
||||
- Update to the final version of pr #421
|
||||
|
||||
* Wed Jul 03 2019 Dave Dykstra <dwd@fedoraproject.org> - 3.6.1-2
|
||||
- Update to newer version of pr #421
|
||||
- Disable building examples on el7
|
||||
|
Loading…
Reference in New Issue
Block a user